LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-11-2009, 01:43 PM   #1
new2nagios
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Rep: Reputation: 0
apache newbie/mrtg newbie (newbie to everything)


Hi I have been trying to get some basic info on a couple of things so I appologize if this sounds totally stupid

I have an apache web server up & running. If I go to my web browser and type in http://localhost/manual it brings up the man page for apache.

I am trying to get mrtg to work & part of the install process has this line:
"This example below will create an mrtg config file in /home/mrtg/cfg assuming this is a directory visible on your webserver"

EXAMPLE:
[root@dns sbin]# cfgmaker --global 'WorkDir: /home/httpd/mrtg' \
> --global 'Options[_]: bits,growright' \
> --output /home/mrtg/cfg/mrtg.cfg \
> community@router.abc.xyz


I have manually created the /home/mrtg/cfg directory so when I run config maker everthing appears to be working...


[root@dns sbin]# cd /usr/local/mrtg-2/bin/

[root@dns bin]# ./cfgmaker --global 'WorkDir: /home/httpd/mrtg' \
> --global 'Options[_]: bits,growright' \
> --output /home/mrtg/cfg/mrtg.cfg \
> Expxxxxxx08@65.205.xx.xxx
[root@dns bin]# env LANG=C ./mrtg /home/mrtg/cfg/mrtg.cfg
2009-12-11 12:03:12, Rateup WARNING: /usr/local/mrtg-2/bin/rateup Can't remove 65.205.xx.xxx_3.old updating log file
2009-12-11 12:03:13, Rateup WARNING: /usr/local/mrtg-2/bin/rateup Can't remove 65.205.xx.xxx_5.old updating log file

2009-12-11 12:03:13, Rateup WARNING: /usr/local/mrtg-2/bin/rateup Can't remove 65.205.xx.xxx_6.old updating log file

[root@dns bin]#
[root@dns sbin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [ OK ]

I also tried changing /home/mrtg/cfg to /var/www/mrtg (which I created)

My question is how do I make a directory visible on my webserver?

I read that .htaccess provides access. I have been reading the manual pages on getting started...but nothing appears to point me to anything conclusive. Also, I installed Nagios on this same server and its working too when I browse to http://localhost/nagios (someoone asked if nagios is running in /var/www/nagios) - but it is not I am not sure where nagios web is installed as I just followed nagios step-by-step instructions and viola it works!

I have no colleagues to ask about this and web forums are my only resource, I am sure this is something simple that I need to edit. I am familiar with vi and most command line utilities in unix so most things I do manually.

thanks for any help.
Em

BTW I am running Fedora 9
 
Old 12-12-2009, 04:50 AM   #2
Davno
Member
 
Registered: Mar 2004
Location: Montreal, Canada
Distribution: Mandriva 2010.2
Posts: 148

Rep: Reputation: 24
On a normal installation of Apache, your working directory would be /var/www/html
 
Old 12-14-2009, 03:25 AM   #3
centosboy
Senior Member
 
Registered: May 2009
Location: london
Distribution: centos5
Posts: 1,137

Rep: Reputation: 116Reputation: 116
Quote:
Originally Posted by new2nagios View Post
Hi I have been trying to get some basic info on a couple of things so I appologize if this sounds totally stupid

I have an apache web server up & running. If I go to my web browser and type in http://localhost/manual it brings up the man page for apache.

I am trying to get mrtg to work & part of the install process has this line:
"This example below will create an mrtg config file in /home/mrtg/cfg assuming this is a directory visible on your webserver"

EXAMPLE:
[root@dns sbin]# cfgmaker --global 'WorkDir: /home/httpd/mrtg' \
> --global 'Options[_]: bits,growright' \
> --output /home/mrtg/cfg/mrtg.cfg \
> community@router.abc.xyz


I have manually created the /home/mrtg/cfg directory so when I run config maker everthing appears to be working...


[root@dns sbin]# cd /usr/local/mrtg-2/bin/

[root@dns bin]# ./cfgmaker --global 'WorkDir: /home/httpd/mrtg' \
> --global 'Options[_]: bits,growright' \
> --output /home/mrtg/cfg/mrtg.cfg \
> Expxxxxxx08@65.205.xx.xxx
[root@dns bin]# env LANG=C ./mrtg /home/mrtg/cfg/mrtg.cfg
2009-12-11 12:03:12, Rateup WARNING: /usr/local/mrtg-2/bin/rateup Can't remove 65.205.xx.xxx_3.old updating log file
2009-12-11 12:03:13, Rateup WARNING: /usr/local/mrtg-2/bin/rateup Can't remove 65.205.xx.xxx_5.old updating log file

2009-12-11 12:03:13, Rateup WARNING: /usr/local/mrtg-2/bin/rateup Can't remove 65.205.xx.xxx_6.old updating log file

[root@dns bin]#
[root@dns sbin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [ OK ]

I also tried changing /home/mrtg/cfg to /var/www/mrtg (which I created)

My question is how do I make a directory visible on my webserver?

I read that .htaccess provides access. I have been reading the manual pages on getting started...but nothing appears to point me to anything conclusive. Also, I installed Nagios on this same server and its working too when I browse to http://localhost/nagios (someoone asked if nagios is running in /var/www/nagios) - but it is not I am not sure where nagios web is installed as I just followed nagios step-by-step instructions and viola it works!

I have no colleagues to ask about this and web forums are my only resource, I am sure this is something simple that I need to edit. I am familiar with vi and most command line utilities in unix so most things I do manually.

thanks for any help.
Em

BTW I am running Fedora 9


hi.

for default mrtg config, run rpm -qc mrtg, assuming you installed by rpm.
there is a default skeleton file that you can just edit normally in /var/www/mrtg
mrtg normally works out of the box for an install such as fedora 9.
you shouldnt need to make a directory visible. if you are using document root, add an index file in the directory. wrt mrtg, you would need to create a symlink to the name of the html page
example on my mrtg config, the default page is the hostname. you can see this page in the mrtg directory. i just create a link to index.html so i can view this page.
If you want to just browse the directory listing, this in a .htaccess file should do it -

Options +Indexes

wrt nagios, the conf file tells you where everything is and how it is set up..
this would normally be in /etc/httpd/conf.d/nagios.conf

Last edited by centosboy; 12-14-2009 at 03:30 AM.
 
Old 12-14-2009, 09:05 AM   #4
new2nagios
LQ Newbie
 
Registered: Aug 2009
Posts: 6

Original Poster
Rep: Reputation: 0
thanks to all who posted

Many thanks to everyone who replied to this post. All input was appreciated. I now have mrtg working with tweeking to be performed and I learned a bit more about apache in the process.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
security newbie, but not Linux newbie. advice on secure delete tools mattie_linux Linux - Security 19 08-15-2005 01:50 AM
newbie;I am a linux newbie who has installed slackware and have run into a few proble MollyJolly Slackware - Installation 6 06-01-2004 11:21 AM


All times are GMT -5. The time now is 02:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration