LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-29-2004, 08:54 PM   #1
einherjar
LQ Newbie
 
Registered: Nov 2003
Posts: 6

Rep: Reputation: 0
apache install problem- redhat enterprise


Hi all,

I have been installing a LAMP from source (I had problems with some of the rpms) and following these instructions.

Everything went smoothly till I tried to start apache. I got this error

Quote:
Syntax error on line 330 of /usr/local/apache/conf/httpd.conf

Invalid command 'Order', perhaps mis-spelled...
The section of the httpd.conf file its referring to looks like this

Quote:
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/usr/local/apache/htdocs">

#
# This may also be "None", "All", or any combination of "Indexes",
# "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
Options Indexes FollowSymLinks MultiViews

#
# This controls which options the .htaccess files in directories can
# override. Can also be "All", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"
#
AllowOverride None

#
# Controls who can get stuff from this server.
#
Order allow,deny # line 330 #
Allow from all
</Directory>
I found this possible solution. But when I try to execute 'configure' with --enable-access added (after doing a 'make clean') I get an error saying that "--with-apxs=/usr/local/apache/bin/apxs" is an invalid option. It definitely worked fine the first time I did it though!

So I guess I have two questions really. Whats up with the httpd.conf file and how can I execute ./configure with the new option?

The details of the setup are...

Redhat Enterprise 3
Apache 1.3.27
mysql 3.23.58
php 4.3.7

Many thanks for any help given
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Install Redhat Enterprise Linux 4, please help karlt78 Linux - Newbie 3 07-15-2009 06:13 PM
can not install Quake3 demo on Redhat Enterprise WS - 4 Ray-s1971 Linux - Games 5 03-03-2006 11:01 PM
Redhat Enterprise 3 - full install is needed. conm Linux - Software 2 07-02-2005 12:06 PM
RedHat Enterprise WS 3.0 Can't Install LinuxWha? Red Hat 3 01-20-2005 11:38 AM
Help with OCI8/PHP APACHE on Redhat enterprise AS 3.0 pdave Linux - Software 0 07-21-2004 11:12 AM


All times are GMT -5. The time now is 10:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration