LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-26-2002, 06:40 PM   #1
thePod
LQ Newbie
 
Registered: Jan 2002
Posts: 3

Rep: Reputation: 0
APACHE - HTTPD will not stay running


I have installed apache 2.0.35 on a slackware system (latest slak
release)...

i try starting apache by using the command /usr/local/apache2/apachectl start

and it appears to run fine..

./apachectl start: httpd started

but then i check all processes running on the system (ps -Aef) and nothing is there about httpd!

I get this error in the error_log file:

[emerg] (22)Invalid argument: Couldn't set permissions on cross-process lock

so then i added AcceptMutex flock to the httpd.conf file

this seems to work:

[notice] Apache 2.0.35 (Unix) configured -- resuming normal operations

but then spits out this error msg:

[alert] (22) Invalid Argument: setgid: unable to set group id to Group
4294967295
[alert] (22) Invalid Argument: setgid: unable to set group id to Group
4294967295
[alert] (22) Invalid Argument: setgid: unable to set group id to Group
4294967295
[alert] (22) Invalid Argument: setgid: unable to set group id to Group
4294967295
[alert] (22) Child 3267 returned a fatal error...
Apache is exiting!


??? any ideas??

thanks
 
Old 04-26-2002, 06:44 PM   #2
thePod
LQ Newbie
 
Registered: Jan 2002
Posts: 3

Original Poster
Rep: Reputation: 0
never mind i figured it out

changed group #-1 to group nogroup in the httpd.conf and it worked!

amazing what using the search function does
 
Old 04-15-2004, 10:27 PM   #3
xanderp123
LQ Newbie
 
Registered: Mar 2004
Posts: 2

Rep: Reputation: 0
HTTPD will not stay running: Change group #-1 to group nogroup

I just want to say that I had the exact same problem and couldn't figure out what was wrong until I came across this post - Thanks! It worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get my Squid to stay running? tdob Linux - Security 13 11-19-2005 04:01 PM
Haldaemon wont stay running RemusX2 Linux - Software 2 04-13-2005 06:19 PM
running httpd.conf without restarting apache mpower Linux - Newbie 3 03-16-2005 05:20 PM
dhcpd will not stay running scuzzman Linux - Networking 15 01-27-2005 10:34 AM
httpd chokes on ScriptAlias line in Apache httpd.conf lhoff Linux - Software 1 07-14-2003 10:32 PM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration