LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-11-2003, 05:02 AM   #1
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Rep: Reputation: 15
Unhappy Apache (httpd) 2.0 conf authentication problem HELP!!!


Hi people,

Man am I in a fix with Apache 2.0! I was a faithful little 1.3 user for quite some time and have now upgraded to version 2.0 with the release of RH9...

I am having some serious authentication control problems when using .htaccess files! I mean they work under 1.3 but not under 2.0.

What I seem to get is that I am prompted for the password on the protected directory... I enter the username and password three times and it gives me an access denied... - All you smart alecs jumping in and saying - you got the password wrong... I thought that too - changed it to a|a no chance of screwing up - but same result.

Need an Apache Guru to give me some detailed instructions on how to sort this out please... please... please...

<urls removed by author>
Distro: Redhat 9.0 (shrike)

Listen - even someone who has a working httpd.conf file for this version who is willing to share - would help so much..

FYI: I am an intermediate user who is more comfortable in shell than a GUI.

A thousand and one thanks...

Bleah (ed out) man

Last edited by bleah-man; 08-13-2003 at 03:14 AM.
 
Old 08-11-2003, 05:45 AM   #2
andrewlkho
Member
 
Registered: Jul 2003
Location: London
Posts: 548

Rep: Reputation: 30
Hey,
I'm sorry that I can't help with your problem, but all I can say is that I have had this problem before. There's nothing I hate more than apache http authorization. I've even had problems on 1.3.26 and 1.3.27 with this. I presume you're using basic authentication, just like I did, ..... yes, you are. Hm....all I can say is that I never found a way round this problem, so ended up using php to authenticate. I did have a niggling feeling that it was to do with the username/password combination I used, though.
 
Old 08-11-2003, 06:42 AM   #3
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Original Poster
Rep: Reputation: 15
Thanks for the sympathy ho_10... Know it must be possible though... Will continue banging head on hard surface.
 
Old 08-11-2003, 08:06 AM   #4
Cooner
Member
 
Registered: Jul 2003
Location: Hastings, MN. USA
Distribution: Ubuntu 10.xx
Posts: 109

Rep: Reputation: 15
Change
#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
AllowOverride None
AllowOverride AuthConfig
 
Old 08-11-2003, 08:29 AM   #5
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Original Poster
Rep: Reputation: 15
Thanks for that, tried exactly what you suggested and reposted my files so that progress can be seen:

<urls removed by author>

Still gives me the authentication error... Any more for any more.. All comments and suggestions welcome.

Last edited by bleah-man; 08-13-2003 at 03:14 AM.
 
Old 08-11-2003, 08:58 AM   #6
Cooner
Member
 
Registered: Jul 2003
Location: Hastings, MN. USA
Distribution: Ubuntu 10.xx
Posts: 109

Rep: Reputation: 15
You changed one to many lines. This default directive:
# First, we configure the "default" to be a very restrictive set of
# features.
#
<Directory />
Options FollowSymLinks
AllowOverride AuthConfig
</Directory>

should stay AllowOverride None
 
Old 08-11-2003, 10:19 AM   #7
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Original Poster
Rep: Reputation: 15
Thanks for all your help here... but apache 2.0 has another casualty - me! I'm going to go to 1.3 - I know I won't have as many headaches...

I just got through with qmail - so you can imagine I've had enough of 9's quirks without having to fiddle with apache 2.0 as well..
 
Old 08-12-2003, 11:50 PM   #8
uncue75
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Rep: Reputation: 0
I'm going down the same road that looks you have already traveled. I am installing qmail from qmailrocks.com. I'm have the exact same problems you are talking about with redhat 9.

please let post here if apache 1.3 fixed your problem.


thanks!
 
Old 08-13-2003, 12:15 AM   #9
HappyDude
Member
 
Registered: Jul 2003
Posts: 140

Rep: Reputation: 15
One recommendation, GET RH 8!!!! I personally cant stand RH 9, its too full of bugs and all that junk....
 
Old 08-13-2003, 03:13 AM   #10
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Original Poster
Rep: Reputation: 15
Lol... Yeah thanks guys.. I was a happy 7.4 (yes I have got that right) user - forced to have 9 from a dedicated server rental thing.

It's been a pain in the arse in terms of getting RH9 to behave with apache 1.3 but eventually it seems to be working.

lots of rpm -qa | grep <package> and rpm -e --nodeps <package>

Also need compat for RH 9 providing backwards compatibility to 7.3 packages... Seems to be working (limping til I've tweaked it)

Mail me if you want to and I'll put a HowTo together when I'm done. peter_AT_divisionbyzero.biz - funny how a morning's work can turn into 3 days aint it!

The bright spark who changed the C compiler need to spend a morning in a room with me alone - I'll bring the pliers and dental instuments!

Bleah
 
Old 08-13-2003, 01:38 PM   #11
uncue75
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Rep: Reputation: 0
just reloadded my box with RH 8. Still have same problem. well it's a little different this time. Instead of it not accpeting the password, it doesn't prompt for one at all.

I have the <directory> tag in the httpd.conf file and it is setup properly.

rpm -qa |grep httpd says:

2.0.40-8

I think I'm going to try RH 7.4
 
Old 08-13-2003, 02:16 PM   #12
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Original Poster
Rep: Reputation: 15
Listen - wait a while - a how to is going to be forthcoming - I've nearly finished this build - let me make sure that it's stable and I'll make a howto page for you guys to follow.
 
Old 08-17-2003, 10:49 PM   #13
uncue75
LQ Newbie
 
Registered: Aug 2003
Posts: 6

Rep: Reputation: 0
any luck getting it working??
 
Old 08-18-2003, 04:39 AM   #14
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Original Poster
Rep: Reputation: 15
Well - I sure have been banging my head - got the password auth working under RH9 with apache 1.3.x. Now SSL over port 443 doesn't work! Got a feeling it's the openSSL module.. if I can't make some symbolic links I'll have to think about downgrading that too.

Again - I will post something about what I did to get which results soon.. so others can learn from my mistakes.. lol. Just want this working right.
 
Old 08-18-2003, 10:04 AM   #15
bleah-man
Member
 
Registered: Nov 2002
Location: London UK
Distribution: RedHat 9
Posts: 58

Original Poster
Rep: Reputation: 15
Just looking at my other box now and thinking again (foolishly maybe) that I can make it work.. been reading..
http://mirror.mricon.com/qvcs-guide/qvcs-guide.html (for rh9)

Seems fairly comprehensive to me.. Let me know what you all think since I am going to be tied up in knots for the next few days.

Bleah
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache httpd.conf ilnli Linux - Software 9 01-11-2005 07:58 AM
Apache httpd.conf help BoardinBum Linux - Software 4 12-29-2004 01:59 PM
problem whith user authentication / httpd.conf elpapazuko Linux - Security 4 12-10-2004 10:10 AM
httpd chokes on ScriptAlias line in Apache httpd.conf lhoff Linux - Software 1 07-14-2003 11:32 PM
apache httpd.conf plisken Linux - Software 1 02-01-2003 03:01 PM


All times are GMT -5. The time now is 11:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration