LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-28-2003, 01:08 PM   #1
Teddy_Horse
Member
 
Registered: Aug 2003
Posts: 30

Rep: Reputation: 15
Angry Apache HELP! HelP! help...


This thing drives me crazy. Here you go with my problem.

1) I have Gallery installed (gallery.menalto.com). Runs perfectly under WinXP on a FAT32 drive. (path: /windows/D/webroot under linux)
2) I have the same under Linux (apache version 2.xx, PHP4 same as under Win) installed in a folder on my Linux HDD. (path: /webroot)
3) I told to gallery the location of the albums (where the files are stored) to be on /windows/D/webroot/albums. This way I can have the albums to be common under both systems so there is no need to reconfigure, copy etc.

OK. Now the funy part comes: the webpage runs, it can see the album but for certain actions (like login) it claims that apache has no rights in the /windows/D/webroot/albums directory! The message is the following:

-----------------
Error: albumDir: /windows/D/webroot/albums exists, but is not writeable by the webserver user. Try:
chown -R nobody /windows/D/webroot/albums

or if that doesn't work:
chmod -R 777 /windows/D/webroot/albums
-----------------

The FAT32 drive is mounted to be RW and all user can create folders for ie.

Damn what is wrong?

Thx, Teddy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail from Apache being rejected - Cannot route to sender apache@localhost.localdomain jimwillsher Linux - Networking 2 01-19-2006 01:41 AM
Apache 1.3.33 (debian built) and Apache SSL does not respond to the proper ports lqorg_user Linux - Networking 0 11-06-2005 05:11 PM
Strange apache trailing / problem - Slack-current, apache 1.3.33 vamp Linux - Networking 1 01-30-2005 08:28 PM
Apache Webserver 403 Forbidden Errors (User not in apache group?) Mankind75 Mandriva 4 07-08-2004 06:30 AM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 11:53 AM


All times are GMT -5. The time now is 10:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration