LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 12-02-2008, 11:31 AM   #1
osuyz
LQ Newbie
 
Registered: Dec 2008
Posts: 1

Rep: Reputation: 0
Apache and tomcat compete for port 443


Hi,

I am new to apache and tomcat. I am having this problem for days, if anyone could give me some suggestions, I will appreciate it.

I 've updated my tomcat to 6.0.18. And removed old tomcat5 using linux's software update/remove toolbox.

Before proceeding, I stopped httpd and tomcat.

1. If I start httpd first, and then start tomcat, I got error in catalina.out:
Dec 1, 2008 4:35:37 PM org.apache.catalina.startup.Catalina start
SEVERE: Catalina.start:
LifecycleException: service.getName(): "Catalina"; Protocol handler start failed: java.net.BindExceptio
n: Address already in use<null>:443
at org.apache.catalina.connector.Connector.start(Connector.java:1138)
at org.apache.catalina.core.StandardService.start(StandardService.java:531)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
Dec 1, 2008 4:35:37 PM org.apache.catalina.startup.Catalina start



2. If I start tomcat first, then httpd, I got error on STDOUT:

[root@oscnet221 idp]# /sbin/service httpd start
Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:443
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
[FAILED]


Could anyone give some ideas what went wrong?

Thanks!

osuyz
 
Old 12-02-2008, 11:40 AM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,102

Rep: Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719Reputation: 2719
Quote:
Originally Posted by osuyz View Post
Hi,

I am new to apache and tomcat. I am having this problem for days, if anyone could give me some suggestions, I will appreciate it.

I 've updated my tomcat to 6.0.18. And removed old tomcat5 using linux's software update/remove toolbox.

Before proceeding, I stopped httpd and tomcat.
The problem is that you had one of the services configured before, to use a different port. Since you upgraded, the config file probably went back to the default. You'll have to change either your Tomcat or Apache to use a different port. Chances are the old Tomcat used a different port, since you removed it before installing the new. Check your old config file (if you still have it), or change the port to a different one.
 
Old 12-02-2008, 03:52 PM   #3
rg.viza
Member
 
Registered: Aug 2006
Posts: 73

Rep: Reputation: 15
the usual https port for tomcat is 8443.

http://tomcat.apache.org/tomcat-4.1-doc/ssl-howto.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Automatic Redirects from port 80 to port 443 with bundled Apache server kaplan71 Fedora 1 12-28-2007 09:30 AM
Apache Port 443 Verbal Kint Linux - Software 0 10-04-2005 04:07 AM
apache mod_ssl not using port 443 davidsrsb Slackware 8 06-07-2005 11:33 AM
FAVICON with apache server at port 443 doesn't seem 2 work ganninu Linux - General 0 12-21-2003 04:58 AM
Apache won't answer on Port 80, but will on 443 KevinJ Linux - Software 10 02-04-2003 09:10 PM


All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration