LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 01-12-2003, 03:20 PM   #1
dkc_ace
Member
 
Registered: Dec 2002
Distribution: freeBSD 4.9/6.0
Posts: 194

Rep: Reputation: 30
apache and permissions


ok i am having a problem with apache and permissions. well i moved the home dir of apache to my 80gb hdd. /hdb1/hdb1/html/
and well if u go to http://dkc1.dnsq.org/notshow/ it will say permissions denyed but if u go to http://dkc1.dnsq.org/notshow/smaller.jpg the picture will show fine but its in the dir notshow.

p.s will i have a problem with hosting .php sites or mysql stuff sense i moved the home dir to a diffrent hard drive.?
 
Old 01-12-2003, 05:44 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 194Reputation: 194
What's the permissions of notshow ? Do you have an index file in there ? If not, you probably just have directory indexing turned off so poeple cant see the directory listing.
 
Old 01-12-2003, 09:15 PM   #3
dkc_ace
Member
 
Registered: Dec 2002
Distribution: freeBSD 4.9/6.0
Posts: 194

Original Poster
Rep: Reputation: 30
i belive its 755 im not sure on the # though.

user= (show entries) (write entrties) (enter)
group=(show entries) (enter)
others= (show entries) (enter)

when i have the files in the /var/www/html it works fine. but when i point it to /hdb1/hdb1/html it dont work.

does it matter who and what group has ownership on the notshow dir? right now ace=user and group = root

i set the the folder permissions the same in the /var/www/html dir but that dont work either.
 
Old 01-12-2003, 11:10 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 194Reputation: 194
What's your output of:

ls -al /hdb1/hdb1/html

That would give us the permissions listing.

Also, do you have a index type file in the html directory your trying to put your files to ?
 
Old 01-13-2003, 08:24 AM   #5
dkc_ace
Member
 
Registered: Dec 2002
Distribution: freeBSD 4.9/6.0
Posts: 194

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by trickykid
What's your output of:

ls -al /hdb1/hdb1/html

That would give us the permissions listing.

Also, do you have a index type file in the html directory your trying to put your files to ?
im not sure what u mean by index file type. then only file i have in the notshow dir is that .jpg.

total 28
drwxrwxr-x 4 root ace 4096 .
drwxr-xr-x 4 root root 16384 ..
drwxr-xr-x 2 ace root 4096 notshow
drwxr-xr-x 2 ace root 4096 ut2k3gamefiles

Last edited by dkc_ace; 01-13-2003 at 08:25 AM.
 
Old 01-13-2003, 08:34 AM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Yeah, so what Tricky is saying is you have no index file. You need to create something like index.html and this will be the default page the users see when they go to yoursite.com.

For example, when you go to www.masterc.no-ip.org all you see in the url is that, however it's bring up my index.html

Cool
 
Old 01-13-2003, 09:03 AM   #7
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 194Reputation: 194
Thank you for clarifying that MasterC.

Like I mentioned before, if you don't have a index.html file, it won't display a directory listing of files that you have in that directory.

You most likely have directory indexing or listing disabled. I believe this option is under the <directory> section of your httpd.conf file.

Last edited by trickykid; 01-13-2003 at 09:06 AM.
 
Old 01-13-2003, 10:02 AM   #8
dkc_ace
Member
 
Registered: Dec 2002
Distribution: freeBSD 4.9/6.0
Posts: 194

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by trickykid
Thank you for clarifying that MasterC.

Like I mentioned before, if you don't have a index.html file, it won't display a directory listing of files that you have in that directory.

You most likely have directory indexing or listing disabled. I believe this option is under the <directory> section of your httpd.conf file.
umm i cant seem to find the httpd.conf file i looked in /etc but couldnt find it. only one i found was in /etc/http/ conf or someting like that. but none of them would show up in kate or pico. i was su.

i guess i found it.

ummmm i cant have listening disabled (or do i) bc when i move the dir back to the old one or default dir /var/www/html it works purfectly fine. but when i change it to /hdb1/hdb1/html and restart the service it stops working. when its in /var/www/html/ works just how li want it to work.

Last edited by dkc_ace; 01-13-2003 at 10:44 AM.
 
Old 01-13-2003, 09:59 PM   #9
dkc_ace
Member
 
Registered: Dec 2002
Distribution: freeBSD 4.9/6.0
Posts: 194

Original Poster
Rep: Reputation: 30
here is my conf file. http://dkc1.dnsq.org/notshow/configfile
 
Old 01-14-2003, 09:46 AM   #10
dkc_ace
Member
 
Registered: Dec 2002
Distribution: freeBSD 4.9/6.0
Posts: 194

Original Poster
Rep: Reputation: 30
anyone? If u need any more info pls ask.
 
Old 01-14-2003, 11:47 AM   #11
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
I really don't know... What is in /var/www/html (is this the actual directory?)?

I read your config file, maybe you need to create an index.html file, but I don't what that would do...

Hmm, I just tried it on mine, no problem. I simply moved my index.html to index.html.old and it brought up a directory listing...

I'm gonna search around a bit and see if I can find anything for ya.

Cool
 
Old 01-14-2003, 11:48 AM   #12
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
btw, this file (httpd.conf) is in /etc/apache on my system, I don't know if it differs from distro to distro...

Cool
 
Old 01-14-2003, 11:53 AM   #13
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Looking through my config, I would think these sections might be of some help (I'm running Apache 1.3, 2.0 might be different..):
Code:
# DirectoryIndex: Name of the file or files to use as a pre-written HTML
# directory index.  Separate multiple entries with spaces.
#
<IfModule mod_dir.c>
    DirectoryIndex index.html
</IfModule>
Code:
# This may also be "None", "All", or any combination of "Indexes",
# "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
    Options Indexes FollowSymLinks MultiViews
These are all down after the <Drectory> option.

Cool
 
Old 01-14-2003, 07:06 PM   #14
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Ok, just lookin over your config file, try using full path to your DocumentRoot:

Code:
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "hdb1/hdb1/html"
So if it's /mnt/hdb1/hdb1/html for the path (which is a VERY odd path btw..) then don't forget the first /

Then restart apache:
apachectl restart

Cool

<further down as well, edit the same thing, add the full path, including />

Last edited by MasterC; 01-14-2003 at 07:10 PM.
 
Old 01-14-2003, 08:52 PM   #15
dkc_ace
Member
 
Registered: Dec 2002
Distribution: freeBSD 4.9/6.0
Posts: 194

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by MasterC
Ok, just lookin over your config file, try using full path to your DocumentRoot:

Code:
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "hdb1/hdb1/html"
So if it's /mnt/hdb1/hdb1/html for the path (which is a VERY odd path btw..) then don't forget the first /

Then restart apache:
apachectl restart

Cool

<further down as well, edit the same thing, add the full path, including />
nope didnt do a thing.

only thing diffrent i did was restart the httpd server threw the gui.

p.s the dir is there bc of the partitions im sure u knew that. :P

Last edited by dkc_ace; 01-14-2003 at 09:37 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache permissions RedHatCore Linux - Software 4 08-25-2005 11:35 PM
Apache permissions doing... nothing? wrbob Linux - Software 5 08-22-2005 08:46 AM
Apache permissions haze Linux - Newbie 1 04-15-2005 03:22 PM
Apache Permissions Canadian_2k2 Linux - Networking 4 12-02-2002 01:51 PM
apache permissions, maybe? roadie Linux - General 4 06-14-2001 09:52 AM


All times are GMT -5. The time now is 07:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration