LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 08-19-2005, 09:23 PM   #1
Red Squirrel
Member
 
Registered: Dec 2003
Distribution: FC9 on main server
Posts: 820

Rep: Reputation: 36
apache acting weird


I think I may have posted this before but the solution only worked termporary.

When I shut down the server, apache tries to resolve all the virtual hosts, for some dumb reason, but since the DNS is turned off before apache, it can't, so it just sits there on each host waiting about 15 minutes or whatever the rediculusly long default tcp time out is. So when you've got a UPS giving you 5 minutes toshut down and the server starts waiting for no reason, it's a big problem. The solution was to make it so DNS stops after apache, but even then, it probably resets itself back to how it was, so it's not a permanent fix. It still does it. Is there a way to stop apachy from doing this? There's no reason why it needs to resolve any hosts, it's shutting down anyway!

Same with when it starts, it does the same, I just want it to start, and I don't care if it can't resove them or not. Once everything is done loading, everything works, and that's what counts. Remote reboots don't seem to cause an issue as I'll sometimes reboot the server and it takes only a few minutes for it to come back. But being able to shut down fast is crucial for my setup.
 
Old 08-19-2005, 09:43 PM   #2
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
Have you tried setting:

HostnameLookups off

in your apache config file? What version are you using? Everything 1.3 and newer should default to off.

slight
 
Old 08-19-2005, 09:47 PM   #3
Red Squirrel
Member
 
Registered: Dec 2003
Distribution: FC9 on main server
Posts: 820

Original Poster
Rep: Reputation: 36
Hmm I'll have to try that. Using 1.3 I think.

Edit: It's actually apache2... hmm never knew I got that to work in debian with php, I thought I tried and it did not work. I think it's my evil apt-get update that did that, it also gave me the unstable version of debian, and stuff has been going bad since then.

That line did not do anything, is there a specific place I have to put it? I just sticked it near the start of the file. But the debian apache2 package is messed up, it's all weird and stuff. httpd.conf is just redirecting to apache2.conf, and the virtual hosts are actually all seperate files.

Last edited by Red Squirrel; 08-19-2005 at 10:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vi Editor acting weird thom Fedora 1 06-19-2004 02:15 PM
Radeon acting weird... r_jensen11 Linux - Hardware 9 05-09-2004 02:41 AM
apache acting weird... Red Squirrel Linux - Newbie 1 03-03-2004 09:29 PM
Apache acting weird with index pages BlurredWeasel Linux - Software 1 11-30-2003 02:05 PM
IPCHAINS is acting weird Snabber Linux - Networking 11 08-08-2003 11:07 AM


All times are GMT -5. The time now is 09:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration