LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-31-2003, 10:13 PM   #1
im1crazyassmofo
Member
 
Registered: Jan 2003
Distribution: Slackware 13
Posts: 89

Rep: Reputation: 15
apache 2


first of all im ver mad cuz im stupid...i cant get apache 2.0.44 to work i did the
./configure
make
make install
and then when i try to do an apachectl start it gives me this crap:

bash-2.05b# apachectl start
/usr/sbin/httpd: line 50: ServerRoot: command not found
/usr/sbin/httpd: line 55: syntax error near unexpected token `newline'
/usr/sbin/httpd: line 55: `<IfModule !mpm_winnt.c>'
/usr/sbin/apachectl start: httpd could not be started

does anyone know what im doing wrong
 
Old 03-31-2003, 10:40 PM   #2
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Where is your httpd.conf? Is it the one from your previous version?
 
Old 03-31-2003, 10:53 PM   #3
im1crazyassmofo
Member
 
Registered: Jan 2003
Distribution: Slackware 13
Posts: 89

Original Poster
Rep: Reputation: 15
it is in the dir where the source code is and it is aslo in /usr/sbin
 
Old 04-01-2003, 06:36 PM   #4
TimeSaver
LQ Newbie
 
Registered: Mar 2003
Posts: 12

Rep: Reputation: 0
Your Apache is getting installed in the same directory as your previous version and having conflicts.

Try cleaning up the build tree. (may be delete it all and unzip again)

To configure do this:

$ ./configure --prefix=/wwwroot --enable-so

where /wwwroot is the new path where u want your apache or it could be something else like /apache or /webserver or /httpd

Then do make and make install.

Before doing all this, I would delete all the apache and httpd folders and files from my machine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail from Apache being rejected - Cannot route to sender apache@localhost.localdomain jimwillsher Linux - Networking 2 01-19-2006 01:41 AM
Apache 1.3.33 (debian built) and Apache SSL does not respond to the proper ports lqorg_user Linux - Networking 0 11-06-2005 05:11 PM
Strange apache trailing / problem - Slack-current, apache 1.3.33 vamp Linux - Networking 1 01-30-2005 08:28 PM
Apache Webserver 403 Forbidden Errors (User not in apache group?) Mankind75 Mandriva 4 07-08-2004 06:30 AM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 11:53 AM


All times are GMT -5. The time now is 12:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration