LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-25-2004, 04:15 PM   #1
MrFixit
Member
 
Registered: Aug 2004
Posts: 32

Rep: Reputation: 15
Exclamation amule crash at first run, please help.


ive installed amule on my suse 9.1 system (after installing the wxbase, wxgtk1 and libcryptopp all compiled with gtk1 from -suser-gbv/rpms/SuSE_9.1/)
the installation went fine, but when i first ran it i got a message about amule copying xmule's config files.
in this point i should say ive installed xmule prior to installing amule - but since everytime i clicked on the connect button it crashed i uninstalled it...
after this message i got from amule, nothing happened.. i tried running it again, this time from the console to see what error message it produces.
and i got this:
Quote:
Initialising aMule
Config:
x1: 0 y1: 0 x2: 0 y2: 0
split read, found : 0
srv_split read, found : 0
External connections disabled in .eMule

OOPS! - Seems like aMule crashed
--== BACKTRACE FOLLOWS: ==--

[0] amule(_ZN9CamuleApp16OnFatalExceptionEv+0x41) [0x81dd9f1]
[1] /usr/local/lib/libwx_gtk-2.4.so.0(wxFatalSignalHandler+0x2b) [0x403e08db]
[2] [0xffffe420]
[3] amule(_ZN9CamuleDlg13CreateSystrayERK8wxString+0x6b) [0x81e908b]
[4] amule(_ZN9CamuleApp6OnInitEv+0x1680) [0x81e1370]
[5] /usr/local/lib/libwx_gtk-2.4.so.0(_Z7wxEntryiPPc+0x240) [0x4023f590]
[6] amule(main+0x1b) [0x81e24ab]
[7] /lib/tls/libc.so.6(__libc_start_main+0xe0) [0x40a4a4b0]
[8] amule(_ZN16wxScrolledWindow16AdjustScrollb****v+0xd1) [0x8091391]
Aborted
after uninstalling everything and following exactly the instructions on
amule.org (installation HOWTO)
(choosing the RPM way, so i could uninstall it with ease on YAST)
ive tried to run it again and got this error:
Quote:
Initialising aMule
Config:
x1: 0 y1: 0 x2: 0 y2: 0
split read, found : 0
srv_split read, found : 0
External connections disabled in .eMule

OOPS! - Seems like aMule crashed
--== BACKTRACE FOLLOWS: ==--

[0] amule(_ZN9CamuleApp16OnFatalExceptionEv+0x3a) [0x81bc16a]
[1] /usr/lib/libwx_gtk-2.4.so.0(wxFatalSignalHandler+0x26) [0x40397f42]
[2] [0xffffe420]
[3] amule(_ZN9CamuleDlg13CreateSystrayERK8wxString+0x69) [0x81c6b39]
[4] amule(_ZN9CamuleApp6OnInitEv+0x143a) [0x81bf4da]
[5] /usr/lib/libwx_gtk-2.4.so.0(_Z7wxEntryiPPc+0x1f9) [0x40233091]
[6] amule(main+0x17) [0x81c05c7]
[7] /lib/tls/libc.so.6(__libc_start_main+0xe0) [0x409f04b0]
[8] amule(_ZN18wxBaseArrayPtrVoidD2Ev+0x31) [0x8090bd1]
Aborted
now ive uninstalled amule 1.8.2 and gave the 2.0.0-rc5 a try...
got this one:
Quote:
Initialising aMule
Userhash loaded: 791E84BFF30E5AD8955618793A686FA5
*** UDP socket at 4665
*** TCP socket at 4662
*** UDP socket at 4672
No cryptkey.dat found, creating

OOPS! - Seems like aMule crashed
--== BACKTRACE FOLLOWS: ==--

[0] amule(_ZN9CamuleApp16OnFatalExceptionEv+0xcc) [0x825d25c]
[1] /usr/lib/libwx_gtk-2.4.so.0(wxFatalSignalHandler+0x26) [0x40398f42]
[2] [0xffffe420]
[3] /usr/lib/libwx_gtk-2.4.so.0(_ZN12wxEvtHandler16SearchEventTableER12wxEventTableR7wxEvent+0xb6) [0x402cee62]
[4] /usr/lib/libwx_gtk-2.4.so.0(_ZN12wxEvtHandler12ProcessEventER7wxEvent+0x83) [0x402cec8f]
[5] /usr/lib/libwx_gtk-2.4.so.0(_ZN11wxTimerBase6NotifyEv+0x6f) [0x4035a867]
[6] /usr/lib/libwx_gtk-2.4.so.0(timeout_callback+0x28) [0x4027796c]
[7] /opt/gnome/lib/libglib-1.2.so.0 [0x4065d8e3]
[8] /opt/gnome/lib/libglib-1.2.so.0 [0x4065dfbb]
[9] /opt/gnome/lib/libglib-1.2.so.0 [0x4065e8b7]
[10] /opt/gnome/lib/libglib-1.2.so.0(g_main_run+0x3f) [0x4065e98f]
[11] /opt/gnome/lib/libgtk-1.2.so.0(gtk_main+0xbf) [0x40563c4f]
[12] /usr/lib/libwx_gtk-2.4.so.0(_ZN8wxDialog9ShowModalEv+0x89) [0x4024dc21]
[13] amule(_ZN9CamuleDlg17changeDesktopModeEv+0x12e) [0x8268b5e]
[14] amule(_ZN9CamuleDlg13CreateSystrayERK8wxString+0x59) [0x8268c99]
[15] amule(_ZN9CamuleDlgC1EP8wxWindow8wxString7wxPoint6wxSize+0x672) [0x8269412]
[16] amule(_ZN9CamuleApp6OnInitEv+0x25fb) [0x8261bab]
[17] /usr/lib/libwx_gtk-2.4.so.0(_Z7wxEntryiPPc+0x1f9) [0x40234091]
[18] amule(main+0x17) [0x82624d7]
[19] /lib/tls/libc.so.6(__libc_start_main+0xe0) [0x409f14b0]
[20] amule(_ZN16wxScrolledWindow16AdjustScrollbarsEv+0xad) [0x8120b91]
Aborted
now i have no clue... maybe its xmule's fault? (even though ive uninstalled it prior to installing amule)
how do i delete the configures, and make amule start with fresh config files?
or maybe its something else?
id appriciate any kind of help.
 
Old 08-25-2004, 04:39 PM   #2
thebover
Member
 
Registered: Jul 2004
Location: Canada
Distribution: suse 9.1/knoppix/slackware
Posts: 60

Rep: Reputation: 15
hehe i suppose you don't want to hear i had amule up and running just by following the info on amules site.

did u install as a user or as root?
are you trying to run it as root?

what are the permissions on the dir, that you installed amule to?
 
Old 08-25-2004, 04:51 PM   #3
MrFixit
Member
 
Registered: Aug 2004
Posts: 32

Original Poster
Rep: Reputation: 15
ive installed as root, and ran as normal user.
just like the instructions on the amule site... (the RPM way)
had no errors when ive installed it..
doesnt the RPM configure the right permissions automatically?
i have no idea where the files are and their permissions...
 
Old 08-25-2004, 05:12 PM   #4
thebover
Member
 
Registered: Jul 2004
Location: Canada
Distribution: suse 9.1/knoppix/slackware
Posts: 60

Rep: Reputation: 15
hmm if i remember rightly i got the tarball and installed it to my users home dir and ran from there.. RPMs i find are nice, but very decieving.
 
Old 08-26-2004, 07:33 PM   #5
MrFixit
Member
 
Registered: Aug 2004
Posts: 32

Original Poster
Rep: Reputation: 15
ok, got the tar, opened it to /home/downloads/amule
make install
(as user)
now i get this error:
Quote:
make[1]: Entering directory `/home/mrfixit/downloads/shit/aMule-2.0.0rc5'
Making all in m4
make[2]: Entering directory `/home/mrfixit/downloads/shit/aMule-2.0.0rc5/m4'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/mrfixit/downloads/shit/aMule-2.0.0rc5/m4'
Making all in intl
make[2]: Entering directory `/home/mrfixit/downloads/shit/aMule-2.0.0rc5/intl'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/mrfixit/downloads/shit/aMule-2.0.0rc5/intl'
Making all in po
make[2]: Entering directory `/home/mrfixit/downloads/shit/aMule-2.0.0rc5/po'
rm -f en_GB.gmo && : -c --statistics -o en_GB.gmo en_GB.po
mv: cannot stat `t-en_GB.gmo': No such file or directory
make[2]: *** [en_GB.gmo] Error 1
make[2]: Leaving directory `/home/mrfixit/downloads/shit/aMule-2.0.0rc5/po'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mrfixit/downloads/shit/aMule-2.0.0rc5'
make: *** [all] Error 2

what is this t-en_GB.gmo?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some services run in foreground but not as daemons after a crash. 3Dave Slackware 12 12-02-2005 09:19 AM
Totem and VLC crash and will not run timswim78 Linux - Software 3 03-03-2005 10:16 PM
amule crash ! need help! novkhan Linux - Software 9 05-10-2004 10:20 PM
xmms crash xine crash mplayer crash paledread Linux - Software 9 03-09-2004 08:09 AM
hard crash after 20 mins. every time on first boot reboot and it will run ok bejamin1 Mandriva 5 02-02-2004 01:42 PM


All times are GMT -5. The time now is 04:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration