LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-29-2002, 04:57 AM   #1
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
AMSN conflicts with xmms


I'm running Mandrake 8.2 with the xmms from the c.d and when i try running amsn (alvaros msn messenger) those 2 programs hang till i kill one of them, and i noticed that it was because of sound, now in alvaro you can set what command is used to play sound and all it is, is 'play' does anyone know how i can stop these two from conflicting....
 
Old 09-29-2002, 05:04 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
try using a different output in xmms, a rpoerp sound server like esd, or arts. maybe you can do the same in amsn
 
Old 09-29-2002, 05:17 AM   #3
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
how would i change it on amsn, cuz i have just found out that it's just not xmms, but any other sound producing program eg. noatun (kde media player)

currently the output for sound on amsn in 'play' would i change it to 'arts' or something along those lines ?
 
Old 09-29-2002, 05:35 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
no idea, never touched amsn. if it's possible it should be in it's docs.
 
Old 09-29-2002, 05:52 AM   #5
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
hmmm tried replacing 'play' with arts, now no sound comes out, no conflicts hahahaha, but i need it to alert me when i get a message, so i still need a way for the sound, anyone else can help ?
 
Old 09-29-2002, 05:59 AM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Well play is exactly that, it plays sounds. To use it, open up a term, locate a wav file, and type:
play /path/to/wav/file.wav

And it will play. So I guess man play might produce something, or possibly man sox as well.

Cool
 
Old 09-29-2002, 06:19 AM   #7
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
so how could i sed amsn to use a different output of sound? instead of 'play; because that must be what xmms or all my other music playing programs are using, am i making sense ?

(so so so many problems) BUT I LOVE IT heheheh
 
Old 09-29-2002, 06:34 AM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Well they aren't all necessarily using 'play' to produce sound. But the problem may lie in the ability of your soundcard. Check into half duplex and full duplex. Although I remember someone saying that the difference is in recording and playing at the same time rather than 2 things using the card at the same time for output, so I don't know if that'll help.

Try doing all this in another window manager, like flux or e or something. Try the same setup, xmms and amsn. What I am thinking is that your sound server (as suggested by Acid) might be your limitation right now. At least if you can figure that out, then you have somewhere to go.

Cool
 
Old 09-29-2002, 06:59 AM   #9
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
hmmmm what is this full duplex and half duplex stuff, and also, i can play two mp3's at the same time ? So whats that mean....
 
Old 09-29-2002, 07:05 AM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Probably nothing, as I said I remember someone telling me it had to do with recording during playback, so it probably doesn't have any baring here. Sorry for mentioning it as I was just 'typing aloud'.

Did you try another wm yet?
 
Old 09-29-2002, 07:13 AM   #11
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
i don't have another one installed, i will try and install it in a sec.....i'm looking for a new mobile fone or as americans call it a cell fone hehehe..well so does my home country indonesia...

Just a question, switching wm's, what does that have to do with the sound? can you shed some light on this ?

Last edited by GT I.N.C; 09-29-2002 at 07:15 AM.
 
Old 09-29-2002, 07:29 AM   #12
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I am assuming you are using KDE as this is mandy's default.

KDE starts the arts sound daemon. Other's use esd or e sound daemon. And so on. So by switching wm, we will effectively kill arts.

You could try to adjust it if you'd like now. Go to your CP and locate sound. The settings should be around that area. See what you can find.

Anyway, yeah, this is what I am thinking.

I call em mobile phones too. Cell phones to me are like the late 80's jobs that are big bulky junkers.

Cool
 
Old 09-29-2002, 07:48 AM   #13
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Original Poster
Rep: Reputation: 30
All i found in the CP in the sound area about arts is the option to start it when KDE starts up and also this thing that says Display message using artsmessage....hmm thats about it...maybe its in the I/O tab...it has an option to use custom sound device...maybe something could go there....
 
Old 09-29-2002, 07:57 AM   #14
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Maybe, but you could have it NOT start up with KDE and then see what happens with that...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
amsn profile being used by another amsn session aeruzcar Linux - Software 2 01-28-2006 02:23 PM
Arts...XMMS conflicts redhatrosh Linux - Software 7 05-28-2005 10:31 PM
ALSA w/ XMMS : No PCM control in xmms Astro Slackware 1 08-08-2004 11:19 PM
Xmms Plugin 1.2.8 [xmms-config problem] MDMA Mandriva 2 01-29-2004 09:55 AM
red hat 9 xmms and nvidia driver-xmms ronss Red Hat 3 09-26-2003 08:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration