LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-17-2003, 11:08 AM   #1
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Americas Army In Gentoo


I emerged americas-army in Gentoo. When I run 'armyops' its gets to the splash screen and then spits this out:

ioctl SETFRAGMENT grab: Invalid argument
armyops-bin: al_mixer.c:735: _alSetMixer: Assertion `mixbuf.data' failed.

Developer Backtrace:
[ 1] ./armyops-bin [0x846ffd1]
[ 2] /lib/libpthread.so.0 [0x40025fea]
[ 3] /lib/libc.so.6 [0x40128358]
[ 4] /lib/libpthread.so.0(raise+0x2b) [0x400238eb]
[ 5] /lib/libc.so.6(gsignal+0x42) [0x40128002]
[ 6] /lib/libc.so.6(abort+0x17c) [0x401298dc]
[ 7] /lib/libc.so.6 [0x401218e5]
[ 8] ./openal.so(_alSetMixer+0x20d) [0x434af939]
Signal: SIGIOT [iot trap]
Aborting.

hmmm...I checked the Gentoo forums with no luck. Any ideas what this is all about? I can't get armyops to run.

Woops! I totally forgot their is a Games Forum in here. Sorry mods.

Last edited by Crashed_Again; 11-17-2003 at 11:45 AM.
 
Old 11-17-2003, 03:24 PM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Original Poster
Rep: Reputation: 57
Problem solved! The only hint I had from that error message was the 'al_mixer' line. I figured it was some sort of sound issue. After installing alsa and recompiling my modules it starts right up with no problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Americas Army carlosinfl Linux - Games 6 07-23-2005 09:17 PM
Americas army... kerryh8er04 Linux - Games 5 10-13-2004 10:46 PM
Americas-Army Robert0380 Linux - Games 18 12-01-2003 04:09 PM
americas army bm1 Linux - Games 1 11-25-2003 06:28 PM
Americas Army MrJBot Linux - Newbie 1 10-25-2003 11:58 PM


All times are GMT -5. The time now is 09:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration