LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   AMD 6870 *2 graphics cards HOT using open source catalyst drivers (http://www.linuxquestions.org/questions/linux-software-2/amd-6870-%2A2-graphics-cards-hot-using-open-source-catalyst-drivers-941823/)

ratman1 04-26-2012 06:09 AM

AMD 6870 *2 graphics cards HOT using open source catalyst drivers
 
Hi

I have been distro hopping for the past few months, and have decided to try Fedora 16 this time. I have been having issues with my graphics cards (two AMD 6870 cards) becoming very hot with the open source radeon drivers, and it has happened in ubunt, arch and now fedora.

I just left Arch linux, due to breaking it for the fourth time trying to get the proprietary catalyst drivers to work. Using lm_sensors, I noticed that the first card would idle at 68 degrees C, and the second at 64 degrees C. I then managed to get the proprietary catalyst drivers installed, and the temps dropped to idling around 34 degrees C. However, I soon broke arch... seems I am not up to it yet ;)

I then installed fedora, and after a update, I straight away installed lm_sensors to check the temperatures. 64 degrees C again!

I am wondering if I am over reacting to the temperatures and they are in fact normal, or whether it is a concern and I should install the proprietary drivers. 68/64 C seems too hot to be normal!

If I should install the proprietary drivers, is there any links or wiki pages that detail how to do it on fedora 16, because the only ones I could find were for earlier versions from a couple of years ago.

Thanks in advance,
James

TobiSGD 04-26-2012 07:47 AM

The free radeon drivers still have issues with the power-management. Complains to AMD please, they rather add new features to the free drivers than fixing issues.

colorpurple21859 04-26-2012 08:16 AM

With the open source driver both video cards are most likley powered at the same time. I had a similar situation with my laptop with ubuntu and added this entry
Quote:

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
to /etc/rc.local to turn the descrete graphics card off. Here is a reference for help.
the running kernel in ubuntu doesn't play nice with my discrete card, but changes have been added to the 3.3 kernel and going to try it on my slackware install in the next few days.

adamk75 04-26-2012 11:50 AM

ratman1, have you enabled any of the power management features of the radeon driver?

http://wiki.x.org/wiki/radeonBuildHo...wer-management

ratman1 04-27-2012 07:13 AM

Quote:

Originally Posted by adamk75 (Post 4663685)
ratman1, have you enabled any of the power management features of the radeon driver?

http://wiki.x.org/wiki/radeonBuildHo...wer-management

I just tried your link and selected the "dynpm" profile, however upon reboot the /sys/class/drm/card0/device/power_profile file always reverts back to containing "default".

Is there a way to set it to contain "dynpm" permenantly? It always reverts upon reboot. I tried putting it in /etc/rc.local however that did not seem to do the trick.

adamk75 04-27-2012 07:16 AM

No, those changes will not stick between reboots. I don't know why it wouldn't work by putting it in /etc/rc.local, but you will either have to figure out how to add this to your system start up, or manually switch profiles.

Adam

ratman1 04-27-2012 07:18 AM

Woops, sorry, I did a bit of incorrect copying and pasting...

I mean, I set /sys/class/drm/card0/device/power_method to contain "dynpm", and it always reverts back to "profile". Sorry!

Hmmm... I will try and google around to find a way to put it in startup


All times are GMT -5. The time now is 07:03 AM.