LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-17-2005, 03:40 AM   #1
jaakkop
Member
 
Registered: Aug 2004
Posts: 433

Rep: Reputation: 30
amarok wont start in Slackware


I installed amarok using the package from linuxpackages.net. I then installed the musicbrainz libraries from source. Now when I started amarok, I got the wizard and got somethings configured until it closed. I tried to start it in konsole but it gave me this:
Code:
amaroK: [Loader] Starting amarokapp..
amaroK: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
amarok: BEGIN: App::App()
amarok:   BEGIN: EngineBase* EngineController::loadEngine(const QString&)
amarok:     [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 5 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] != 'void-engine' and [X-KDE-amaroK-rank] > 0
amarok:     [PluginManager] Plugin trader constraint: [X-KDE-amaroK-framework-version] == 5 and [X-KDE-amaroK-plugintype] == 'engine' and [X-KDE-amaroK-name] == 'void-engine' and [X-KDE-amaroK-rank] > 0
amarok:     [PluginManager] Trying to load: libamarok_void-engine_plugin
amarok:
amarok:     PluginManager Service Info:
amarok:     ---------------------------
amarok:     name                          : <no engine>
amarok:     library                       : libamarok_void-engine_plugin
amarok:     desktopEntryPath              : amarok_void-engine_plugin.desktop
amarok:     X-KDE-amaroK-plugintype       : engine
amarok:     X-KDE-amaroK-name             : void-engine
amarok:     X-KDE-amaroK-authors          : (Max Howell,Mark Kretschmann)
amarok:     X-KDE-amaroK-rank             : 1
amarok:     X-KDE-amaroK-version          : 1
amarok:     X-KDE-amaroK-framework-version: 5
amarok:
QObject::connect: Cannot connect Engine::Base::statusText( const QString& ) to (null)::shortMessage( const QString& )
QObject::connect: Cannot connect Engine::Base::infoMessage( const QString& ) to(null)::longMessage( const QString& )
amarok:   END__: EngineBase* EngineController::loadEngine(const QString&) - Took 0.02s
amarokapp: symbol lookup error: amarokapp: undefined symbol: _ZN11KSystemTray9setPixmapERK7QPixmap
What is this? How can I fix this?
 
Old 07-17-2005, 05:16 AM   #2
markey
LQ Newbie
 
Registered: Jan 2005
Posts: 7

Rep: Reputation: 0
That's a binary incompatibility issue. In other words: Your amaroK package was made for a different kdelibs/qt version.

Get another package or build amaroK from source. We recommend using the latest 1.3-beta2 release.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I am a newbie and I really like the Amarok media p but it wont play kiam Linux - Newbie 4 07-09-2005 01:51 PM
amaroK Fails to Start ShoCkwave Slackware 2 04-11-2005 07:01 AM
x wont start on slackware berrance Linux - Laptop and Netbook 2 11-28-2004 12:31 PM
x wont start on slackware berrance Linux - Laptop and Netbook 2 11-28-2004 12:02 PM
slackware wont start xquizit Slackware 9 09-13-2004 12:57 PM


All times are GMT -5. The time now is 11:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration