LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-16-2007, 11:47 AM   #1
wolfger
LQ Newbie
 
Registered: Oct 2006
Distribution: Ubuntu - Feisty Fawn
Posts: 25
Blog Entries: 3

Rep: Reputation: 15
[solved] Amarok won't load Ogg Vorbis files to mp3 player?


Normally I just use my mp3 player for listening to podcasts, but today I decided to load some music on there, because I just can't concentrate on a podcast and do productive work at the same time. I used Amarok's "smart playlists" to grab 50 random songs from my collection and put them in my playlist, then I moved the playlist to the transfer queue, then I hit the transfer button. Only 3 songs made it to the player, and Amarok reported "47 tracks not playable on media device."
I'm betting this has something to do with the fact that most of my songs are in Ogg format rather than MP3 format (the ones that were MP3s made it onto the device), but my player is Ogg capable. I've played Oggs on it before with no problem. Seems Amarok is just being stupid. Anybody have any ideas?

Last edited by wolfger; 03-16-2007 at 10:55 PM.
 
Old 03-16-2007, 03:14 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
Are you using the xine engine in your Amarok configuration? If so, was xine built with ogg support?
 
Old 03-16-2007, 03:42 PM   #3
wolfger
LQ Newbie
 
Registered: Oct 2006
Distribution: Ubuntu - Feisty Fawn
Posts: 25
Blog Entries: 3

Original Poster
Rep: Reputation: 15
I can't answer that question until I get home, but let me point out that I can *play* oggs in Amarok with no problem. I can transfer oggs to my mp3 player (using Konqueror) with no problem. The only problem is in transferring oggs to my mp3 player with Amarok.
 
Old 03-16-2007, 03:46 PM   #4
MQMan
Member
 
Registered: Jan 2004
Location: Los Angeles
Distribution: Slack64 13.37
Posts: 536

Rep: Reputation: 36
Maybe you've hit the same problem that I did.

Quick edit: I am using the xine engine. And I have other oggs that play just fine.

Cheers.

Last edited by MQMan; 03-16-2007 at 03:47 PM.
 
Old 03-16-2007, 03:58 PM   #5
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
What mp3 player are you using, and what media device plugin in Amarok?
 
Old 03-16-2007, 05:41 PM   #6
wolfger
LQ Newbie
 
Registered: Oct 2006
Distribution: Ubuntu - Feisty Fawn
Posts: 25
Blog Entries: 3

Original Poster
Rep: Reputation: 15
Software info:
libxine1 1.1.2-1mepis1
libvorbis0a 1.1.2-0ubuntu2
Amarok 2:1.4.3-0ubuntu8~dapper1

If I try to uninstall libvorbis0a, Synaptic package manager insists on uninstalling libxine1 as well, so I assume libxine is compiled with ogg support.

Device info:
[17260238.132000] Vendor: SORELL Model: SF SERIES Rev: 1.00
[17260238.132000] Type: Direct-Access ANSI SCSI revision: 00
[17260238.144000] SCSI device sde: 513024 512-byte hdwr sectors (263 MB)
[17260238.152000] sde: Write Protect is off
Amarok plugin is "Generic Audio Player"

I try to play 02_eat_the_rich.ogg and it plays fine.
I drag-n-drop from the playlist to the media device browser, and it appears in my transfer queue.
I click transfer, I get an error.
Here is the console output:
Code:
amarok: BEGIN: ScanController::ScanController(CollectionDB*, bool, const QStringList&)
amarok: BEGIN: void ScanController::initIncremental()
amarok: END__: void ScanController::initIncremental() - Took 0.061s
amarok: END__: ScanController::ScanController(CollectionDB*, bool, const QStringList&) - Took 0.061s
amarok: BEGIN: virtual void ThreadWeaver::Thread::run()
amarok: BEGIN: virtual bool ScanController::doJob()
amarok: BEGIN: SqliteConnection::SqliteConnection(const SqliteConfig*)
amarok: END__: SqliteConnection::SqliteConnection(const SqliteConfig*) - Took 0.00048s
amarok: END__: virtual bool ScanController::doJob() - Took 0.00077s
amarok:   [CollectionDB] JobFinishedEvent from Incremental ScanController received.
amarok:   [ThreadWeaver] Job completed: CollectionScanner. Jobs pending: 0
amarok: BEGIN: virtual ScanController::~ScanController()
amarok: END__: virtual ScanController::~ScanController() - Took 0.00018s
amarok: END__: virtual void ThreadWeaver::Thread::run() - Took 0.0059s
amarok: BEGIN: ScanController::ScanController(CollectionDB*, bool, const QStringList&)
amarok: BEGIN: void ScanController::initIncremental()
amarok: END__: void ScanController::initIncremental() - Took 0.06s
amarok: END__: ScanController::ScanController(CollectionDB*, bool, const QStringList&) - Took 0.06s
amarok: BEGIN: virtual void ThreadWeaver::Thread::run()
amarok: BEGIN: virtual bool ScanController::doJob()
amarok: BEGIN: SqliteConnection::SqliteConnection(const SqliteConfig*)
amarok: END__: SqliteConnection::SqliteConnection(const SqliteConfig*) - Took 0.0006s
amarok: END__: virtual bool ScanController::doJob() - Took 0.00089s
amarok:   [CollectionDB] JobFinishedEvent from Incremental ScanController received.
amarok:   [ThreadWeaver] Job completed: CollectionScanner. Jobs pending: 0
amarok: BEGIN: virtual ScanController::~ScanController()
amarok: END__: virtual ScanController::~ScanController() - Took 0.00022s
amarok: END__: virtual void ThreadWeaver::Thread::run() - Took 0.0062s
 
Old 03-16-2007, 06:48 PM   #7
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
Have you configured the generic media player plugin to handle ogg files? See this tutorial.
 
Old 03-16-2007, 10:54 PM   #8
wolfger
LQ Newbie
 
Registered: Oct 2006
Distribution: Ubuntu - Feisty Fawn
Posts: 25
Blog Entries: 3

Original Poster
Rep: Reputation: 15
Thank you! That was it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Easy way to convert OGG Vorbis to mp3 on Fedora Antarctica Linux - Software 13 10-23-2007 08:45 PM
Cannot play Ogg Vorbis files in KDE Wynd Slackware 13 10-19-2006 06:53 PM
Playing ogg vorbis files in ipod chandan Linux - Software 7 01-02-2006 02:52 PM
converting ogg vorbis to mp3 Samoth Linux - Software 3 11-28-2005 08:05 PM
Ogg Vorbis portable music player coming! macewan General 1 05-25-2003 05:27 PM


All times are GMT -5. The time now is 09:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration