LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Amarok wants to use camera & flash-drive (http://www.linuxquestions.org/questions/linux-software-2/amarok-wants-to-use-camera-and-flash-drive-571935/)

amcleod 07-24-2007 01:34 PM

Amarok wants to use camera & flash-drive
 
I recently installed Slackware 12.0 with a 2.6.21.5 kernel, and started using Amarok instead of XMMS (which doesn't seem to come with Slack any more).

Amarok seems to work OK, but whenever I plug in my camera or USB flash drive, or put a CD in the drive, Amarok pops up an annoying dialog box, asking me what it should do with the drive. If I am not careful how I respond, this can lead to Amarok crashing.

I never play music from my camera or USB stick, and only rarely play CDs. Is there some way to tell Amarok to IGNORE these devices unless I specifically tell it to use them? (Slack 12 uses HAL and messagebus (D-BUS) which I am only now trying to understand. I think these may be involved.)

Thanks...

hollywoodb 07-24-2007 04:05 PM

Are you sure it is Amarok that is doing it? KDE has a mechanism for dealing with newly plugged in devices (comes with HAL support) that does this type of thing. You can adjust the settings for each type of device in KDE Control Center -> Peripherals.

AGazzaz 07-24-2007 07:07 PM

i do not have any removable media right now but i think you should take a look at
settings>configure amarok>media devices

amcleod 07-24-2007 08:25 PM

Quote:

Originally Posted by hollywoodb
Are you sure it is Amarok that is doing it? KDE has a mechanism for dealing with newly plugged in devices (comes with HAL support) that does this type of thing.

I've just tried it again. The dialog box says

Quote:

Manage Devices and Plugins - Amarok
Name: sdc1 (Detail) Plugin: [Do not handle] [>][Remove]
[Autodetect Devices][Add Device]
[Ok][Cancel]
Sorry, but it isn't easy to describe. But it's definately Amarok.

KDE also pops up, but that is another issue that I have to get to the bottom of.

Oh, wait! I left the pulldown at [Do not handle] and clicked [Ok]. Then when i tried it again, it did not pop up the dialog box! I'll shut down Amarok and restart it to see if the behaviour is persistent. Right after this album!

BTW, Settings->Configure Amarok->Media Devices shows an empty list.


All times are GMT -5. The time now is 03:57 PM.