Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-30-2005, 08:06 PM   #1
Registered: Dec 2004
Location: USA
Distribution: Gentoo Linux
Posts: 41

Rep: Reputation: 15
amarok-svn configure on Gentoo: "can't find designer plugins"

When I try to configure amarok-svn (latest version), I get the following error before it quits:
checking for KDE... configure: error:
I can't find the designer plugins. These are required and should have been installed
by kdelibs
The problem started after I installed qt-4.0.0 (hard masked), but amarok-svn needs qt4 to compile.
Here's my compile line:
./configure \
            --without-arts \
            --without-akode \
            --without-gstreamer \
            --without-konquisidebar \
            --without-xmms \
            --with-doc \
            --with-libvisual \
            --with-xine \
            --with-qt-includes=/usr/include/qt4 \
            --with-qt-libraries=/usr/lib/qt4 \
            --prefix=`kde-config --prefix` \
And the output from kde-config --version:

kde-config --version
Qt: 3.3.4
KDE: 3.4.1
kde-config: 1.0
...even though Qt 4.0.0 is definitely installed.
Old 07-31-2005, 11:09 AM   #2
Registered: Aug 2004
Location: Israel
Distribution: Ubuntu 10.10
Posts: 271

Rep: Reputation: 34
You don't need QT4 to compile amaroK-SVN. Just delete your /multimedia/admin/ and get a new one using a command:
svn co svn://
KDE has been branched and KDE4 is now Head, so the admin dir from head requires QT4


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
"bad interpreter : no such file or directory" when configure "flex" acer_peri Linux - Software 10 11-10-2010 01:19 AM
Not able to Run/find "configure" command aaryan72 Linux - Newbie 4 09-10-2005 11:16 AM
Can't install "glibmm" library. "configure" script can't find "sigc++-2.0&q kornerr Linux - General 4 05-10-2005 02:32 PM
"configure: error: can not find sources in <dir>" naveenkoneru Linux - Software 0 05-31-2004 05:08 PM
Can't find "Configure my computer" link mmorales Mandriva 4 03-01-2004 12:56 AM

All times are GMT -5. The time now is 04:41 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration