LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Amarok: [Loader] Amarok is taking a long time to load! Perhaps something has gone wro (http://www.linuxquestions.org/questions/linux-software-2/amarok-%5Bloader%5D-amarok-is-taking-a-long-time-to-load-perhaps-something-has-gone-wro-521099/)

fakie_flip 01-20-2007 02:52 AM

Amarok: [Loader] Amarok is taking a long time to load! Perhaps something has gone wro
 
Hello, I am using Ubuntu 6.10. I tried to play a mp3 in Amarok. Amarok said there was no mp3 support and would I like to add it, so I told it to add mp3 support and it asked for my password. After a little bit, Amarok would not play a mp3, so I thought, maybe I need to restart Amarok for it to be able to play a mp3 just like Firefox has to be restarted for new plugins to work. It showed the blue box that it normally does when it is starting except it stayed there for a while and then went away. I could not use Amarok, and it was not showing in the gnome panel. I could not start Amarok because ps showed that it was already running, so I killed all instances of it and tried to run it in terminal. The blue box showed, but when it went away it gave me the last message about something being wrong with Amarok. I have tried removing and purging amarok, amarok-xine, and libxine-extracodecs. Then I installed amarok and amarok-xine again, but the same problem. I choose to reinstall those packages because the /var/log/dpkg.log showed said they half installed and half configured. Does this mean I have to reinstall Ubuntu again if I want Amarok to work? :(

Code:

chris@ubuntu:~$ amarok
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  147
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  147
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokapp.
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  147
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  147
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
QLayout "unnamed" added to QVBox "unnamed", which already has a layout
QLayout: Adding KToolBar/mainToolBar (child of QVBox/unnamed) to layout for PlaylistWindow/PlaylistWindow
Amarok: [Loader] Amarok is taking a long time to load! Perhaps something has gone wrong?

Code:

2007-01-20 00:06:29 install libmad0 <none> 0.15.1b-2.1
2007-01-20 00:06:29 status half-installed libmad0 0.15.1b-2.1
2007-01-20 00:06:29 status unpacked libmad0 0.15.1b-2.1
2007-01-20 00:06:29 status unpacked libmad0 0.15.1b-2.1
2007-01-20 00:06:29 install libxine-extracodecs <none> 1.1.2-0ubuntu2
2007-01-20 00:06:29 status half-installed libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:06:30 status unpacked libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:06:30 status unpacked libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:06:30 status unpacked libmad0 0.15.1b-2.1
2007-01-20 00:06:30 status half-configured libmad0 0.15.1b-2.1
2007-01-20 00:06:32 status installed libmad0 0.15.1b-2.1
2007-01-20 00:06:32 status unpacked  1.1.2-0ubuntu2
2007-01-20 00:06:32 status half-configured libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:06:32 status installed libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:11:37 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:11:37 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:43:45 remove libxine-extracodecs 1.1.2-0ubuntu2 1.1.2-0ubuntu2
2007-01-20 00:43:45 status half-configured libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:43:45 status half-installed libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:43:45 status config-files libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:43:45 status config-files libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:43:45 status config-files libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:43:45 status not-installed libxine-extracodecs <none>
2007-01-20 00:44:00 status installed libmad0 0.15.1b-2.1
2007-01-20 00:44:00 remove libmad0 0.15.1b-2.1 0.15.1b-2.1
2007-01-20 00:44:00 status half-configured libmad0 0.15.1b-2.1
2007-01-20 00:44:00 status half-installed libmad0 0.15.1b-2.1
2007-01-20 00:44:00 status config-files libmad0 0.15.1b-2.1
2007-01-20 00:44:00 purge libmad0 0.15.1b-2.1 0.15.1b-2.1
2007-01-20 00:44:00 status config-files libmad0 0.15.1b-2.1
2007-01-20 00:44:00 status config-files libmad0 0.15.1b-2.1
2007-01-20 00:44:00 status config-files libmad0 0.15.1b-2.1
2007-01-20 00:44:00 status config-files libmad0 0.15.1b-2.1
2007-01-20 00:44:03 status config-files libmad0 0.15.1b-2.1
2007-01-20 00:44:03 status not-installed libmad0 <none>
2007-01-20 00:44:23 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 remove amarok 2:1.4.3-0ubuntu10 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status half-configured amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:23 status half-installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 purge amarok 2:1.4.3-0ubuntu10 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status not-installed amarok <none>
2007-01-20 00:44:24 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 remove amarok-xine 2:1.4.3-0ubuntu10 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status half-configured amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status half-installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status config-files amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:44:24 status not-installed amarok-xine <none>
2007-01-20 00:46:22 install amarok-xine <none> 2:1.4.3-0ubuntu10
2007-01-20 00:46:22 status half-installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:46:22 status unpacked amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:46:22 status unpacked amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:46:22 install amarok <none> 2:1.4.3-0ubuntu10
2007-01-20 00:46:22 status half-installed amarok 2:1.4.3-0ubuntu10
2007-01-20 00:46:23 status unpacked amarok 2:1.4.3-0ubuntu10
2007-01-20 00:46:23 status unpacked amarok 2:1.4.3-0ubuntu10
2007-01-20 00:46:23 install libmad0 <none> 0.15.1b-2.1
2007-01-20 00:46:23 status half-installed libmad0 0.15.1b-2.1
2007-01-20 00:46:23 status unpacked libmad0 0.15.1b-2.1
2007-01-20 00:46:24 status unpacked libmad0 0.15.1b-2.1
2007-01-20 00:46:24 install libxine-extracodecs <none> 1.1.2-0ubuntu2
2007-01-20 00:46:24 status half-installed libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:46:24 status unpacked libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:46:24 status unpacked libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:46:24 status unpacked libmad0 0.15.1b-2.1
2007-01-20 00:46:24 status half-configured libmad0 0.15.1b-2.1
2007-01-20 00:46:24 status installed libmad0 0.15.1b-2.1
2007-01-20 00:46:24 status unpacked libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:46:24 status half-configured libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:46:24 status installed libxine-extracodecs 1.1.2-0ubuntu2
2007-01-20 00:46:24 status unpacked amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:46:24 status half-configured amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:46:24 status installed amarok-xine 2:1.4.3-0ubuntu10
2007-01-20 00:46:24 status unpacked amarok 2:1.4.3-0ubuntu10
2007-01-20 00:46:24 status unpacked amarok 2:1.4.3-0ubuntu10
2007-01-20 00:46:24 status half-configured amarok 2:1.4.3-0ubuntu10
2007-01-20 00:46:24 status installed a


FnordPerfect 01-20-2007 09:40 PM

It looks as if some important libraries for amarok have not finished installing. Thus is might be sufficient to type
$ sudo dpkg -a --configure
in a terminal to complete the installation process. If that fails, however, the terminal output will give you some hints, why.


All times are GMT -5. The time now is 10:49 AM.