LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-03-2004, 10:19 PM   #1
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Rep: Reputation: 47
AltGr key not working in X


Well, my AltGr key just stopped working after my last reboot couple days ago,
I'm using a Belgian (be) keyboard (azerty).
I get this error message:
"The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error: Can't find file "aliases" for keycodes include
> Exiting
> Abandoning keycodes file "default"
Errors from xkbcomp are not fatal to the X server
Couldn't load XKB keymap, falling back to pre-XKB keymap
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error: Can't find file "unknown" for geometry include
> Exiting
> Abandoning geometry file "default""

Everything is ok in the XF86Config file, I'm using the same one for a long long time now.
 
Old 03-05-2004, 01:35 PM   #2
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Original Poster
Rep: Reputation: 47
*bump*
 
Old 03-07-2004, 10:51 AM   #3
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Original Poster
Rep: Reputation: 47
*bump2*
Could a moderator move this thread to the debian section please?
Maybe I'll have more luck there.
thx
 
Old 03-07-2004, 06:27 PM   #4
iceman47
Senior Member
 
Registered: Oct 2002
Location: Belgium
Distribution: Debian, Free/OpenBSD
Posts: 1,123

Original Poster
Rep: Reputation: 47
After a long time searching I did a drastic step,
I forced xbase-clients, xlibs-data and xlibs to uninstall, rm'd /etc/X11/xkb and reinstalled them.
That didn't work either, so I dpkg -i --force-confmiss them again and now it works again.
I don't think I will get any, but if anyone wants to give feedback on those actions, I will be gratefull.
I don't feel that was the best way to handle the problem.
It's like reinstalling something because a feature doesn't work or rebooting when X hangs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AltGr-key on debian-ppc working! ElPuello LinuxQuestions.org Member Success Stories 2 10-26-2004 12:58 PM
AltGr key does not work OlegL Debian 5 09-17-2004 02:22 AM
AltGr key does not work OlegL Linux - Laptop and Netbook 2 08-30-2004 09:35 AM
X.org AltGR key problem wigry Slackware 3 07-18-2004 12:15 PM
Mouse Wheel and AltGR key not working after Dropline install TNA-Mistersasaa Slackware 8 05-30-2004 07:32 AM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration