LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-19-2008, 08:01 PM   #1
iro_number1
Member
 
Registered: Jan 2007
Location: Shirley, NY
Distribution: Gentoo
Posts: 128
Blog Entries: 1

Rep: Reputation: 15
Lightbulb ALT+TAB and Cedega - how to make it work?


I'm playing World of Warcraft through Cedega and ALT+TAB doesn't work for me at all (not just in WoW but in any game). Is it possible to make it work?
 
Old 02-21-2008, 03:44 AM   #2
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Try adding the following line to /etc/X11/xorg.conf in the ServerFlag section.

Option "AllowDeactivateGrabs" "True"

To use it, press CTRL+ATL+NUMLOCK_DIVIDE. This will make any program that grabbed the keyboard and mouse give it back to X11.
 
Old 02-21-2008, 10:41 AM   #3
iro_number1
Member
 
Registered: Jan 2007
Location: Shirley, NY
Distribution: Gentoo
Posts: 128
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Electro View Post
Try adding the following line to /etc/X11/xorg.conf in the ServerFlag section.
There is no ServerFlag section.....
should i add it?
 
Old 02-22-2008, 02:27 AM   #4
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Yes you can, but just double check if you do not have it. Duplicates causes headaches later. Check the manual for xorg.conf to make sure you comply to the formatting.
 
Old 02-22-2008, 11:50 AM   #5
iro_number1
Member
 
Registered: Jan 2007
Location: Shirley, NY
Distribution: Gentoo
Posts: 128
Blog Entries: 1

Original Poster
Rep: Reputation: 15
Question

It should look like this? :

Code:
Section "ServerFlag"
	Option 		"AllowDeactivateGrabs" "True"
EndSection
And the whole file like this? :

Code:
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ImPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"Generic Video Card"
	Driver		"fglrx"
	Busid		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"COMPAQ FS760"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Generic Video Card"
	Monitor		"COMPAQ FS760"
	Defaultdepth	24
	SubSection "Display"
		Modes		"1280x1024"	"1152x864"	"1024x768"	"800x600"	"640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	
	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
EndSection
Section "Module"
	Load		"glx"
EndSection
Section "Extensions"
	Option		"Composite"	"0"
EndSection

Section "ServerFlag"
	Option 		"AllowDeactivateGrabs" "True"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alt-Tab does not work under Xfce or Gnome kosmik Linux - Desktop 1 09-02-2009 11:09 AM
FC 4. Modify ALT+TAB behaviour to CTRL+TAB xtracto Linux - Software 1 09-22-2005 02:06 PM
Switching window focus (like alt+tab in windows) and Ctrl+Alt+F1 X windows problem... DiZASTiX Linux - Software 3 01-20-2005 04:56 PM
How to make Alt+Ctrl+DEL work in linux Boffy Linux - General 6 08-15-2004 06:32 AM
Alt-Tab and Alt-F4 in Fluxbox? tavilach Linux - Software 2 07-17-2004 04:03 PM


All times are GMT -5. The time now is 07:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration