LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-23-2006, 02:57 AM   #1
Bigpet
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Rep: Reputation: 0
"Alt GR" produces Keycodes for "CTRL" as well


It took me ages to find out why I couldn't
write curly Brackets and the Piping sign on
my Keyboard with my newly installed SuSE 10.

The Reason is:
Every time I press Alt Gr the keycodes of
Alt Gr AND Ctrl_L are recognised. This seems
to be a general problem of the keymaps I use
because this also happened in the text console.

The thing is I installed SuSE 2 Times with the
CD's I used. The first intallation was on the
Virtual Machine "Virtual PC 2004" and the second
was on an old PC.
The keyboard on the old PC worked with no
problems. But the one on the VM has the
described error. I don't have some sort of
a special media keyboard or something. It's
a plain "cherry" keyboard.
Ok it's likely to blame Virtual PC for that
but I need it to work and I haven't encountered
anyone using the VM who has this problem.

What did work (well kinda) is unbinding the
left Ctrl. That let me print all the Alt GR
characters but I need the left Ctrl as well.

I'll post the keymaps I use later.
 
Old 01-23-2006, 03:00 AM   #2
Bigpet
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Original Poster
Rep: Reputation: 0
"Alt GR" produces Keycode for "CTRL" as well

Ok I got it myself.
After 3 Days I finnaly found out that
this is a bug of the SP1 for Virtual
PC 2004.
I fixed it by adding the functions
the keys (in the keymaps) usually have when pressing
altgr with ctrl+altgr

the keymaps are located depending on the distro:
Debian /usr/share/keymaps/(your arch)/(qwertz/qwerty/azerty)/(theconfiguredkeymap).kmap.gz
SuSE /usr/share/kbd/keymaps/(your arch)/(qwertz/qwerty/azerty)/(theconfiguredkeymap).map.gz
example:
keycode 9 = eight parenleft bracketleft
control altgr keycode 9 = bracketleft

I don't think M$ will fix this so hopefully
everyone who encounters this error reads this

Last edited by Bigpet; 01-25-2006 at 03:13 AM.
 
Old 01-23-2006, 04:36 AM   #3
Bigpet
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Oh damn
now I just can't find out how to do the same settings in xkb.
So could please anyone tell me how I can configure CTRL+AltGR+* combinations in xkb?

Last edited by Bigpet; 01-25-2006 at 03:14 AM.
 
Old 01-25-2006, 02:15 AM   #4
Bigpet
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Original Poster
Rep: Reputation: 0
wup double post

Last edited by Bigpet; 01-25-2006 at 03:14 AM.
 
Old 04-03-2006, 12:21 PM   #5
the bear
LQ Newbie
 
Registered: Jan 2006
Posts: 9

Rep: Reputation: 2
Take a look in the compat folder in xkb (arm/mvroot/usr/X11R6/lib/X11/xkb/compat). The pc file seems to have what you're looking for. I don't know exactly what needs to be changed but I would think it's related to:

Code:
interpret Alt_R+Any	{
	virtualModifier= Alt;
	action = SetMods(modifiers=modMapMods);
    };
However, I've been trying to make changes similar to what you're suggesting and clean fixes can be very complicated with xkb. An easy hack would be to go into the symbols/pc folder and open whatever language file you're using. In there you can control what every single key does. It wont let you define alt+ctrl behavior but you can set some other key that isn't used (like alt+shift keys maybe?) to do what you want.
 
Old 04-09-2006, 04:31 AM   #6
Bigpet
LQ Newbie
 
Registered: Jan 2006
Posts: 12

Original Poster
Rep: Reputation: 0
thanks the bear.
But I got it fixed another way (sorry for not posting it)

I found the modifier options in „/etc/X11/xkb/types/extra“.
below the word FOUR_LEVEL I changed the following lines:
(-->= previous line changed to: )
modifiers = Shift+LevelThree;
-->modifiers = Shift+LevelThree+Control;
map[LevelThree] = Level3;
-->map[Control+LevelThree] = Level3;
level_name[Level3] = “Alt Base”;
-->level_name[Level3] = “AltGr”;

I know I should've made these changes in another file
that's supposed to be used for user changes. But I tried
it so long that I was fond of this quick hack to work. I
just left it the way it was.

But sadly xemacs doesn't use the xkb maps so if I were to
use it I would have had to remap the keys there as well.
This problem should be solved by a global interface for
keymaps for all modes (text and graphical) and programs
in linux. That's just my
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Telling people to use "Google," to "RTFM," or "Use the search feature" Ausar General 77 03-21-2010 11:26 AM
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
Ctrl+Alt+"+" Pico_01 Linux - Laptop and Netbook 2 12-28-2004 10:34 AM
"unlock" ctrl-alt-del raysr Linux - Newbie 6 05-07-2004 11:53 AM


All times are GMT -5. The time now is 07:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration