LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-25-2008, 03:57 PM   #1
JosephS
Member
 
Registered: Jun 2007
Distribution: Debian Squeeze, CrunchBang Waldorf
Posts: 516

Rep: Reputation: 38
alsactl store not saving settings


I opened a terminal as root.
I set alsamixer and stored the settings with asactl store.
I have capture set on Mix

When I reboot the computer the settings change:
On Mix I have Captur R
On Mic I have Captur L

Why isn't alsactl store saving the settings?

Thanks.
 
Old 10-26-2008, 10:16 AM   #2
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,545

Rep: Reputation: 238Reputation: 238Reputation: 238
It probably is saving your settings. But that doesn't mean that some other mixers don't also have saved settings and is changing things to its way on reboot. It's also possible that the user level settings are being used instead of those set by root. According to the man page it looks like it uses the same config file /etc/asound.state. So maybe try alsactl store as the user after root changes the settings. Or just completely remove asound.state and then alsactl store as root. Which should leave only roots settings and be the default system wide. (in theory)

In debian, I had a similar issue. I used aumix to set the settings. But if an alsamixer settings file (/etc/asound.state) was found, it was used and not aumix's settings file (~/.aumixrc). This is in the boot scripts where aumix checks for the existence of said file before trying to touch mixer settings. Which doesn't mean that there's anything in the file, just that if it exists aumix passes on changing the settings. Your boot scripts might differ in their configuration. The solution for me was to remove the /etc/asound.state file in order to have aumix's settings restored at boot. Not applicable for you which would be the other way around, and the default on my system.
 
Old 12-14-2008, 08:14 AM   #3
Sjonnie48
Member
 
Registered: Jun 2005
Location: Earth
Distribution: Ubuntu10.04
Posts: 308

Rep: Reputation: 43
I have experienced a similar problem. My desktop environment is Kde.

Although my alasctl settings were really saved it was for the actual session. And after starting a new session the old settings had returned.
Purely by coincidence I found the culprit: kmix.
There is an option in the settings "Restore volumes on login" which is selected by default.
After unchecking this option my alsactl settings have been safe ever since!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to run 'alsaconf' at every boot, even with 'alsactl store'. wtn2die Linux - Hardware 7 03-12-2010 01:48 AM
Setterm -powerdown 2 -store not saving settings after reboot kragbax Linux - Newbie 1 12-22-2004 10:11 PM
alsactl store doralsoral Linux - Software 2 05-20-2004 09:14 PM
alsactl store promblem doralsoral Linux - Software 0 05-17-2004 10:38 PM
alsactl not saving settings dschobel Linux - Software 2 02-18-2004 01:44 PM


All times are GMT -5. The time now is 07:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration