LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-18-2004, 01:52 AM   #1
happyman
LQ Newbie
 
Registered: Mar 2004
Distribution: **~Gentoo~**
Posts: 10

Rep: Reputation: 0
ALSA works, but sound is EXTREEEMLY quiet!!


i have compiled ALSA, and sound is now working on my system. the problem is that i can harldley hear anything!!! sound is comming out but it is so quiet. when i open the "Volume Conrol" in GNOME it looks like "Spkr" is turned all the way up. im using panasonic stereo headphones for speakers. i tried using reguar digital speakers but i had the same problem.im using a 2.6.5 kernel on the Gentoo Linux distro, and im using a GNOME desktop, and my soundcard specs are: VIA Technologies, Inc. VT8233/A/8235/8237. i didnt have this problem on windows xp so i dont think my soundcard is broken. whats the problem??

-thanks in advance.
 
Old 06-18-2004, 02:19 AM   #2
vrln
Member
 
Registered: Mar 2004
Location: Finland
Distribution: Gentoo
Posts: 235

Rep: Reputation: 30
try typing alsamixer in console and change volume there, the one you need to change is the master volume level (the first bar)
 
Old 06-18-2004, 02:53 AM   #3
happyman
LQ Newbie
 
Registered: Mar 2004
Distribution: **~Gentoo~**
Posts: 10

Original Poster
Rep: Reputation: 0
i ran alsamixer an the master volume IS all the way up. is there something else in the alsamixer menu i need to change?? also there are items in the alsamixer menu that are off and i would like to turn them on. how would i do that?
 
Old 06-18-2004, 07:09 AM   #4
smtibor
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
I had a similar problem with my onboard ac97 chip. In order to get it working, I had to increase the volume of the DXS channel. You may want to try that with your card.
 
Old 06-18-2004, 10:16 AM   #5
Guillaume2x
LQ Newbie
 
Registered: Jun 2004
Location: Paris, France
Distribution: Debian "sid" (unstable)
Posts: 3

Rep: Reputation: 0
Question

Hello,
I have exactly the same problem with my Hercules Muse XL sound card.
Alsa works, but the sound is extremely low.
I don't know why, but when I mute the channel "mic" in alsamixer, I can't hear anything at all.
This probably means that I can only hear sound through the "mic" channel and not directly through the "PCM" channel.
Maybe you should try to mute this channel and to tell us if you can still hear something...
Guillaume (debian sid, kernel 2.6) <zeubestNOSPAM@ifrance.com>
Ps : I uninstalled alsa, I unblacklisted oss sound drivers in the hotplug config files, and everything worked fine.

Last edited by Guillaume2x; 06-18-2004 at 10:18 AM.
 
Old 06-18-2004, 11:31 AM   #6
Ross Clement
Member
 
Registered: Jun 2003
Location: UK
Distribution: Redhat 9 (work) Fedora 1 (home)
Posts: 171

Rep: Reputation: 30
I find gnome-alsamixer much easier to read and use than alsamixer. Not sure if it will solve anyone's problems, but at least you can see what you are doing :-)

Cheers,

Ross-c
 
Old 06-18-2004, 11:45 AM   #7
Guillaume2x
LQ Newbie
 
Registered: Jun 2004
Location: Paris, France
Distribution: Debian "sid" (unstable)
Posts: 3

Rep: Reputation: 0
Hello,
I solved the problem by muting the "exchange" channel (to do that, select the channel and then hit the "m" key in alsamixer).
It may work with your card too...
Bye
Guillaume
 
Old 06-18-2004, 05:02 PM   #8
happyman
LQ Newbie
 
Registered: Mar 2004
Distribution: **~Gentoo~**
Posts: 10

Original Poster
Rep: Reputation: 0
i have been told many times now in other forums, and chatrooms, that my problem has something to do with my settings the the alsamixer. i made some screenshots of alsamixer so you all can see for it for your self. maybe by viewing these screen shots you guys guys can figure out whats wrong.

there are three different screen shots with all the different items in alsamixer:

Screen Shot #1: http://www.thegoobers.com/AMIXER_IMG/AMIXER1.PNG
Screen Shot #2: http://www.thegoobers.com/AMIXER_IMG/AMIXER2.PNG
Screen Shot #3: http://www.thegoobers.com/AMIXER_IMG/AMIXER3.PNG

thanks for all the help so far!!
 
Old 06-18-2004, 06:52 PM   #9
happyman
LQ Newbie
 
Registered: Mar 2004
Distribution: **~Gentoo~**
Posts: 10

Original Poster
Rep: Reputation: 0
i figured out was wrong. the 'Headphone' item in alsamixer was muted. thanks for all the help everyone.
 
Old 08-07-2006, 11:50 AM   #10
timothyb89
Member
 
Registered: Jul 2006
Location: Colorado, USA
Distribution: openSuSE 11.4
Posts: 118

Rep: Reputation: 15
I fixed it by unmuting everything in alsamixer. Not only did it make it TOO loud, but it also get rid of the crackling from ALSA.

This worked with a Dell Dimension E510 /w integrated audio
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help, FC2 ALSA sound works just halfway ??? tho_x_tran Fedora 1 08-11-2004 11:45 AM
My alsa is very quiet devfreak Linux - Software 2 07-03-2004 01:24 AM
ALSA ESD --> no sound, but OSS sound works intense Slackware 1 03-23-2004 02:34 PM
[sound] Alsa works, speaker doesn't BlackCell Linux - General 3 11-12-2003 04:28 PM
ALSA sound works...and then goes away bhay Linux - Hardware 3 08-30-2002 05:04 AM


All times are GMT -5. The time now is 10:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration