LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-18-2009, 11:59 AM   #1
heiko
LQ Newbie
 
Registered: Oct 2009
Posts: 3

Rep: Reputation: 0
ALSA - sometimes only one speaker working


Hello out there,

I am a happy user of Slackware 13, but there is an annoying problem with ALSA (or anything else??) on my system.

Sometimes (rather often) only one speaker of my system plays music.

I use plain Slackware 13, without /etc/asound.conf and ~/.asoundrc

-- ALSA restart /etc/rc.d/rc.alsa doesn`t help
-- muting/unmuting the mixer doesn`t help
-- Rebooting the PC helps - most of the times

Does anybody has the same problem or a solution ??

Thanks for all help!!

Heiko




1. )My Card is

bash-3.1$ cat /proc/asound/cards
0 [CA0106 ]: CA0106 - CA0106
Live! 7.1 24bit [SB0410] at 0x9c00 irq 22


2.) All modules are properly loaded

bash-3.1$ lsmod |grep snd
snd_seq_dummy 2464 0
snd_seq_oss 29792 0
snd_seq_midi_event 5980 1 snd_seq_oss
snd_seq 47984 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss 37728 0
snd_mixer_oss 14300 1 snd_pcm_oss
snd_ca0106 32864 4
snd_rawmidi 19040 1 snd_ca0106
snd_seq_device 6088 4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_ac97_codec 100128 1 snd_ca0106
ac97_bus 1372 1 snd_ac97_codec
snd_pcm 68128 4 snd_pcm_oss,snd_ca0106,snd_ac97_codec
snd_timer 19108 3 snd_seq,snd_pcm
snd 50820 16 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_ca0106,snd_rawmidi,snd_seq_device,snd_ac97_codec,s nd_pcm,snd_timer
soundcore 5824 1 snd
snd_page_alloc 7972 2 snd_ca0106,snd_pcm
 
Old 10-18-2009, 01:02 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,034

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Most likely to be a hardware fault as software faults generally lead to no sound at all.

Please check your cables and connectors (try others, jiggle / reconnect the connectors while music is playing out of the one speaker).

Welcome to LQ!
 
  


Reply

Tags
alsa, slackware, soundcard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA software speaker rotation fr0zen Linux - Software 0 01-21-2008 08:35 PM
ALSA surround center speaker problems LavaDevil94 Linux - Hardware 25 06-16-2004 12:10 AM
alsa speaker config ???? Wynand1 Slackware 2 06-08-2004 07:28 PM
alsa and 4 speaker system vexer Linux - General 1 12-29-2003 11:29 PM
[sound] Alsa works, speaker doesn't BlackCell Linux - General 3 11-12-2003 05:28 PM


All times are GMT -5. The time now is 02:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration