LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-26-2003, 09:38 AM   #1
]Trix[
LQ Newbie
 
Registered: Feb 2003
Location: Europe - Slovenia
Distribution: Gentoo
Posts: 10

Rep: Reputation: 0
ALSA SBLive5.1 Rear Speakers Volume Control


I am using ALSA Drivers with SB Live 5.1 Digital and I just don't know how to set the rear speakers volume. I don't use 5.1 speaker, just 2 speakers for front output channel and two speakers for rear output channel. Is there any kind of mixer that with witch I could unmute and control the volume of rear speakers. I tried gnome-alsamixer, and a lot of other mixers but none of them support separate controls for rear and front chanels.
Thank you in advance for your help.
]Trix[

Last edited by ]Trix[; 02-26-2003 at 09:43 AM.
 
Old 02-26-2003, 11:20 AM   #2
kater
Member
 
Registered: Feb 2003
Location: Switzerland, Berne
Distribution: Slackware 9.0
Posts: 186

Rep: Reputation: 30
I remember this problem: I have a SB PCI512 with the Creative FourPoint Speaker System. I just changed the connections of the speakers:

Front-R & Rear-R
Rear-L & Front-R

Normaly, they would be connected like this:

Front-L & Front-R
Rear-R & Rear-L

So you can set the volume between front/rear, but you lose control over right/left.

Last edited by kater; 02-26-2003 at 11:21 AM.
 
Old 02-26-2003, 06:21 PM   #3
]Trix[
LQ Newbie
 
Registered: Feb 2003
Location: Europe - Slovenia
Distribution: Gentoo
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks for your reply. But I guess i wasn't to specific about my problem. The rear speakers just don't work, no sound, nothing, null... It looks like they are muted or sth and I don't know how to unmute them and it would be nice to control the volume too directly from the mixer.
I looked in the specifications for ALSA drivers and they have the support for rear and front speakers.
Could I somehow unmute them with amixer? And how?
 
Old 02-26-2003, 07:15 PM   #4
subservant
Member
 
Registered: Feb 2003
Location: Portland , Oregon
Distribution: Red Hat 8.0
Posts: 91

Rep: Reputation: 15
what speaker system do you have ???

I have been using a chambridge works 4.1 set and all 4 speakers are set to equial channels. try setting your speakers differently.
 
Old 02-27-2003, 02:05 AM   #5
boonders
Member
 
Registered: Feb 2003
Posts: 47

Rep: Reputation: 15
use the ALSAGUIMIXER, if you have 5.1 TURN OFF "digital out" i think that is what it is called(unless you actually have a digital system hooked up), and increase "WAVE surround", "WAVE CENTER", "WAVE something else..." and that should solve your problem...if that doesn't work, reply, I can check my config again to see if i missed something
 
Old 02-27-2003, 06:52 AM   #6
]Trix[
LQ Newbie
 
Registered: Feb 2003
Location: Europe - Slovenia
Distribution: Gentoo
Posts: 10

Original Poster
Rep: Reputation: 0
Can you suggest any other gui mixer which have the same option as alsaguimixer, cause it won't compile with my fltk and gcc version?
THX
 
Old 02-27-2003, 09:03 AM   #7
]Trix[
LQ Newbie
 
Registered: Feb 2003
Location: Europe - Slovenia
Distribution: Gentoo
Posts: 10

Original Poster
Rep: Reputation: 0
Thank you all for your help and time. I managed to fix my problem and now works really goooooood I installed gamix which has the support ti disable Live Analog/Digital... so I disabled it and now it work.
OK. I was happy too soon just found out that sometimes it works sometimes it don't. It is so f...... strange.
When xmms changes song every setting gets lost and I am back to front speakers only.
Hmmmmmmmm. Argh.
I guess I am again at the begining.

Last edited by ]Trix[; 02-27-2003 at 11:26 AM.
 
Old 02-27-2003, 12:32 PM   #8
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Look into the gamix docs, you may have an option to keep the changes (make em perm). Otherwise, see what you can do about getting alsaguimixer to compile. What distro are you using?
 
Old 02-28-2003, 08:00 AM   #9
]Trix[
LQ Newbie
 
Registered: Feb 2003
Location: Europe - Slovenia
Distribution: Gentoo
Posts: 10

Original Poster
Rep: Reputation: 0
I am using gentoo linux. I get an error fltk not found bu I have it installed. Alsa gui mixer doesn't work with the newest fltk.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Terratec Aureon 7.1 Space + ALSA = no sound from rear speakers :( BedriddenTech Linux - Hardware 4 10-06-2004 09:10 AM
master volume control for both front and rear? zarathustra674 Mandriva 1 12-05-2003 06:03 PM
Alsa, soundblaster 5.1 & rear speakers Ravendark Slackware 3 11-30-2003 04:08 PM
No sound on rear channels, no volume control chiefjoe Linux - Hardware 7 08-23-2003 05:44 PM
rear speaker volume control bennyp Linux - Software 1 05-11-2003 12:33 PM


All times are GMT -5. The time now is 04:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration