LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-14-2011, 08:29 AM   #1
sevs
Member
 
Registered: Jul 2008
Location: Ukraine, Kharkov
Distribution: debian, knoppix, mandriva, asplinux, altlinux
Posts: 110

Rep: Reputation: 20
Question ALSA, Phonon, Debian Squeeze.


Hi there!
Two days ago I've got upgraded from my Debian Lenny to Squeeze. It's all cool - KDE 4, GNOME 2.30 and everything... But here is one problem. I've got no sound in applications using Phonon. "Alright" i thought. Let's go some deeper. As I have understood - Phonon is just API. It bases on PulseAudio sound server, who bases on ALSA. Though - as I've got it from forums and other people - PulseAudio should start as soon, as possible after ALSA. "And here you _should_ go." I have ONLY Dummy Output in PulseAudio. I even do not see any of my sound devices in Phonons settings in systemsettings. As I saw on Ubuntu/Kubuntu/Fedora forums there was similiar problem, but they saw their sound devices. In /etc/rc2.d (second startup mode is default) - S25pulseaudio as a link to /etc/init.d/pulseaudio. ALSA is started as modules. It has its *.conf files in /etc/modprobe.d/

Thanks in advance.
Sorry for bad English.
 
Old 02-14-2011, 12:35 PM   #2
rizzy
Member
 
Registered: Mar 2004
Distribution: Debian
Posts: 283

Rep: Reputation: 65
I had to run "alsactl init" to enable sound in clean squeeze install.
 
Old 02-15-2011, 09:24 AM   #3
sevs
Member
 
Registered: Jul 2008
Location: Ukraine, Kharkov
Distribution: debian, knoppix, mandriva, asplinux, altlinux
Posts: 110

Original Poster
Rep: Reputation: 20
I do not have to run anything for alsa to run.
But I do not have sound in pulseaudio.

By the way, I think that it is because of kenel. Version 2.6.33 - is that ok?
 
  


Reply

Tags
alsa, phonon, pulseaudio


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Perfect Server - Debian Squeeze (Debian 6.0) ISPConfig 2 LXer Syndicated Linux News 0 02-14-2011 08:00 AM
[SOLVED] Kde 4.4.5: Use custom Alsa device in Phonon Vookimedlo Linux - Software 6 01-30-2011 04:39 PM
LXer: Goodbye Fedora, welcome back Debian, Part 2: Review of Debian Squeeze LXer Syndicated Linux News 0 12-02-2010 09:00 AM
alsa-source from squeeze cccc Debian 4 08-10-2009 09:24 AM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration