LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-16-2003, 10:24 PM   #1
cb9fl
Member
 
Registered: Oct 2003
Posts: 64

Rep: Reputation: 15
alsa - mmap - almost fixed slack ET


I have been troubleshooting a problem with no sound in ET caused by an error message of "unable to map valid mmap /dev/dsp". I have mostly resolved the issue.


As a regular user while dropline is running I can remove the volume control from the panel and "killall -9 esd". Afterwards I "modprobe -r snd-cs46xx" and then "modprobe snd-cs46xx mmap_valid=1". Afterwards I have to unmute and then increase the PCM volume using alsamixer. At this poing sound works correctly in Enemy Territory and I would assume other ID games.

Now how can I add this to my modules.conf to allow 'snd-cs46xx mmap_valid=1' to be loaded automatically as slack is loading? My modules.conf currently ONLY has the current line.

alias char-major-195 nvidia

From what I've read the line
"options mmap_valid=1" needs to be added directly after ALSA information in the modules.conf. But as you can see I have practically nothing in my modules.conf just a line about the Geforce Ti4400 card I have.

Any help would be greatly appreciated.

P.S. I searched dmesg for any references to ALSA to determine a slot number. The only thing returned with "dmesg | grep ALSA" was

ALSA ../../alsa-kernel/pci/cs46xx/cs46xx_lib.c:416: cs46xx: failure waiting for FIFO command to complete
ALSA ../../alsa-kernel/pci/cs46xx/cs46xx_lib.c:416: cs46xx: failure waiting for FIFO command to complete

but sound works fine in most things normally and in ET if I used the first posted procedure.
 
Old 12-17-2003, 03:50 AM   #2
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
You can add the line:
Code:
snd-cs46xx mmap_valid=1
to your /etc/modules file or add the line:
Code:
option snd-cs46xx mmap_valid=1
to any point in the modules.conf file. The second method is probably preferable.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa sound stops in mmap mode with events/0 spike Moloko Debian 0 02-02-2005 07:34 AM
Unsupported burner in Slack 10. Can this be fixed? libranikki Slackware 15 08-12-2004 01:55 PM
ALSA & mmap -- Return to Castle Wolfenstein The Burninator Linux - General 2 02-05-2004 07:47 AM
Fixed my Alsa sound problem with Slack 9.1 Cyclops Slackware 4 10-26-2003 12:33 AM
Just fixed ALSA prob, but with some minor inconvenience ... Elijah Linux - Software 2 04-17-2003 12:43 PM


All times are GMT -5. The time now is 04:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration