LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-23-2004, 07:45 PM   #1
atheist
Member
 
Registered: Sep 2003
Location: Iceland
Distribution: Debian Lenny - Kernel 2.6.22.8
Posts: 331

Rep: Reputation: 30
ALSA messing up


I've just reinstalled Debian on my machine. I saved the kernel configuration and used it to compile the same version of my kernel as before (2.6.6).

Sound was working great before. Now alsaconf gives me this:
Code:
modinfo: could not find module snd
Do you know what could be the cause of this? Or what I should try?

Thanks.
 
Old 10-23-2004, 08:51 PM   #2
UsualTuxpect
Member
 
Registered: Aug 2004
Location: New York
Distribution: --------- Gentoo-2004.2 [2.6.8] Redhat-9 [2.6.6]
Posts: 545

Rep: Reputation: 31
see if the module for ur card is present on ur system [.o or .ko]
http://www.alsa-project.org/alsa-doc...dor=All#matrix

#lsmod [to see all the modules loaded]

check ur /etc/modules.conf

did u run ----> modules-update [i beieve there's one on debian too]

and see if ur loading the alsa at startup...
 
Old 10-23-2004, 11:32 PM   #3
atheist
Member
 
Registered: Sep 2003
Location: Iceland
Distribution: Debian Lenny - Kernel 2.6.22.8
Posts: 331

Original Poster
Rep: Reputation: 30
I had compiled it into the kernel. (Not (M) but (*)). But I tried compiling it as a module and now alsaconf configures my sound card. Thanks, though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo configuration issue (missing user groups, alsa messing with emerge, DEVFS) Lechium Linux - Distributions 3 04-06-2005 02:06 AM
What should I know before messing with Apache? Rundi Linux - Software 1 04-02-2005 11:46 AM
Anyone messing with Core3 yet? ArenaJAG Fedora 4 08-06-2004 04:27 PM
X is messing with me, or something is... Starchild Linux - General 2 09-27-2003 02:44 PM
RH keeps messing up...:( floyes Red Hat 4 09-06-2003 02:36 PM


All times are GMT -5. The time now is 02:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration