LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-31-2003, 08:52 PM   #1
The Burninator
LQ Newbie
 
Registered: Jan 2003
Posts: 26

Rep: Reputation: 15
ALSA install - NEW problem autoloading snd-seq-oss


ALSA is installed, but the module snd-seq-oss won't load on login. The other necessary modules do. Just not that. Here's my modules.conf file:

alias parport_lowlevel parport_pc
alias eth0 3c59x
alias sound-slot-0 snd-cs46xx
#post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
#pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

post-install sound-slot-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
pre-remove sound-slot-0 /usr/sbin/alsactl store >/dev/null 2>&1 || :


alias usb-controller usb-uhci


#alias char-major-195 nvidia


alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias char-major-195 NVdriver

After login, I have no problems loading the module and playing sounds.

Also, I'm still getting the 'unresolved symbols' error (see below), which is likely related. And I don't think the alsamixer restore script is working.

This is weird.


-------------------------------------------------------------------

I'm using RedHat 8.0, and my sound has a tendency to "hiccup." So I decided to try and install ALSA. I went to www.freshrpms.net and downloaded the following files:

alsa-driver-0.9.0-fr0rc6.2.i386.rpm
alsa-kernel-0.9.0-fr0rc6.2_2.4.18_19.8.0.athlon.rpm
alsa-xmms-0.9.7-fr1.i386.rpm
alsa-lib-0.9.0-fr0rc6.1.i386.rpm
alsa-utils-0.9.0-fr0rc6.1.src.rpm

I installed them by double-clicking on them in GNOME. Then, when I ran XMMS and selected the ALSA output plugin, I got this message:

ALSA error
error opening alsa device: No such file or directory

What's wrong??


P.S. I then downloaded alsaplayer, which I installed the same way. It seemed completely functionless, so I tried to uninstall it through the terminal. The uninstall wasn't completely effective; it seems to technically be installed, but the link it the GNOME menu is gone. Any ideas? I'm quite a newbie. Thanks.

Last edited by The Burninator; 02-02-2003 at 05:02 PM.
 
Old 02-01-2003, 03:00 PM   #2
The Burninator
LQ Newbie
 
Registered: Jan 2003
Posts: 26

Original Poster
Rep: Reputation: 15
Anybody?
 
Old 02-01-2003, 05:23 PM   #3
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,137

Rep: Reputation: 65
Re: ALSA install

Quote:
Originally posted by The Burninator
I'm using RedHat 8.0, and my sound has a tendency to "hiccup." So I decided to try and install ALSA. I went to www.freshrpms.net and downloaded the following files:

alsa-driver-0.9.0-fr0rc6.2.i386.rpm
alsa-kernel-0.9.0-fr0rc6.2_2.4.18_19.8.0.athlon.rpm
alsa-xmms-0.9.7-fr1.i386.rpm
alsa-lib-0.9.0-fr0rc6.1.i386.rpm
alsa-utils-0.9.0-fr0rc6.1.src.rpm

I installed them by double-clicking on them in GNOME. Then, when I ran XMMS and selected the ALSA output plugin, I got this message:

ALSA error
error opening alsa device: No such file or directory

What's in modules.conf?

What do you see in /proc? You should see a subdirectory `asound' and under that you should see an entry `version'. What does that contain?
What do you see under /proc/modules?
 
Old 02-01-2003, 06:03 PM   #4
The Burninator
LQ Newbie
 
Registered: Jan 2003
Posts: 26

Original Poster
Rep: Reputation: 15
There's no directory asound. Being a linux newbie, i don't know exactly what you mean by "modules.conf".
Here are the contents of proc/modules

sr_mod 18136 0 (autoclean)
cs46xx 62960 2 (autoclean)
ac97_codec 13384 0 (autoclean) [cs46xx]
soundcore 6500 3 (autoclean) [cs46xx]
autofs 13348 0 (autoclean) (unused)
3c59x 30608 1
ipt_REJECT 3736 6 (autoclean)
iptable_filter 2412 1 (autoclean)
ip_tables 14840 2 [ipt_REJECT iptable_filter]
usb-storage 62000 0
ide-scsi 10512 0
scsi_mod 107176 3 [sr_mod usb-storage ide-scsi]
ide-cd 33608 0
cdrom 33696 0 [sr_mod ide-cd]
nls_iso8859-1 3516 1 (autoclean)
nls_cp437 5116 1 (autoclean)
vfat 13084 1 (autoclean)
fat 38744 0 (autoclean) [vfat]
mousedev 5524 1
keybdev 2976 0 (unused)
hid 22244 0 (unused)
input 5888 0 [mousedev keybdev hid]
usb-uhci 26188 0 (unused)
usbcore 77056 1 [usb-storage hid usb-uhci]
ext3 70400 2
jbd 52212 2 [ext3]


Upon closer look, i found "modules.conf" in /etc, and the contents are....

alias parport_lowlevel parport_pc
alias eth0 3c59x
alias sound-slot-0 cs46xx
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias usb-controller usb-uhci


My instincts would tell me that there's no evidence of ALSA anywhere here, but in XMMS, the output plugin is listed. I'm really, really confused. Thanks for any help you can give me.
 
Old 02-01-2003, 06:12 PM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Yeah, you'd wanna checkup on a page over at alsa about how to setup modules.conf for your soundcard, here's the page to locate your soundcard:
http://www.alsa-project.org/alsa-doc/

Read the one for your card, if you have questions, ask

And you've got the ALSA plugin in XMMS because you installed the RPM for it

Cool
 
Old 02-01-2003, 08:07 PM   #6
The Burninator
LQ Newbie
 
Registered: Jan 2003
Posts: 26

Original Poster
Rep: Reputation: 15
Well, I entered the lines of code there, and i also downloaded and installed the alsa-utils package, which had previously been wrong, but now i get this error upon login:

couldn't open mixer device /dev/sound/mixer

in addition, not even the OSS output plugin works now... I've made things worse!

What could be wrong?
 
Old 02-01-2003, 08:13 PM   #7
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
First check if /dev/sound/mixer exists. If it does, is it a device or symlink. To check out all this:
ls -l /dev/sound/mixer

If it shows up as a symlink, look at where it's linked to. If it's an actual device what are the permissions on it? Post up what comes up when you type:
ls -l /dev/sound/mixer

You probably will be able to get away with simple chmodding. Something like:
chmod 666 /dev/sound/mixer (as root).

But first off, let's see what shows up with the above command.

Cool
 
Old 02-01-2003, 08:32 PM   #8
The Burninator
LQ Newbie
 
Registered: Jan 2003
Posts: 26

Original Poster
Rep: Reputation: 15
no such file or directory
 
Old 02-01-2003, 08:37 PM   #9
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Ok, sounds like maybe instead of the RPM's you may wanna go tarballs (or bzipped tarballs). Get the newest alsa files from their website, then follow the directions exactly as they are written on the webpage for your soundcard. You maybe have missed the create devices scripts. ./snddevices or something along those lines, been a while since I've worked with alsa. Anyway, here's a link to their latest files:
www.alsa-project.org
Get the latest unstable files (0.90 rc7).
Cool
 
Old 02-01-2003, 09:15 PM   #10
The Burninator
LQ Newbie
 
Registered: Jan 2003
Posts: 26

Original Poster
Rep: Reputation: 15
The installation instructions require that i use a command called "modprobe," which doesn't appear to be valid for me. What to do?
 
Old 02-01-2003, 10:24 PM   #11
The Burninator
LQ Newbie
 
Registered: Jan 2003
Posts: 26

Original Poster
Rep: Reputation: 15
Nev.... I managed to find it, but now I get an error during startup (before login) that says:

Feb 1 22:58:19 localhost depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.18-14/kernel/sound/isa/gus/snd-gus-synth.o
Feb 1 22:58:19 localhost depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.18-14/kernel/sound/isa/sb/snd-emu8000-synth.o
Feb 1 22:58:19 localhost depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.18-14/kernel/sound/pci/emu10k1/snd-emu10k1-synth.o
Feb 1 22:58:19 localhost depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.18-14/kernel/sound/pci/trident/snd-trident-synth.o
Feb 1 22:58:19 localhost depmod: depmod: *** Unresolved symbols in /lib/modules/2.4.18-14/kernel/sound/synth/emux/snd-emux-synth.o

(this is from /var/log/boot.log)
 
Old 02-02-2003, 01:10 AM   #12
mad_ady
Member
 
Registered: Jan 2003
Location: I'm all in your mind!
Distribution: Debian
Posts: 248

Rep: Reputation: 30
The problems you get at startup are caused probably by a faulty configuration of you /etc/modules.conf...
Check the file again and see if modprobe (or the install script) has made any changes to it... If it did, please post them...

Good luck!
 
Old 02-02-2003, 04:59 AM   #13
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Can you post the following:
uname -r
modprobe sound (if it returns any errors, if not, can you post up 'lsmod' (LSMOD lowercase)
and your /etc/modules.conf
?

Cool
 
Old 02-02-2003, 01:57 PM   #14
The Burninator
LQ Newbie
 
Registered: Jan 2003
Posts: 26

Original Poster
Rep: Reputation: 15
Ok, it's working.... there's a very well-hidden alsamixer setting that was muting my external amplifier. However, my modules.conf doesn't contain any of the lines ALSA's website tells me to insert. Perhaps those are for autoloading the modules??

Thanks for all the help.
 
Old 02-02-2003, 10:31 PM   #15
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,137

Rep: Reputation: 65
Quote:
Originally posted by The Burninator
Ok, it's working.... there's a very well-hidden alsamixer setting that was muting my external amplifier.
Aahh... When you build the alsa driver from the sources, there's a big notice at the end of the build alerting you that the sound is muted and to fire up your mixer to set the sound level. Guess the rpm install doesn't provide that little hint. :-)

Quote:
However, my modules.conf doesn't contain any of the lines ALSA's website tells me to insert. Perhaps those are for autoloading the modules??
So, did you add them? (You'll need 'em.)

Have fun...

Rick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to un-install alsa steve1401 Linux - General 6 12-11-2004 06:10 PM
Alsa install help etern8ty Red Hat 4 06-24-2004 03:37 PM
alsa install fideli Linux - Hardware 2 11-29-2003 09:14 PM
alsa install barazor Linux - Software 2 04-19-2002 06:06 PM
ALSA install... fxlee Linux - Newbie 1 09-25-2001 12:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration