Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-18-2003, 04:23 PM   #1
Registered: Jan 2003
Location: Sudbury Ontario, Canada
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
Alsa drivers, no surround

Does anyone know how to get surround in alsa?

I configured everything by following this site:

I've played with the alsamixer with out any results.

I have a SB Audigy Gamer, so I'm using the emu10k1 driver. My speakers are Altec 4piece sat. with sub. My modules.conf section look like this (running slack 9, 2.4.21):

# Sound support
alias char-major-116 snd
alias snd-card-0 snd-emu10k1
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

LSMOD looks like this:

snd-pcm-oss 39428 0 (autoclean)
snd-mixer-oss 13592 0 (autoclean) [snd-pcm-oss]
snd-emu10k1 75060 0
snd-pcm 67264 0 [snd-pcm-oss snd-emu10k1]
snd-timer 16708 0 [snd-pcm]
snd-page-alloc 6868 0 [snd-emu10k1 snd-pcm]
snd-ac97-codec 41672 0 [snd-emu10k1]
snd-rawmidi 15360 0 [snd-emu10k1]
snd-util-mem 1616 0 [snd-emu10k1]
snd-seq-device 4372 0 [snd-emu10k1 snd-rawmidi]
snd-hwdep 5248 0 [snd-emu10k1]
snd 34020 0 [snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-pcm snd-timer snd-ac97-codec snd-rawmidi snd-util-mem snd-seq-device snd-hwdep]


Last edited by vexer; 07-18-2003 at 04:25 PM.
Old 07-19-2003, 08:46 PM   #2
Registered: Jan 2003
Location: Sudbury Ontario, Canada
Distribution: Slackware
Posts: 388

Original Poster
Rep: Reputation: 30


PS: Bump
Old 11-01-2003, 02:18 PM   #3
Registered: Sep 2003
Posts: 49

Rep: Reputation: 15
for me, i used gnome-alsamixer and check off surround in the options and it worked for me

remember to use:
alsactl store

to store the settings


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa, surround sound and so on.... BedriddenTech Linux - Hardware 8 01-06-2005 07:40 AM
ALSA Surround for EMU10K1 smehi Slackware 2 03-04-2004 10:44 AM
ALSA Surround for EMU10K1 smehi Linux - Hardware 1 03-03-2004 09:55 PM
How to use Surround soud with Alsa... The SIN Raven Slackware 5 10-27-2003 03:13 PM
alsa doesn't support surround? vexer Linux - Software 0 08-06-2003 10:13 PM

All times are GMT -5. The time now is 04:35 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration