LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-14-2006, 02:26 PM   #1
PaladinOfKaos
LQ Newbie
 
Registered: Mar 2006
Location: Oregon, Earth, Sol System, Orion Arm, Milky Way Galaxy
Distribution: Gentoo
Posts: 13
Blog Entries: 1

Rep: Reputation: 0
alsa 1.0.13rc1 compile issue


I'm trying to build the 1.0.13rc1 ALSA distribution on SLED10 64-bit. The driver and libraries build fine, but I'm having a strange issue building the utilities.

When alsactl is (not) linking, gcc complains about four missing symbols. Here's the relevent output:
Code:
Making all in alsactl
make[1]: Entering directory `/root/alsa-utils-1.0.13rc1/alsactl'
if gcc -DHAVE_CONFIG_H -I. -I. -I../include -g -O2 -MT alsactl.o -MD -MP -MF ".deps/alsactl.Tpo" -c -o alsactl.o alsactl.c; \
then mv -f ".deps/alsactl.Tpo" ".deps/alsactl.Po"; else rm -f ".deps/alsactl.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I../include -g -O2 -MT state.o -MD -MP -MF ".deps/state.Tpo" -c -o state.o state.c; \
then mv -f ".deps/alsactl.Tpo" ".deps/state.Po"; else rm -f ".deps/state.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I../include -g -O2 -MT names.o -MD -MP -MF ".deps/names.Tpo" -c -o names.o names.c; \
then mv -f ".deps/names.Tpo" ".deps/names.Po"; else rm -f ".deps/alsactl.Tpo"; exit 1; fi
gcc -g -O2 -o alsactl alsactl.o state.o names.o -lasound -lm -ldl -lpthread
state.o: In function `add_user_control':
/root/alsa-utils-1.0.13rc1/alsactl/state.c:815: undefined reference to `snd_ctl_elem_tlv_write'
state.o: In function `get_control':
/root/alsa-utils-1.0.13rc1/alsactl/state.c:288: undefined reference to `sdn_ctl_elem_info_is_tlv_readable'
/root/alsa-utils-1.0.13rc1/alsactl/state.c:288: undefined reference to `snd_ctl_elem_info_is_tlv_writable'
/root/alsa-utils-1.0.13rc1/alsactl/state.c:291: undefined reference to `snd_ctl_elem_tlv_read'
collect2: ld returned 1 exit status
make[1]: *** [alsactl] Error 1
make[1]: *** Leaving directory `/root/alsa-utils-1.0.13rc1/alsactl'
make: *** [all-recursive] Error 1
Now for the strange bit. Doing
Code:
objdump -x /usr/lib/libasound.so | grep <undefined reference>
shows that all four missing functions are, in fact, in the library. Any ideas? Is this a SLED issue? a 64-bit issue?

Last edited by PaladinOfKaos; 09-14-2006 at 03:03 PM.
 
Old 09-16-2006, 04:14 AM   #2
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
YOu need to build and install the alsa-libs before building the utils. It is also recommended that you build and install each package in this order: drivers, libs, utils, (any other alsa package). The libs depend on headers from the drivers, and the utils depend on headers from the libs. Since all of these are moving targets, it is necessary to build and install each in the proper order.
 
Old 09-16-2006, 02:06 PM   #3
PaladinOfKaos
LQ Newbie
 
Registered: Mar 2006
Location: Oregon, Earth, Sol System, Orion Arm, Milky Way Galaxy
Distribution: Gentoo
Posts: 13
Blog Entries: 1

Original Poster
Rep: Reputation: 0
That's what I had done. I tried the same thing on RHDT4U4, and it built fine (after commenting out redundant typedefs in the driver). It seems to be an issue with ld on SLED10.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa issue Mow Slackware 10 08-12-2005 09:49 AM
ALSA Issue Centinul Linux - Hardware 2 07-02-2005 01:47 AM
Can't compile Alsa starionwolf Slackware 23 02-18-2005 01:11 PM
Alsa driver won't compile ssfrstlstnm Linux - Hardware 2 02-15-2005 08:11 PM
compile alsa 0.5.12a under RH 8.0 ? null_mind Linux - Hardware 0 01-01-2003 10:07 PM


All times are GMT -5. The time now is 01:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration