LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-19-2003, 11:28 AM   #1
liguorir
Member
 
Registered: May 2003
Posts: 256

Rep: Reputation: 30
alias sound-card-0 i810_audio


Sound documentation saids to do the following:

alias snd-card-0 snd-<soundcard-name>
alias sound-slot-0 snd-card-0

However, modules.conf has this unsilimar alias:

alias sound-card-0 i810_audio

Why?

Also modules.conf has the following statements:
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null2>&1 || :

and

pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null2>&1 || :


What do these statements do, and can they be removed.

I also think the the i810_audio driver is not the one I need, Is there a generic one, and is there any way of determining what sound hardware is in my system?
 
Old 06-19-2003, 02:38 PM   #2
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 587

Rep: Reputation: 32
A lot of questions .... :)

1. --alias matter--
the 'sound-slot-0' is token looked for by soundcore module;
so it is the beginning of "alias chain"
next you can use any names so the lines like
alias sound-slot-0 abcd
alias abcd defg
alias defg xxxx
are OK but on condition that the chains is finished (here: with 'xxxx') with the name of your sound driver
look at /lib/modules/<kernel_version>/ directory and subdirectories (mine is just 'sound') for the file xxxx.o to check if you have the sound module and how it is called (you probably see a lot of modules, which one is yours -see below)


2.-- post-install & pre-remove ---
is the action (program) just after (or just before respectively) loading/removing the module;
is it important? generally- it depends on the command; this time I don't think so (try: 'aumix-minimal --help')

3. --proper audio module--
investigate results of : 'cat /proc/pci|grep audio'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Which alias for loading the i810_audio using OSS ? gt73 Linux - Hardware 1 03-29-2004 03:32 AM
Sound module i810_audio not loading on startup MadCactus Linux - General 3 12-22-2003 02:22 AM
No Sound With i810_audio jwbrown77 Linux - General 13 08-05-2003 01:50 PM
sound problem (i810_audio/ac97) linen0ise Slackware 3 07-09-2003 10:35 AM
No Sound With i810_audio jwbrown77 Linux - Hardware 2 02-04-2003 05:51 PM


All times are GMT -5. The time now is 07:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration