LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Akonadi with Google Calendar/Contacts sync (http://www.linuxquestions.org/questions/linux-software-2/akonadi-with-google-calendar-contacts-sync-771572/)

Vetruvet 11-25-2009 05:51 PM

Akonadi with Google Calendar/Contacts sync
 
I'm trying to get my Google Calendar and Contacts to sync with my Linux system (openSUSE 11.2 x64) through Akonadi.

I've considered using GCalDeamon, but that seems like a hassle for the PC (maybe not for the user once it's set up) to sync (running a local LDAP server, and creating temp. stuff). Perhaps I'm missing something about GCalDeamon, so maybe someone can enlighten me.

So I found libgcal and akonadi-googledata packages for openSUSE and installed them through YaST. I'm pretty sure they are the latest versions (libgcal-0.9.3 and akonadi-googledata-1.0.1). I can see the resource agent in Akonadi Configuration (in System Settings). When I add it, it asks for the username and password, and I put them in.

However, after maybe 3 minutes (of, I assume, retrying), it says "Invalid password". I double-check the password, try my username again and then my username with @gmail.com on the end. I still get the same result.

Just to make sure, I uninstalled the packages, and compiled from source, but still got the same result. For easier updating, I uninstalled the source-installed binaries and reinstalled from YaST.

I figure that the KDE team wants to make all (correct me if I'm wrong) PIM apps utilize Akonadi, and that doesn't seems like a bad thing.

Has anybody gotten Akonadi to sync with Google Calendar/Contacts??? Any help is appreciated.

In case this helps, I'm getting the two packages from this repo:
http://download.opensuse.org/reposit...+KDE4_Factory/

EDIT: I checked the kde site, and apparently, google calendar and contact support is done: http://techbase.kde.org/Schedules/KD...re_Plan#kdepim


All times are GMT -5. The time now is 06:12 PM.