LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-08-2007, 01:14 AM   #1
binarybob0001
Member
 
Registered: Dec 2004
Distribution: Debian Wheezy
Posts: 441

Rep: Reputation: 30
Talking Ahhh, XSane, UDEV and Device Node Permissions?


I have an Epson Perfection 1670 scanner. I'm using Slackware 11.0 with 2.6.16.9 kernel installed with udev enabled. XSane runs fine as root, but I can't seem to give normal users permission to use the scanner even if I add them to the group scanner. To verify that I editted my group and passwd files correctly, please look at them.
/etc/group
Code:
scanner::93:1000,1001
/etc/passwd
Code:
bobby:x:1000:100:,,,:/home/bobby:/bin/bash
joe:x:1001:100:,,,:/home/joe:/bin/bash
Do bobby and joe belong to group scanner? If not now that I have udev installed there should be some way to figure out what device node it naturally assigns to the scanner. I thought it would be sg0, but I just don't know. Thanks to anyone who can help.
 
Old 04-08-2007, 02:06 AM   #2
dugas
Member
 
Registered: Jul 2004
Location: louisiana
Distribution: fedora 4/kubuntu
Posts: 116

Rep: Reputation: 15
Udev

You may have to make a UDEV rule for your scanner. An example of one I use for my UPS is:

KERNEL="hiddev*", NAME="usb/hiddev%n"
(NOTE: Place this line in /etc/udev/rules.d/50-udev.rules)

This will create a rule for all hidden device entries, which may or may not be what type of device your scanner is.
 
Old 04-10-2007, 12:16 AM   #3
binarybob0001
Member
 
Registered: Dec 2004
Distribution: Debian Wheezy
Posts: 441

Original Poster
Rep: Reputation: 30
Thanks for the help. I actually got it working by just typing in my name rather than the number.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing permissions on images created by XSANE ajkrishock Fedora 1 10-26-2006 06:07 AM
Created new partition. No device node for it. udev Slack10.2 myslfkeepslippin Linux - General 5 02-01-2006 02:16 PM
udev does not create scsi device node maenho Linux - Software 0 11-27-2004 05:08 AM
Why does xsane scanner ask me which device harry_fine Linux - Hardware 0 09-03-2004 08:35 AM
udev : framebuffer device (/dev/fb0) default permissions keefaz Slackware 6 07-04-2004 06:54 PM


All times are GMT -5. The time now is 08:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration