Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-29-2003, 03:24 PM   #1
Registered: Jan 2003
Location: Sudbury Ontario, Canada
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
AGP support Disabled!

I installed the nvidia 4496 driver and ever since I first installed the driver I've had ut and ut2k3 crash on me and crappy framerates.

After updating the driver to 4496, I read the readme, and saw that /proc/driver/nvidia/agp/status tells me the status of my AGP support. Here is the result.

root@TheKeep:/proc/driver/nvidia/agp# cat status
Status: Disabled

NvAGP is set to "1" in XF86Config, dmesg gives me this:
root@TheKeep:/proc/driver/nvidia/agp# dmesg |grep agp
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Detected Via Apollo Pro KT400 chipset
agpgart: unable to determine aperture size.


# Nvidia options support
options agpgart agp_try_unsupported=1
options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1
alias char-major-195 nvidia

I'm desperate to get AGP support for this PC!

Please help me!

Old 07-29-2003, 04:00 PM   #2
Senior Member
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59

andys the man, so if thats what he says when pertaining to the nvidia drivers than thats what shall be done

and heres a quote from another thread:
The problem was solved in the following way:

1. Recompiled the kernel without AGPGART support (it was previously compiled in monolithically - not as a module). I think this was the cause of the problem in the first place.

2. Set Option "NvAgp" "1" in XF86Config

rebooted after this and it still didn't work. Then we decided to:

3. Reinstall the driver

I'm not certain why step 3 was required, but it was...

Anyhow, now it works and I am very happy - thanks.
so i'll leave you with that...GL!
Old 07-29-2003, 06:01 PM   #3
Registered: Jan 2003
Location: Sudbury Ontario, Canada
Distribution: Slackware
Posts: 388

Original Poster
Rep: Reputation: 30
I did what he said, I recompiled with agpgart as a module and still I got the same error


I've also just recompiled my kernel (second time) with out AGPgart at all. And still nothing.

Last edited by vexer; 07-29-2003 at 06:20 PM.
Old 08-18-2003, 01:00 PM   #4
LQ Newbie
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
i had exactly the problem than your (i gotta VIA KT4000, geforce fx 5600) ...

I i found that when XFREE was launch, it was unable to play with MTRR ...

look if u got this in the kernel

PROCESSOR TYPE AND FEATURE[*] MTRR (Memory Type Range Register) support

seem to work on mine computer

(if u want more help use mail ;-)


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
AGP support jamaso Slackware 1 02-15-2006 07:53 PM
AGP Slot support in suse 9.2 Infernal211283 Linux - Hardware 1 02-20-2005 05:09 AM
How to use AGP 8x Support ? cartridge Linux - Hardware 2 02-16-2005 02:06 AM
AGP support .... ? hirts123 Mandriva 5 02-05-2005 04:54 PM
Next! AGP 2.6.1 support... darklogik_org Slackware 6 01-26-2004 02:25 AM

All times are GMT -5. The time now is 10:09 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration