LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-08-2008, 10:00 AM   #1
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Rep: Reputation: 30
Adventures with no picture in VLC and compiling FFMPEG


Whenever I try to open videos with VLC, Video doesn't play.
The audio plays fine. My other video players can play them.

I've tried going into >preferences>output modules> advanced and trying different modes starting with X11 and trying others.

I tried removing vlc and ffmpeg

Code:
dpkg --force-depends --purge vlc ffmpeg
and
Code:
rm -rf ~/.vlc/
and reinstalling to no success.

I've also tried
Code:
apt-get source -b ffmpeg vlc
And VLC fails with the error messsage:
Code:
Your FFmpeg library doesn't have the needed img_resample() function. You should rebuild it with software scaler disabled
(another suggestion?)

So I try to install ffmpeg from subversion with dhmake:
(should I choose single/multiple/ or library?)
Code:
#dh_make --create-orig
#dpkg-buildpakage -rfakeroot
make[1]: *** No rule to make target `libavutil/../config.mak'.  Stop.
 
Old 11-08-2008, 11:01 AM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
You need to do what is says and build ffmpeg without swscaler support, probably using './configure --disable-swscaler'.
 
Old 11-08-2008, 11:02 AM   #3
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,192

Rep: Reputation: 120Reputation: 120
I had this happen to me on vlc 32 bit after I was messing around with the video stuff. Have you tried within vlc using Settings->Preferences->Reset All?
 
Old 11-08-2008, 11:20 AM   #4
jiml8
Senior Member
 
Registered: Sep 2003
Posts: 3,171

Rep: Reputation: 114Reputation: 114
http://www.linuxquestions.org/questi...?highlight=vlc
 
Old 11-08-2008, 11:31 AM   #5
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by jiml8 View Post
Following this is useful; it boils down to:
Code:
 vlc -v --reset-plugins-cache
which highlights the following:
Code:
cannot load module `/usr/lib/vlc/codec/libffmpeg_plugin.so' (/usr/lib/vlc/codec/libffmpeg_plugin.so: undefined symbol: img_resample)
 
Old 11-08-2008, 03:37 PM   #6
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by H_TeXMeX_H View Post
You need to do what is says and build ffmpeg without swscaler support, probably using './configure --disable-swscaler'.
You could be right. I'll try that as soon as I can get ffmpeg to build (and then I'll build again with correct configuration).

Code:
libavdevice/Makefile:1: libavdevice/../config.mak: No such file or directory
libavformat/Makefile:1: libavformat/../config.mak: No such file or directory
libavcodec/Makefile:1: libavcodec/../config.mak: No such file or directory
libavutil/Makefile:1: libavutil/../config.mak: No such file or directory
make[1]: *** No rule to make target `libavutil/../config.mak'.  Stop.
 
Old 11-09-2008, 03:42 AM   #7
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
Have you tried using the the standard './configure; make; make install' ? It works for me that way.
 
Old 11-09-2008, 09:37 AM   #8
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
I would like to use dh_make for the ease of adding and removing. I can check to see if checkinstall is any easier.


As far as the default configuration goes; I was thinking I should enable at list a few of these. I haven't had a chance to look them all up.

Code:
libamr-nb support         no
libamr-wb support         no
libdc1394 support         no
libdirac enabled          no
libfaac enabled           no
libfaad enabled           no
libfaad dlopened          no
libgsm enabled            no
libmp3lame enabled        no
libnut enabled            no
libschroedinger enabled   no
libspeex enabled          no
libtheora enabled         no
libvorbis enabled         no
libx264 enabled           no
libxvid enabled           no
 
Old 11-09-2008, 10:37 AM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
sure you should enable some, but remember to get the dependencies first
 
Old 11-09-2008, 10:46 AM   #10
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
I used checkinstall things seem to have worked. I'm using ffmpeg right now and it works. I'll check on compiling vlc.

--Side note: It seems to me that dh_make worked a little better at making debs a while ago, but recently I've had more success with checkinstall.
 
Old 11-09-2008, 10:56 AM   #11
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
I'm compiling VLC now. For my configuration I'll use :

Code:
./configure --enable-x11 --enable-xvideo --disable-gtk --enable-sdl --enable-avcodec --enable-avformat --enable-swscale --enable-mad --enable-libdvbpsi --enable-a52 --enable-libmpeg2 --enable-dvdnav --enable-faad --enable-vorbis --enable-ogg --enable-theora --enable-faac --enable-mkv --enable-freetype --enable-fribidi --enable-speex --enable-flac --enable-live555 --with-live555-tree=/usr/lib/live --enable-caca --enable-skins --enable-skins2 --enable-alsa --disable-kde --enable-qt4 --enable-ncurses --enable-release
Actually I noticed that config would be wrong for me. I'm using KDE; I don't know how much that affects things. Instead I'll use:
Code:
./configure --enable-x11 --enable-xvideo --disable-gtk --enable-sdl --enable-avcodec --enable-avformat --enable-swscale --enable-mad --enable-libdvbpsi --enable-a52 --enable-libmpeg2 --enable-dvdnav --enable-faad --enable-vorbis --enable-ogg --enable-theora --enable-faac --enable-mkv --enable-freetype --enable-fribidi --enable-speex --enable-flac --enable-live555 --enable-caca --enable-skins --enable-skins2 --enable-alsa --enable-kde --enable-ncurses --enable-qt4 --enable-release
Oh,I also wanted to export some GCC flags for the architecture. I'll use:
Code:
export CFLAGS="-march=athlon64 -mtune=athlon64"
(which can also be added in the vlc-config file.)But it seems as if there should be some more flags.

In the mean time I notice I've hosed noatun. It worked well until yesterday and now even if I start it on the command line it quietly dies...

Last edited by donnied; 11-09-2008 at 12:42 PM.
 
Old 11-09-2008, 11:17 AM   #12
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
Well for the .configure of ffmpeg in order to enable swscale gpl has to be enabled. I don't know which is better. I like the sound of having swscale in vlc so I'll try that.

For ffmpeg:
Code:
./configure --enable-gpl --enable-swscale
 
Old 11-09-2008, 12:18 PM   #13
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266Reputation: 1266
Either way you must either disable swscale in both or enable it in both.
 
Old 11-09-2008, 12:29 PM   #14
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
Right. What do you think about using swscale?

Now when I make VLC I get the error message:
Code:
/usr/bin/ld: /usr/local/lib/libavcodec.a(allcodecs.o): relocation R_X86_64_32 against `aasc_decoder' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/libavcodec.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
I'm not sure what to do about that.

Last edited by donnied; 11-09-2008 at 12:49 PM.
 
Old 11-09-2008, 01:02 PM   #15
donnied
Member
 
Registered: Oct 2006
Distribution: Debian x64
Posts: 198

Original Poster
Rep: Reputation: 30
Code:
Your FFmpeg library doesn't have the needed img_resample() function. You should rebuild it with software scaler disabled
Adding
Code:
 
--enable-share
seemed to fix that problem. I got VLC built and installed but then I got the following message:
Code:
vlc: error while loading shared libraries: libvlc.so.2: cannot open shared object file: No such file or directory

Last edited by donnied; 11-09-2008 at 07:27 PM.
 
  


Reply

Tags
compile, ffmpeg, svn, vlc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
adventures compiling, installing, and insmod? deiz92 Linux - Newbie 11 09-03-2006 09:53 PM
Video picture off in VLC, Kaffeine, and Mplayer plugin biosol Suse/Novell 2 06-07-2006 11:40 PM
Can't get any picture with vlc FireInTheDark Linux - Newbie 1 04-13-2006 01:01 PM
Problem with ffmpeg compiling vlc Gerard_2009 Linux - Software 3 12-11-2005 04:46 PM
Adventures in Woody-land (compiling and installing modules) iraysyvalo Debian 1 07-16-2003 09:13 AM


All times are GMT -5. The time now is 09:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration