LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-07-2007, 02:22 AM   #1
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Rep: Reputation: 31
adept database is already locked ?


Ok, here is the exact messege..... "You will not be able to change your system settings in any way (install, remove or upgrade software), because another process is using the packaging system database (probably some other Adept application or apt-get or aptitude). Please close the other application before using this one."

Here is the output of ps -A

PID TTY TIME CMD
1 ? 00:00:01 init
2 ? 00:00:00 migration/0
3 ? 00:00:00 ksoftirqd/0
4 ? 00:00:00 watchdog/0
5 ? 00:00:00 events/0
6 ? 00:00:00 khelper
7 ? 00:00:00 kthread
30 ? 00:00:00 kblockd/0
31 ? 00:00:00 kacpid
32 ? 00:00:00 kacpi_notify
175 ? 00:00:00 kseriod
201 ? 00:00:03 pdflush
202 ? 00:00:03 kswapd0
203 ? 00:00:00 aio/0
2054 ? 00:00:00 ksuspend_usbd
2055 ? 00:00:00 khubd
2062 ? 00:00:00 ata/0
2063 ? 00:00:00 ata_aux
2116 ? 00:00:00 scsi_eh_0
2117 ? 00:00:00 scsi_eh_1
2292 ? 00:00:00 scsi_eh_2
2293 ? 00:00:00 usb-storage
2501 ? 00:00:00 kjournald
2701 ? 00:00:00 udevd
3699 ? 00:00:00 kpsmoused
3738 ? 00:00:00 ivtv_vbi/0
3739 ? 00:00:00 ivtv_yuv/0
4202 ? 00:00:00 kjournald
4204 ? 00:00:02 kjournald
4533 tty4 00:00:00 getty
4534 tty5 00:00:00 getty
4539 tty2 00:00:00 getty
4540 tty3 00:00:00 getty
4541 tty1 00:00:00 getty
4542 tty6 00:00:00 getty
4786 ? 00:00:00 acpid
4880 ? 00:00:00 syslogd
4936 ? 00:00:00 dd
4938 ? 00:00:00 klogd
4959 ? 00:00:00 dbus-daemon
4975 ? 00:00:00 hald
4976 ? 00:00:00 hald-runner
4982 ? 00:00:00 hald-addon-keyb
4983 ? 00:00:00 hald-addon-keyb
4984 ? 00:00:00 hald-addon-keyb
4985 ? 00:00:00 hald-addon-keyb
4987 ? 00:00:00 hald-addon-cpuf
4988 ? 00:00:00 hald-addon-acpi
5000 ? 00:00:01 hald-addon-stor
5007 ? 00:00:01 hald-addon-stor
5021 ? 00:00:00 dhcdbd
5036 ? 00:00:00 NetworkManager
5054 ? 00:00:00 avahi-daemon
5055 ? 00:00:00 avahi-daemon
5071 ? 00:00:00 NetworkManagerD
5166 ? 00:00:00 hpiod
5169 ? 00:00:00 python
5204 ? 00:00:00 dhclient
5415 ? 00:00:00 kondemand/0
5542 ? 00:00:00 hcid
5559 ? 00:00:00 krfcommd
5596 ? 00:00:00 atd
5610 ? 00:00:00 cron
5683 ? 00:00:00 kdm
5702 tty7 00:02:09 Xorg
5717 ? 00:00:00 kdm
5734 ? 00:00:00 x-session-manag
5773 ? 00:00:00 ssh-agent
5776 ? 00:00:00 dbus-launch
5777 ? 00:00:00 dbus-daemon
5814 ? 00:00:00 start_kdeinit
5815 ? 00:00:00 kdeinit
5818 ? 00:00:00 dcopserver
5821 ? 00:00:00 klauncher
5823 ? 00:00:04 kded
5828 ? 00:00:00 kwrapper
5830 ? 00:00:00 ksmserver
5831 ? 00:00:08 kwin
5833 ? 00:00:04 kdesktop
5835 ? 00:00:08 kicker
5841 ? 00:00:00 kio_file
5853 ? 00:00:01 kweatherservice
5864 ? 00:00:00 artsd
5868 ? 00:00:00 kaccess
5874 ? 00:00:00 konqueror
5875 ? 00:00:01 knotify
5878 ? 00:00:00 passkey-agent
5883 ? 00:00:00 klipper
5884 ? 00:00:00 konqueror
5886 ? 00:00:00 knetworkmanager
5889 ? 00:00:00 kbluetoothd
5928 ? 00:00:00 gconfd-2
5951 ? 00:00:18 gaim
6067 ? 00:00:00 kio_uiserver
6100 ? 00:01:44 firefox-bin
6423 ? 00:00:00 kmix
7298 ? 00:00:00 kdesud
7349 ? 00:00:00 artsd
7364 ? 00:00:01 konsole
7365 pts/1 00:00:00 bash
7881 ? 00:00:00 kio_file
7882 ? 00:00:00 kio_file
7887 ? 00:00:00 kio_file
7889 ? 00:00:00 kio_file
7890 ? 00:00:00 kio_file
7891 ? 00:00:00 kio_file
7896 ? 00:01:24 k9copy
7903 ? 00:00:00 kio_media
7912 ? 00:00:00 kio_file
8187 ? 00:00:00 kdeinit
8191 ? 00:00:00 dcopserver
8194 ? 00:00:00 klauncher
8197 ? 00:00:00 kded
8238 ? 00:00:00 knotify
8344 ? 00:00:00 pdflush
8588 pts/1 00:00:00 ps



Yeah, I know there are a few things I need to turn off, or rather prevent from starting, especially considering I don't even use any bluetooth stuff. Anyway, I'm working on that stuff, as this is a new install. Anyway. I've logged out and back in, and I have no idea what process has the apt database locked, every damn time. I'm using Kubuntu fiest, in case it matters. I had been getting some errors that roxxen fonts or something like that wasn't installing correctly, but I wasn't trying to install them, and everything else was working, so I ignored it. Maybe that was a mistake, I'm not sure. Anyway, could someone please point out the error of my ways.....

Question 2, I go to stop services from starting up, I stop them on run level 2. Do I have to go through and do it over and over again for every damn run level ? Please don't tell me that's the case. Please. I will lose respect for linux coders, and Ubuntu in particular if that's the case. It's something I would expect from windows.

Ok, found the fix for problem number one....

sudo dpkg --configure -a

Sorry to bother you guys about that one.....guess that's fixed, so far anyway.....

Last edited by budword; 07-07-2007 at 02:27 AM.
 
Old 07-07-2007, 03:02 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,017

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
You answered Q1 yourself.
Q2:
Quote:
Question 2, I go to stop services from starting up, I stop them on run level 2. Do I have to go through and do it over and over again for every damn run level ?
No, not if you are not using those other runlevels. In (K)ubuntu, runlevel 2 is the graphical environment, if this is what you usually boot to, setting the services you need for this level only is sufficient.
 
Old 07-07-2007, 08:57 PM   #3
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Original Poster
Rep: Reputation: 31
The bluetooth stuff still starts up. I don't have any bluetooth dev attached to this pc. I turned it off via the system services part of systmem settings. I only turned it off for run level 2 though. Can anyone tell me whay it's still starting up ?
 
Old 07-08-2007, 04:21 AM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,017

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
Go back to "System Services". Look at the entry for bluez-utils Is it set to start at boot? If so change this to "No".
 
Old 07-08-2007, 01:04 PM   #5
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Original Poster
Rep: Reputation: 31
It is not set up to boot, on run level 2 at least. That is the least of my worries right now though. I don't seem to know my own password now. sudo doesn't work, and I can't install any new programs. I can't even change my password. Is it possible my box got hacked ? Or is it more likely I just screwed something up somewhere ? My box is a 100% uptodate Kubuntu fiesty desktop.

Thank you for your help....

David
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adept launch error, something else using the database cormack Ubuntu 1 06-03-2007 05:53 PM
Adept Database Locked Optiker Ubuntu 3 10-19-2006 12:22 PM
urpmi database locked? otto k Mandriva 9 05-17-2005 11:37 AM
RPM database locked cepheus Linux - Newbie 1 10-23-2004 01:43 PM
urpmi database locked! /home/kyle Mandriva 3 03-09-2004 06:05 AM


All times are GMT -5. The time now is 01:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration