LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-30-2003, 11:20 PM   #1
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Rep: Reputation: 30
Add Fluxbox to Redhat 9


I've searching the forums and Google but I'm still stumped. I can't add Fluxbox to my list of windows managers. I added this to /etc/X11/gdm/Sessions named fluxbox:
#!/bin/bash
/usr/local/bin/fluxbox

and it didn't work. I checked the other sessions (KDE, GNOME) and I saw this:
#!/bin/bash

exec /etc/X11/xdm/Xsession kde

How do I add fluxbox?
 
Old 07-31-2003, 05:06 AM   #2
KaZeR
LQ Newbie
 
Registered: Jul 2003
Posts: 4

Rep: Reputation: 0
Arrow

Fluxbox is great. To have it working, simply issue the following into your home directory :

echo 'exec fluxbox' >> .xinitrc

This will add the exec fluxbox command to the xinitrc file. That's the best way to start fluxbox. Notice that you will need to add this command to every users on your box who wish to use flux.

Hope this helps

Cheers.
 
Old 07-31-2003, 08:31 AM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
KaZer's suggestion may, or may not, work depending how you log in. If you use a graphical login manager like kdm or gdm, then the file you added to the .../Sessions should work if you add exec fluxbox in place of your /usr/local/bin/fluxbox line. The graphical login managers tend to ignore .xinitric so adding exec fluxbox to that may not do the trick.

However, if you log in through the text console and use startx to start your graphical environment, then editing .xinitric is the way to go. However, I would strongly suggest editing it with a text editor like pico or gedit (if you are in a graphical environment) since simply tacking exec fluxbox onto the end (as KaZer's command would do) could have unwanted results. For example, if you .xintiric already has exec startkde as the last line, putting exec fluxbox after that isn't going to do much except maybe screw up KDE.
 
Old 08-03-2003, 03:32 PM   #4
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Original Poster
Rep: Reputation: 30
I tried editing /etc/X11/gdm/Sessionsfluxbox to show this:
exec /etc/X11/xdm/Xsession fluxbox
and this:
exec fluxbox

Neither worked. I tried using the precompiled Redhat rpms which setup gdm for me but it was an older version of Fluxbox that crashed incessantly.
 
Old 08-04-2003, 02:51 PM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
exec /etc/X11/xdm/Xsession fluxbox
That didn't work because that isn't where the fluxbox executable is (at least I doubt it)

Quote:
exec fluxbox
That should have worked IF the fluxbox executable is on your PATH. To find out where the executable is try which fluxbox. If you don't get anythign back from that, they something may be wrong with the installation.

How did you install fluxbox anyway? I know you said that you used an RPM of an old version, but did you compile one of the newer ones?
 
Old 09-13-2003, 10:48 AM   #6
marc_omorain
LQ Newbie
 
Registered: Sep 2003
Posts: 12

Rep: Reputation: 0
I am having the same problem as bax.

Here is my /etc/X11/gdm/Sessions/Fluxbox :
Code:
#!/bin/bash
exec /usr/local/bin/fluxbox
Has anyone managed to run fluxbox under redhat 9?

Edit:

I managed to get it working!

http://www.nxsupport.net/forums/show...astpost&t=6349

You need to chmod a+x /etc/X11/gdm/Sessions/Fluxbox

Last edited by marc_omorain; 09-13-2003 at 10:52 AM.
 
Old 10-15-2003, 01:00 AM   #7
tw33k
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Help!

[root@localhost fluxbox-0.1.14]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/home/tw33k/fluxbox-0.1.14/missing: Unknown `--run' option
Try `/home/tw33k/fluxbox-0.1.14/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH

^that is what happens when I type ./configure, as su, in the correct folder,
what do i do?
 
Old 10-15-2003, 03:57 AM   #8
macewan
Senior Member
 
Registered: Jan 2002
Distribution: Ubuntu, Debian
Posts: 1,055
Blog Entries: 1

Rep: Reputation: 45
http://www.macewan.org/howto/getting...redhat%208.txt


here's how i did it on redhat 8

may or may not help for rh9
 
Old 10-15-2003, 09:09 AM   #9
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
Hi bax....check out this thread..

http://www.linuxquestions.org/questi...=fluxbox+guide

Hope that solves your concerns..

Regards,

amit
 
Old 10-15-2003, 09:27 AM   #10
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Rep: Reputation: 31
I have installed flux box in RH9. You just have to compile and create the fluxbox binary. Then, you have to find the fluxbox path, which is usually /usr/local/fluxbox.

So, add the following to your /etc/X11/Sessions/fluxbox

#! /bin/bash

exec /usr/local/fluxbox

and it is done with.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how do I add icons to fluxbox desktop? CPUFreak91 Linux - Newbie 2 07-19-2005 07:08 PM
How to add gtk2 to fluxbox? flamesrock Linux - Software 4 02-08-2005 05:43 PM
How to add Fluxbox to GDM Duffy Slackware 4 04-21-2004 12:47 AM
add mozilla to fluxbox arktype Linux - Newbie 2 10-29-2003 10:37 PM
add fluxbox ? elite Linux - Newbie 1 04-10-2002 09:28 PM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration