LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Acroread won't print in KDE (http://www.linuxquestions.org/questions/linux-software-2/acroread-wont-print-in-kde-528627/)

Ashrack 02-13-2007 07:01 AM

Acroread won't print in KDE
 
Thus far I've been using KPDF and it prints OK. But because it lacks the option to print multiple pages per sheet I'm trying now ACROREAD. But acroread won't even start printing.

This is what I think is the reason for not printing. This is the command that gets send to printer in ACROREAD:
Code:

/usr/bin/lpr -P HP840c -o PageSize=A4
And so I installed LPR and MAGICFILTER.

But now when I click on PRINT and then OK I get something being load but the printer still won't start.

ps. I also installed ASPFILTER and removed MAGICFILTER but still didn't help

uselpa 02-13-2007 01:38 PM

Try using "kprinter" (without any options) as the print command, instead of "lpr". That should give you the KDE dialog.

Ashrack 02-13-2007 03:35 PM

It didn't give me the dialog nor did it start printing.

Ashrack 02-17-2007 03:26 AM

up
any help would be hot :)

bosewicht 02-17-2007 03:30 AM

have you tried launching the app from bash and see what it returns when you try sending it to the printer. It may help you figure out what is wrong

Ashrack 02-17-2007 04:30 AM

nothing gets written to the bash:(

bosewicht 02-17-2007 04:46 AM

have you searched around to be sure you have it configured correctly?

http://ubuntuguide.org/wiki/Ubuntu_E...m_Adobe_Reader

Ashrack 02-18-2007 09:02 AM

I found the problem and got another problem:(
This is the line that must be set:
Code:

/usr/bin/kprinter -P HP840c -o PageSize=A4
B4 I was only using '/usr/bin/kprinter/' and that didn't work.
But now the thing is that when I restart ACROREAD it doesn't remember the 'printer command'. It just gives me the default setting:
Code:

/usr/bin/lpr -P HP840c
instead of:
Code:

/usr/bin/kprinter -P HP840c -o PageSize=A4
Any way to fix this?

BOSEWICH
I did read that but I wanted to use the KDE's native KPRINTER.

bosewicht 02-18-2007 04:05 PM

do a search for .....app-defaults/AcroRead.ad You can change the lpr command in there.

Ashrack 02-19-2007 03:31 AM

I changed this file:
Code:

/usr/share/apps/kdisplay/app-defaults/AcroRead.ad
so that it looks like this now:
Code:

nspluginviewer*lprCommand: /usr/bin/kprinter -P HP840c -o PageSize=A4
acroread*lprCommand: /usr/bin/kprinter -P HP840c -o PageSize=A4
Acroread.foreground:              WINDOW_FOREGROUND
Acroread.background:              WINDOW_BACKGROUND
AcroRead.borderColor:              WINDOW_FOREGROUND
AcroRead.XmScreen.background:      WINDOW_BACKGROUND
AcroRead.XmScreen.borderColor:    WINDOW_FOREGROUND

But Acroread still gives me the LPR printer command.


All times are GMT -5. The time now is 01:38 AM.