LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-05-2003, 04:52 PM   #1
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Rep: Reputation: 30
Acrobat 5 in Red Hat 9


Something that I'm struggling with as a newbie, but a Red Hat issue. I like Acrobat Reader over the xpdf reader and installed it. The issue has to do with the defualt environmental variable LANG in Red Hat. Most distro's use the universal default of =C but Red Hat has for some time used LANG=en_US.UTF-8. Acrobat reader does not support UTF-8 unicode so to successfully call up the program you must set the LANG variable to =C before the call up. That works fine and I have it scripted into my shortcuts to acroread.

But to make the plug-in work in Mozilla, I have to find a way to change the LANG=C automatically or to just CHANGE it at boot-up and always have it LANG=C.

My question is twofold. First, can I find a way to make the plug-in work by some scripting magic somewhere? And lacking that, is it possible (and how do I?) and advisible to put LANG=C in the start-up files somewhere. I have cruised a lot of files and still haven't found where Red Hat set's that variable. I have looked at the bashrc, bash_profile, both in the /boot and /etc directories (some of the file just direct the output to the other files.....and all over the place. Red Hat is kind of unorganized in this area.

Does anyone know the solution to this. If not, it's not a big deal as I can always just open documents in xpdf when browsing and I can use Acrobat for opening documents when not browsing. If I set LANG=C it's fine until I close the program then LANG slips back to it's default value.

Thanks.
 
Old 06-05-2003, 05:27 PM   #2
zmedico
Member
 
Registered: Feb 2002
Location: Mission Viejo, California, USA
Distribution: Gentoo
Posts: 707

Rep: Reputation: 30
Re: Acrobat 5 in Red Hat 9

see /etc/sysconfig/i18n
 
Old 06-05-2003, 05:52 PM   #3
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Original Poster
Rep: Reputation: 30
Zemedico!

Thanks....it would have taken forever to find that file. I changed it, I can now normally open the program...I changed my link to a simple one, and the plug-in works perfectly. This forum is GREAT and I thank you very much.

One more question....NOW that my GLOBAL and FULL TIME setting of LANG=C is there, what implications will that have? Will I see any problems on any other programs? I am still unclear on what all of the UTF codes are and how they differ. So if something wanted a UTF-8 setting now, will that be a problem?

What the heck am I talking about? Anyway, if I can just get a simple answer to what the IMPLICATIONS of changing your environmental varible from "en_US.UTF-8" to "C" for "everything" because its global are, I will be satisfied. For now, it FIXED acrobat and it's plug-in, and I see no other ill effects.

Thanks again and I look forward to someone giving me a little more on the LANG variable and what it REALLY does (Google wasn't much help!)
 
Old 06-05-2003, 05:56 PM   #4
zmedico
Member
 
Registered: Feb 2002
Location: Mission Viejo, California, USA
Distribution: Gentoo
Posts: 707

Rep: Reputation: 30
If you only use ASCII characters, it makes no difference. UTF-8 is great because it allows you to work with characters from almost every language in the world.

If you're really interested you can read the man pages for unicode and utf-8, and there's a Unicode howto over at the Linux Documentation Project:

http://www.tldp.org

Last edited by zmedico; 06-05-2003 at 06:01 PM.
 
Old 06-05-2003, 06:17 PM   #5
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Original Poster
Rep: Reputation: 30
Thanks so much for the info. I guess I'll just leave it as is....see if the next version of Reader will work in the other environment, and if I need to, I know how to change back to Unicode...

I thank you again for your help.
 
Old 06-05-2003, 08:30 PM   #6
macewan
Senior Member
 
Registered: Jan 2002
Distribution: Ubuntu, Debian
Posts: 1,055
Blog Entries: 1

Rep: Reputation: 45
su

vi /usr/local/Acrobat5/bin/acroread

* add this *

LANG=en_US
export LANG
 
Old 06-05-2003, 08:40 PM   #7
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Original Poster
Rep: Reputation: 30
Hi macewan:

OK....I am now wondering what that will do. I have already changed my SYSTEM to LANG=C which seems to be no problem....Acrobat is behaving as it's supposed to now. I thought my problem was solved. Now, if I edit Acroread and add what you specify, are you saying that will solve my problem if I go BACK to the original configurationz? Or are you saying to add this IN ADDITION to my changing the i18n file?

I guess I could just try a bunch of combinations to get the results I'm looking for. Giving up the UTF-8 enfironment doesn't seem to be a problem, as I see that several other distributions have this as the default.

Please clarify what you are directing me to do with this edit of the acroread file....

Thanks, in advance!
 
Old 06-05-2003, 08:53 PM   #8
zmedico
Member
 
Registered: Feb 2002
Location: Mission Viejo, California, USA
Distribution: Gentoo
Posts: 707

Rep: Reputation: 30
If mozilla calls /usr/local/Acrobat5/bin/acroread then macewan's idea should work fine as a substitiute for changing /etc/sysconfig/i18n. Otherwise, you have to find a way to modify LANG for the plugin as well.

ASCII is actually a subset of UTF-8 so you should have no problem running programs like that while the system default is UTF-8.

Last edited by zmedico; 06-05-2003 at 08:55 PM.
 
Old 06-05-2003, 08:59 PM   #9
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Original Poster
Rep: Reputation: 30
OK...I'll try a few combinations. I wasn't worried about programs running under UTF-8...that is the way it came out of the box. I was wondering if running under LANG=C (which is the way I have it configured NOW) would be a problem. I didn't think so, especially being here in the US and stuff...

OK...I'll just play with it, back up my files, and just find the best combination. I'm not sure WHAT the plug-in "call" is for the program...I should read it and find out...

Thanks again
 
Old 06-05-2003, 09:06 PM   #10
zmedico
Member
 
Registered: Feb 2002
Location: Mission Viejo, California, USA
Distribution: Gentoo
Posts: 707

Rep: Reputation: 30
You can configure mozilla to call external programs here:

Edit->Preferences->Navigator->Helper Applications
 
Old 06-05-2003, 09:44 PM   #11
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Original Poster
Rep: Reputation: 30
Everybody, you have been a great help. I am not a programmer, but just a REAL newbie with Linux (one month) and enjoying it very much. I tried to edit the acroread file but it didn't work when changing the i18n file back to it's original. Maybe I am putting it in the wrong place, but I tried to LANG=en_US and export that...then I tried LANG=C and export that...but I put it at the end of the file....I could try it at the beginning of the file.

However....I am satisfied the way things work with thi i18n edit. ALL FUNCTIONS PERFECTLY. I will only hope that Adobe addresses this issue on the next release (hopefully coming soon now that 6.0 is out on the Windows and Mac side).

Being a newbie, I have come a long way, thanks to the help of the documentation, the community (meaning all of YOU) and the neat "club" atmosphere of the entier GNU/Linux arena.

Just today I compiled my first installations from source code. I can't DO CODE yet, but I'm trying to get ahold of the system. I have made several software adjustments and am starting to get much more comfortable with the system.

OK...the thing about Linux is....once you get it configured and working (admittedly, sometimes a chore as illustrated by tonight) it works consistently and reliably. THAT is the big plus for the office desktop environment. STABILTY....and THIS IS IT.

I am VERY impressed.

So thanks and I'll call when I need help again (probably soon!)
 
Old 06-05-2003, 10:05 PM   #12
zmedico
Member
 
Registered: Feb 2002
Location: Mission Viejo, California, USA
Distribution: Gentoo
Posts: 707

Rep: Reputation: 30
Quote:
Originally posted by Bobmeister
but I put it at the end of the file....I could try it at the beginning of the file.
Putting it an the end of the file would have no affect, it must be near the beginning.
 
Old 06-06-2003, 06:34 AM   #13
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Original Poster
Rep: Reputation: 30
OK....I'll try that too! I'm just trying to learn stuff so poking around like this is fun. Thanks....I'll let you know if it worked.
 
Old 06-06-2003, 06:52 AM   #14
Bobmeister
Member
 
Registered: May 2003
Location: Mt. Prospect, Illinois
Distribution: Fedora Core 2, SuSE 9.1 Professional
Posts: 189

Original Poster
Rep: Reputation: 30
You guys did it for me! It worked. I set LANG=C and exported right at the beginning of the acroread file (just after the directory entry) and changed my i18n file back to the original. It works great...and the plug-in module does from Mozilla as well.

I cannot thank you enough. Now my environment is set properly globally, but specialized only for Acrobat Reader...just the way I wanted it. Thanks again for all of your help...you guys (and gals) are terrific!
 
Old 06-06-2003, 10:07 AM   #15
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
By the way, have you tried GGV?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Red Hat custom Kernel compilation mini-How-To for Red Hat 8-9 Thetargos Red Hat 431 04-13-2007 05:19 AM
Red Hat 9 to Red Hat EL Mozilla Migration Question rharvey@cox Linux - Software 2 01-13-2004 06:43 PM
Red Hat does not plan to release another product in the red hat linux line... Whitehat General 5 11-03-2003 06:33 PM
red hat 9.0.93. -beta red hat 10-xmms problem ronss Red Hat 1 09-08-2003 04:00 AM
Red Hat 7.2... & a modem with Red Hat 7.1 driver support rahduku Linux - Distributions 1 02-14-2002 11:49 AM


All times are GMT -5. The time now is 02:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration