LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-27-2003, 02:54 AM   #1
tunedLow
Member
 
Registered: Sep 2001
Location: Salt Lake City
Distribution: Slackware 8.1
Posts: 133

Rep: Reputation: 15
Accessing cups config page


I'm unabe to access the cups config page through my browser, using
http://localhost:631, or http://127.0.0.1:631


--> My loopback is running. I can ping localhost etc, and it's listed under hosts, and states that it's running in #ifconfig.


--> Cups is installed, and cupsd has been started and restarted. I make sure by checking #ifconfig aux, and cupsd is listed. I have also tried different combinations of starting and stopping /etc/rc.d/init.d/cups [start/stop/etc].


--> Here is the cups error log
/etc/cups# tail /var/log/cups/error_log
I [26/Apr/2003:12:37:05 -0600] Full reload complete.
E [26/Apr/2003:12:41:32 -0600] Scheduler shutting down due to SIGTERM.
I [26/Apr/2003:12:41:36 -0600] Listening to 0:631
I [26/Apr/2003:12:41:36 -0600] Loaded configuration file "/etc/cups/cupsd.conf"
I [26/Apr/2003:12:41:36 -0600] Configured for up to 100 clients.
I [26/Apr/2003:12:41:36 -0600] Allowing up to 100 client connections per host.
I [26/Apr/2003:12:41:36 -0600] Full reload is required.
I [26/Apr/2003:12:41:36 -0600] LoadPPDs: Read "/etc/cups/ppds.dat", 144 PPDs...
I [26/Apr/2003:12:41:36 -0600] LoadPPDs: No new or changed PPDs...
I [26/Apr/2003:12:41:36 -0600] Full reload complete.


--> Root is a member of the group sys. Don't really know how that relates but read it while googling around.


--> My display variable is set to :0.0


--> Here is some /var/log/messages for good measure:
Apr 26 10:00:25 marsha kernel: lp0: using parport0 (polling).
Apr 26 10:00:25 marsha kernel: lp0: compatibility mode
Apr 26 10:00:25 marsha last message repeated 2 times
Apr 26 10:05:08 marsha kernel: lp0: compatibility mode
Apr 26 10:05:08 marsha last message repeated 2 times
Apr 26 10:16:15 marsha -- MARK --
Apr 26 10:36:15 marsha -- MARK --
Apr 26 10:55:53 marsha kernel: usb.c: USB disconnect on device 2
Apr 26 11:16:15 marsha -- MARK --
Apr 26 11:36:15 marsha -- MARK --
Apr 26 11:49:42 marsha kernel: parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE]
Apr 26 11:49:42 marsha kernel: parport0: irq 7 detected
Apr 26 11:49:42 marsha kernel: lp0: using parport0 (polling).
Apr 26 11:49:42 marsha kernel: lp0: compatibility mode
Apr 26 11:49:42 marsha last message repeated 2 times
Apr 26 11:56:10 marsha kernel: lp0: compatibility mode
Apr 26 11:56:14 marsha last message repeated 5 times
Apr 26 11:57:26 marsha last message repeated 3 times
Apr 26 11:58:25 marsha last message repeated 3 times
Apr 26 12:16:15 marsha -- MARK --
Apr 26 12:30:35 marsha kernel: lp0: compatibility mode
Apr 26 12:30:35 marsha last message repeated 2 times
Apr 26 12:37:05 marsha kernel: lp0: compatibility mode
Apr 26 12:37:05 marsha last message repeated 2 times
Apr 26 12:41:36 marsha kernel: lp0: compatibility mode
Apr 26 12:41:36 marsha last message repeated 2 times
Apr 26 12:53:35 marsha kernel: lp0: compatibility mode
Apr 26 12:53:35 marsha last message repeated 2 times



Thanks much.
 
Old 04-27-2003, 03:37 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,000
Blog Entries: 11

Rep: Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893
Looks good so far ... did you also add
cups 631/tcp cupsd #cups print daemon

to your /etc/services?

Cheers,
Tink
 
Old 04-27-2003, 01:01 PM   #3
tunedLow
Member
 
Registered: Sep 2001
Location: Salt Lake City
Distribution: Slackware 8.1
Posts: 133

Original Poster
Rep: Reputation: 15
Thanks for the reply

I hadn't but have now, restarted inetd, even rebooted. Started cupsd, started /etc/rc.d/init.d/cups too. Still no joy.


The old lpd is still running. But that shouldn't have an effect on me simply getting to the cups config page. Figured I'd deal with that issue later.


Just times out at each try to http://localhost:631

Also tired:

--> Here is the Browse address section of my cups.conf
#BrowseAddress x.y.z.255
#BrowseAddress x.y.255.255
#BrowseAddress x.255.255.255
#BrowseAddress 255.255.255.255
BrowseAddress @LOCAL
#BrowseAddress @IF(name)
BrowseAddress 192.168.1.255

--> Also tried messing with mozilla proxy prefs. I don't have proxy, but saw it in another post here.

Thanks again

Last edited by tunedLow; 04-27-2003 at 01:20 PM.
 
Old 04-27-2003, 08:17 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,000
Blog Entries: 11

Rep: Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893
Quote:
started /etc/rc.d/init.d/cups too. Still no joy.
You should clean up your rc.d directory ... it's good
enough to copy cups (the shell script from init.d) to
rc.d and then modify rc.M and rc.6 to call it with
start and stop (respectively) ... having the structure
can have quite undesired results at times :}

What error-message are you getting, btw,
when trying to access http://localhost:631?

Also, when you say "the old lpd is still running",
did you verify that cupsd is actually up & running,
too?

The last thing I can think of is that you've been too
rough with a firewall script :}

Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
white sctreen/page when accessing php files. gottin Linux - Software 1 10-26-2005 10:11 AM
CUPS problem - page margins bitpicker Linux - Software 1 11-19-2004 04:42 PM
CUPS test page sethgeekx86 Linux - Software 7 05-05-2004 07:43 PM
CUPS - cannot access admin page Vincent_Vega Linux - Software 0 03-18-2004 02:20 AM
Thanks | CUPS test page ? niidea LinuxQuestions.org Member Intro 5 06-29-2003 07:09 PM


All times are GMT -5. The time now is 01:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration