LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-30-2003, 12:28 PM   #1
artman62
Member
 
Registered: Nov 2001
Distribution: Mandrake 8.2
Posts: 97

Rep: Reputation: 15
accessing a pop3 server


I have a couple of questions on accessing a pop3 server. I setup my linux box on my network to (hopefully) be my mail server for my Windows system (using outlook) and my system at home.
I loaded IMAP 2001 which has pop3 and imap.

Things seem to be working fine. But, when I try to access my mailbox over the network with Outlook, I had to use the IP address of my mailserver as opposed to pop3.domain.com. The host name of the server webserver.domain.com didn't work either.

Am I just missing a setting in my hosts file?
For my remote system to work, I am assuming I will have the same issue.

Secondly, when I do access my mailbox using the ip address, I am flooded with messages from:

Cron <root@webserver> nice -n 19 run-parts /etc/cron.hourly

the body of which says this:

Cannot open /etc/news/inn.conf
run-parts: /etc/cron.hourly/inn-cron-rnews exited with return code 1

Can I disable the newserver and why is it addressed to root?
 
Old 01-30-2003, 12:35 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
yeah sure remove the file in /etc/cron.hourly/ that is giving you this (by removing it's rpm if it has one if you wish). it is addressed to root as it's an error message that would otherwise dissapear.

if you look in /etc/crontab there will be a line sayiong MAILTO=root (unless it's jsut a default).

alternatively if you want this to work, then fix the problem with /etc/news/inn.conf
 
Old 01-30-2003, 12:41 PM   #3
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 591

Rep: Reputation: 32
1. it seems you don't know what is DNS and name resolving method (i.e. method of changing for example name "linuxquestions.org" to corresponding IP address 64.179.4.146). So the sollution is just to learn it.

2. Yes, you can disable mailing. Study cron configuration.
 
Old 01-30-2003, 03:34 PM   #4
artman62
Member
 
Registered: Nov 2001
Distribution: Mandrake 8.2
Posts: 97

Original Poster
Rep: Reputation: 15
Let me ask this

I registered my domain name (mydomain.com) with a registrar like registry.com.

If I want to be able to access pop3.mydomain.com, do I have to add this to my nameserver registry at registry.com?

So far, I can telnet the ip address of my mail server system on port 110 - which is pop3.

telnet xxx.xxx.xxx.xxx 110

I added this to my hosts file

127.0.0.1 pop3.mydomain.com pop3

But it didn't seem to make any difference.

In Outlook on my system I still have to use the ip address of my mail server as the pop server.

Not sure what I am missing.
 
Old 01-30-2003, 04:09 PM   #5
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 591

Rep: Reputation: 32
As I wrote: you do not know what is DNS and name resolving hierarchy.

Unfortunately registry.com doesn't work so I can only assume that it is a name registration place which has allowed you to register your "mydomain.com" as a name of your IP.
Doing it you are able to use "mydomain.com" instead of pure IP digits. That's all.

But the rest like resolving "sub.mydomain.com" is in your hand. So resolving the name pop3.mydomain.com to an IP should be done by your own DNS server. So learn DNS like BIND (named) or better djbdns and run such service.

BTW.
I you do not want any subdomain you do not need run any DNS server. Just use everywhere "mydomain.com" (without any prefix).
Thus you pop client should connect to "mydomain.com" rather than "pop3.mydomain.com" which has not been serviced by you.

Last edited by dorian33; 01-30-2003 at 04:11 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with accessing other network server when connected from a dial-in server radatan71 Linux - Networking 0 11-22-2005 02:20 AM
POP3 server Tihi Linux - Software 3 03-16-2005 06:30 AM
pop3 server amadkow Linux - Software 5 11-17-2004 03:35 PM
best pop3 server sirjosi Linux - Networking 1 10-23-2003 02:03 PM
pop3 server chamkila Linux - Software 1 08-12-2003 09:44 AM


All times are GMT -5. The time now is 06:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration