LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-24-2008, 12:27 PM   #1
he_the_great
LQ Newbie
 
Registered: Sep 2006
Location: EWU
Distribution: Debian Testing
Posts: 16

Rep: Reputation: 0
Access VMWare 2.0 Server with Apache installed (Resolved)


The latest VMWare as switched to using a browser plugin to do all management of your virtual machines. And as such this means you must access it through http://localhost/ The problem I'm having is that with Apache installed I am unable to get to the vmware server. In order to try and find it I have tried adding the port http://localhost:902 which is the default set for remote access. Unfortunately this does not get me what I want. So I am wondering where I should be pointing my browser or configure my programs.

Last edited by he_the_great; 10-12-2008 at 06:17 PM. Reason: Resolution found
 
Old 08-25-2008, 07:20 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Apache has absolutely nothing to do with VMware Server and doesn't interfere with it. During the VMWare install, you should have specified a port that it listens to, and that is where you need to connect. If you specified port 902, maybe you should describe what you're seeing so we can help you better.
 
Old 08-27-2008, 11:40 PM   #3
he_the_great
LQ Newbie
 
Registered: Sep 2006
Location: EWU
Distribution: Debian Testing
Posts: 16

Original Poster
Rep: Reputation: 0
upon using the address http://localhost:902/ I receive.

"220 VMware Authentication Daemon Version 1.10: SSL Required, ServerDaemonProtocol:SOAP, MKSDisplayProtocol:VNC , VMXARGS supported"

A search on google gets me some stuff on fedora forms which is a jungle of misunderstanding. And ubuntu which seems to say that I am getting a correct message.

My assumption is that this is the port the VM Client connects to. Problem is I'm trying to get to the VM Client, which before I installed apache was just http://localhost/ and I have reinstalled VMWare with the latest RC2.
 
Old 08-28-2008, 06:35 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Quote:
My assumption is that this is the port the VM Client connects to. Problem is I'm trying to get to the VM Client, which before I installed apache was just http://localhost/
That is just weird since http://localhost defaults to port 80, and since you didn't have Apache installed, nothing should have been listening there. Unless, of course, you had configured VMWare to listen on port 80.

Anyway, I did some googling and the common thread seems to be that not all bits of VMware seem to start at boot, even if vmware-config.pl runs successfully. Take a look at your running processes for vmware and see what is there. For me it is:

vmware-watchdog
vmware-authdlau
vmware-hostd

Also make sure that your firewall isn't blocking access to port 902. And while your doing that, have a look at your lsof -i output and see if anything is listening on port 902.

The part I don't get about the Ubuntu thread you linked to is why xinetd is required. Slackware uses inetd, not xinetd and I've got no problems. However, if you haven't already, you might try either installing (or reinstalling) xinetd and see if that makes a difference.
 
Old 08-28-2008, 10:41 PM   #5
he_the_great
LQ Newbie
 
Registered: Sep 2006
Location: EWU
Distribution: Debian Testing
Posts: 16

Original Poster
Rep: Reputation: 0
I'm not running a firewall, have been considering setting one up but haven't for the whole I might need to unblock something I don't know about :P I also may not be recalling the whole just going to http://localhost thing, it's been a while.

Anyway, original I had some vmnet stuff and only:

vmware-watchdog
webAccess (Java thing)

I ran vmware-hostd and that gave me vmware-authdlauncher (aka vmware-authdlau) Which listens on port 902. Still no good. And hostd doesn't seem to continue to run.

FYI I'm running Debian, and did try xinetd (confused me because I read it with xine first) didn't help. And tell you what, I might be getting parts for a new computer so I'll probably end up reinstalling too, I'll try and see if I can avoid this problem. (If I get it working I can use a VM to try and reproduce it

Thank you for your help so far, I'll post back with an update.
 
Old 08-29-2008, 07:31 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Quote:
I ran vmware-hostd and that gave me vmware-authdlauncher (aka vmware-authdlau) Which listens on port 902. Still no good. And hostd doesn't seem to continue to run.
Yeah, this is looking like vmware isn't starting up properly. Have a look in your log files (/var/log/syslog, /var/log/messages and the dmesg output) and see if vmware is complaining about anything.
 
Old 08-29-2008, 09:14 AM   #7
he_the_great
LQ Newbie
 
Registered: Sep 2006
Location: EWU
Distribution: Debian Testing
Posts: 16

Original Poster
Rep: Reputation: 0
Yeah, it seems there are some things in there.
Quote:
Aug 24 09:15:20 goliath watchdog-webAccess: PID file /var/run/vmware/watchdog-webAccess.PID not found

Aug 24 09:15:20 goliath watchdog-webAccess: Unable to terminate watchdog: Can't find process

Aug 24 09:27:06 goliath watchdog-webAccess: [6451] Begin '/usr/lib/vmware/webAccess/java/jre1.5.0_15/bin/webAccess -client -Xmx64m -XX:MinHeapFreeRatio=30 -XX:MaxHeapFreeRatio=30 -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.endorsed.dirs=/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/common/endorsed -classpath /usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/bin/bootstrap.jar:/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/bin/commons-logging-api.jar -Dcatalina.base=/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16 -Dcatalina.home=/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16 -Djava.io.tmpdir=/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/temp org.apache.catalina.startup.Bootstrap start', min-uptime = 30, max-quick-failures = 5, max-total-failures = 1000000

Aug 24 09:27:06 goliath watchdog-webAccess: Executing '/usr/lib/vmware/webAccess/java/jre1.5.0_15/bin/webAccess -client -Xmx64m -XX:MinHeapFreeRatio=30 -XX:MaxHeapFreeRatio=30 -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.endorsed.dirs=/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/common/endorsed -classpath /usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/bin/bootstrap.jar:/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/bin/commons-logging-api.jar -Dcatalina.base=/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16 -Dcatalina.home=/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16 -Djava.io.tmpdir=/usr/lib/vmware/webAccess/tomcat/apache-tomcat-6.0.16/temp org.apache.catalina.startup.Bootstrap start'
I don't see anything in dmesg, and just a call to shutdown in messages.

Last edited by he_the_great; 08-29-2008 at 09:15 AM. Reason: format
 
Old 10-12-2008, 06:21 PM   #8
he_the_great
LQ Newbie
 
Registered: Sep 2006
Location: EWU
Distribution: Debian Testing
Posts: 16

Original Poster
Rep: Reputation: 0
I have installed the latest VMware on my new system. During the vmware-config.pl stage, it asked for the standard http and https ports after the remote port. It was not doing this before, for what ever reason. The defaults were, http 8222 and https 8333
 
Old 10-12-2008, 09:59 PM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Quote:
The defaults were, http 8222 and https 8333
Sorry, but I'm a bit confused. What defaults is this referring to Apache or VMWare? Are you still having a problem accessing VMware?
 
Old 10-12-2008, 10:14 PM   #10
he_the_great
LQ Newbie
 
Registered: Sep 2006
Location: EWU
Distribution: Debian Testing
Posts: 16

Original Poster
Rep: Reputation: 0
The defaults were for VMware, and at this point I don't have apache installed but I can get to VMware. Since the setup actually requested port numbers, I don't think I will be having any issues. With my previous system, I had only been asked to provide a remote access port (whatever that is used for), it did not ask the follow up questions about http ports for the vmware server.
 
Old 10-12-2008, 10:34 PM   #11
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
OK, as long as VMWare is working. However, it is still odd that it is asking about http ports since it never should interact with a web server.
 
  


Reply

Tags
apache2, vmware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vmware server install error, The VMware VmPerl Scripting API was not installed. fakie_flip Linux - Software 4 12-28-2008 04:49 AM
FreeNX Server Not installed or NX access disable Glock23 Slackware 5 06-19-2006 10:42 AM
using an already installed Windows XP under VMware server? microsoft/linux General 10 04-16-2006 10:00 PM
Problem with NX : Server not installed or NX access disabled cHeAp_PeTe Linux - Networking 0 03-27-2006 01:52 PM
Setup linux-apache server to access documents on NT server josephswagner Linux - Software 11 04-11-2003 08:35 AM


All times are GMT -5. The time now is 07:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration