LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-05-2007, 11:12 PM   #1
pengu
Member
 
Registered: Dec 2005
Location: Canton, GA, USA
Distribution: Ubuntu 7.10, FreeBSD, Debian
Posts: 207

Rep: Reputation: 30
Access linux SAMBA share from windows


I have an Ubuntu file server with samba installed.

the host name is "jack-server"

I want to access the share "allusers" from my windows box.

I type "\\jack-server\allusers" into the run prompt, and i get the User name and password prompt. However, when I type "Administrator" as the user (mapped to root) and the password, It wont login.

It's as if i dont have the right password, but I know it is correct.

here is my smb.conf

----------------------------------------------------------
[global]
passwd chat debug = yes
name resolve order = wins bcast hosts
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
idmap gid = 15000-20000
add group script = /usr/sbin/groupadd %g
delete group script = /usr/sbin/groupdel %g
add user to group script = /usr/sbin/usermod -G %g %u
logon drive = H:
username map = /etc/samba/smbusers
passwd program = /usr/bin/passwd %u
passdb backend = tdbsam
wins support = true
netbios name = jack-server
server string = %h server (Samba, Ubuntu)
printing = CUPS
idmap uid = 15000-20000
unix password sync = yes
workgroup = NOVUS
logon path = \\jack-server\profile\%U
os level = 20
auto services = global
add user script = /usr/sbin/useradd -m %u
printcap name = CUPS
add machine script = /usr/sbin/useradd -s /bin/false/ -d /var/lib/nobody %u
delete user script = /usr/sbin/userdel -r %u
log level = 3
domain logons = yes



# Set CUPS for printing

# Default logon
#logon script = scripts/logon.bat


# Useradd scripts


# sync smb passwords woth linux passwords

# set the loglevel


[homes]
comment = Home
valid users = %S
read only = no
browsable = no


[printers]
comment = All Printers
path = /var/spool/samba
printable = yes
guest ok = yes
browsable = no


[netlogon]
comment = Network Logon Service
path = /home/samba/netlogon
admin users = Administrator
valid users = %U
read only = no


[profile]
comment = User profiles
path = /home/samba/profiles
valid users = %U
create mode = 0600
directory mode = 0700
writable = yes
browsable = no

[allusers]
writeable = yes
path = /home/shares/allusers
force group = users
comment = All Users
valid users = jack,win,root,@users
public = yes
create mode = 0771
 
Old 02-06-2007, 01:59 AM   #2
jason_dustrose
Member
 
Registered: Feb 2007
Location: Arizona
Distribution: Currently toying with Debian-based MEPIS
Posts: 31

Rep: Reputation: 15
Question Okay... Couple Things...

Firstly, when you say "mapped to root", do you mean you created an alias in the smbusers file, or did you do something else. There are supposedly a couple tricks to doing that. Personally I've never had any luck doing it anyway. Plus, it seems that you are (kind of) running a domain, in which case you should have "root" as a user anyway. Why not just use that?

Second, which version of Windows are you using to connect? I've found that there are many Samba intricasies that Windows treats differently with different versions, perhaps I could be more help with this info.

Lastly, did you try accessing the root of your share alone (\\jack-server)? Perhaps somehow the permissions got a little screwy. Of course the share specifies "root" as being a valid user, however Unix permissions always trump Samba permissions, and as weird as that sounds (being that we are dealing with "root" here) believe me, I've done it. After a kernel overhaul anything can happen.

Anyway get back to me and we'll work this thing out.

Last edited by jason_dustrose; 02-06-2007 at 02:00 AM.
 
Old 02-06-2007, 02:06 AM   #3
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
And an obvious question perhaps (and implicit in the response above) but you did add a samba user?
 
Old 02-11-2007, 10:54 PM   #4
pengu
Member
 
Registered: Dec 2005
Location: Canton, GA, USA
Distribution: Ubuntu 7.10, FreeBSD, Debian
Posts: 207

Original Poster
Rep: Reputation: 30
very sorry for not replying sooner, forgot I had posted here...

I solved the problem- I had mapped the root user (in the folder /etc/samba/users) as "Administrator" for use from windows PC's. Actually there is no such user as "Administrator" on windows... So i just had to change it to a user that was on the windows pc.

One of those stupid mistakes...
 
Old 02-12-2007, 08:37 PM   #5
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 231Reputation: 231Reputation: 231
How did you forget? Aren't you automatically subscribed to your own thread?

http://www.linuxquestions.org/questi...do=editoptions
Quote:
Messaging & Notification
. . .

Default Thread Subscription ModeWhen you post a new thread, or reply to a topic, you can choose to automatically add that thread to your list of subscribed threads, with the option to receive email notification of new replies to that thread.

Default Thread Subscription Mode:
And pick an e-mail option.
 
Old 02-12-2007, 08:41 PM   #6
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Perhaps he meant forgot he'd posted on LQ and uses hotmail or similar for notifications
 
Old 02-17-2007, 11:55 AM   #7
pengu
Member
 
Registered: Dec 2005
Location: Canton, GA, USA
Distribution: Ubuntu 7.10, FreeBSD, Debian
Posts: 207

Original Poster
Rep: Reputation: 30
as i said, im sory for forgetting...

Yes, i forgot i had posted on LQ

I do have e-mail subscriptions for all my posts- but I do not have the time to go through all of them every day...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot access my Linux share from Windows va7hg Linux - Networking 6 12-13-2005 08:00 AM
Can't access my linux share through samba. I get permission denied. mlsbraves Linux - Software 1 08-16-2005 07:59 PM
samba: linux mounted share = choppy playback, windows mounted share = smooth kleptophobiac Linux - Software 2 04-10-2005 08:23 AM
Window share access through linux (SAMBA) emailssent Linux - Software 12 09-19-2004 02:11 PM
Installed SAMBA and XP or Win2000 can access Linux Share! Please Help. NYAndy Linux - Newbie 3 02-29-2004 09:29 AM


All times are GMT -5. The time now is 07:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration