LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-11-2011, 10:02 AM   #1
loachh
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Rep: Reputation: 0
Question a version trouble about gstreamer


I trying to play my music(.mp3) on my new slackware laptop(13.37), what I used is clementine, and it tells me
Quote:
GStreamer could not create the element: uridecodebin. Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)
So I trying to update my gstreamer to 0.10.35, but I could not complied it with only the souce code, so I find a slackbuild script for it, then it installed, but while I trying to install the "gst-plugins-base 0.10.35", it says
Quote:
configure: Requested 'gstreamer-0.10 >= 0.10.34' but version of GStreamer is 0.10.33
, but I'm really sure that in pkgtool it shows that the GSTreamer is 0.10.35

It puzzled me, what's wrong with it/me?

Hope you guys happy everyday! Amen!
 
Old 08-11-2011, 04:53 PM   #2
qlue
Member
 
Registered: Aug 2009
Location: Umzinto, South Africa
Distribution: Crunchbang
Posts: 613
Blog Entries: 1

Rep: Reputation: 140Reputation: 140
mp3 is a propriety codec that is not installed by default on most distros. I'm not sure how to do this in Slackware, but in Ubuntu you have to activate the non-free repositories and install the restricted extras packages.
 
Old 08-11-2011, 09:00 PM   #3
loachh
LQ Newbie
 
Registered: Aug 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Smile

Yes, the mp3 decodec is in the package "gst-plugins-ugly", but the package "gst-plugins-base" should be installed at first
 
  


Reply

Tags
gstreamer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] gstreamer-plugins-base conflicts with gstreamer-plugins-good Raveolution Linux - Software 14 11-17-2009 12:24 PM
trouble installing gstreamer plugins for Ubuntu 8.10 from source zadclu Linux - Software 3 01-01-2009 12:42 PM
trouble with mod_security version 2.0.2 mtruong Linux - Security 1 10-30-2006 03:19 PM
fglrx and gcc version trouble... noxious Debian 2 09-12-2006 09:48 AM
amaroK / gstreamer plugin trouble (-)Ions Linux - Software 5 05-10-2005 04:39 PM


All times are GMT -5. The time now is 11:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration