LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-21-2003, 03:11 PM   #1
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Rep: Reputation: 30
2.6 Kernel Panic


I am having a heck of a time trying to get the 2.6test5 kernel to boot up. It gives a kernel panic saying that it can't mount root partition on hda5. I am using lilo as my boot loader. I compiled devfs and ext3 journaling file system into the kernel and I don't have any other idea on how to get it to mount the root partition. I also have my IDE controller compiled in. Any suggestions?
 
Old 09-21-2003, 03:43 PM   #2
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Go in to your original kernel. Then make a ramdisk image for the 2.6 kernel if you have not done it. I hope you kept the original kernel because the latest kernel or recompiled kernel sometimes doesn't work. If that doesn't work you can use Knoppix to make one.
 
Old 09-21-2003, 04:00 PM   #3
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
oh yeah, i have still have my old image. How do I make a ramdisk image?
 
Old 09-21-2003, 04:34 PM   #4
mrsolo
Member
 
Registered: Jun 2002
Location: Where ever the Navy sends me
Distribution: Gentoo
Posts: 320

Original Poster
Rep: Reputation: 30
just to give a better picture, here's the last three messages during the kernel load and boot time:

VFS: cannot open root device "305" or hda5
Please append a correct "root=" boot option
kernel panic: VFS: cannot load root fs on hda5

here's the lilo entry for that particular image:

image=/boot/vmlinuz2.6
label="linux_smp2.6"
root=/dev/hda5
initrd=/boot/initrd.img
append="acpi=off"
read-only

I used to have append="acpi=on" but I wanted to see if acpi was screwing it all up but it wasn't.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.4 in Zipslack (Waring: unable to open an initial console | Kernel Panic...) kurtamos Linux - General 2 05-10-2006 01:58 PM
kernel panic: try passing init= option to kernel...installation with Red Hat 9 kergen Linux - Hardware 1 09-30-2004 04:28 AM
Kernel panic puts me in a panic theeeg Linux - Software 2 07-31-2004 05:46 PM
kernel panic (narius panic) narius Linux - Newbie 3 06-20-2002 04:56 PM
Kernel panic making me panic! Linux_N0oby Linux - Software 19 05-29-2002 01:31 AM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration