LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-20-2003, 11:24 PM   #1
meks
Member
 
Registered: Jul 2003
Location: AT, Upper Austria
Posts: 33

Rep: Reputation: 15
2.6.0 - error: unknown pseudo-op: .incbin ??


hi there!

i recently tried to compile kernel 2.6.0 (the final one) but no matter what i'm doing, i'm always getting this error:

-----
server:/hda1/src/linux-2.6.0 # make bzImage
make[2]: `scripts/fixdep' is up to date.
scripts/kconfig/conf -s arch/i386/Kconfig
#
# using defaults found in .config
#
SPLIT include/linux/autoconf.h -> include/config/*
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
CC init/main.o
CHK include/linux/compile.h
CC init/version.o
CC init/do_mounts.o
LD init/mounts.o
LD init/built-in.o
AS usr/initramfs_data.o
/tmp/ccmfgDUM.s: Assembler messages:
/tmp/ccmfgDUM.s:30: Error: Unknown pseudo-op: `.incbin'
make[1]: *** [usr/initramfs_data.o] Error 1
make: *** [usr] Error 2
-----

so before you are asking:
*) yes, i do have config'd it - using make oldconfig first and xconfig afterwards

i tried it without using the initial ramdisk. worked well for a while, but then stopped compiling again with the same error.

help would be appreciated.

thanks,
meks
 
Old 12-23-2003, 09:40 AM   #2
Kroppus
Member
 
Registered: Aug 2003
Location: Norway
Distribution: Debian UNSTABLE + latest 2.6.kernel
Posts: 391

Rep: Reputation: 30
First of all. Make sure that you got all the updates for the programs that's listed in the readme file.

I've missed on that myself. *grins*
Run through the full list that's there and see what you're missing.
I'd copy the old .config file to the 2.6.0 dir as oldconfig or something and try to load that into the menyconfig. But that's just my way of doing it.
 
Old 01-14-2004, 06:33 AM   #3
s.lessing
LQ Newbie
 
Registered: Jan 2004
Location: Germany
Posts: 2

Rep: Reputation: 0
Hi all,

i have the same problem! I have checked all the versions inside the "change" documentation. Just the update of the binutils failed. There i have a version of 2.10.93 instead of minimum 2.11.

Could this cause my problems?

Stefan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] shmget(lowmem) error: Unknown error 999 kaz2100 Linux - Software 1 10-26-2010 04:11 AM
Regarding Pseudo tty, Pseudo terminals ? mqureshi Programming 0 07-30-2005 10:51 AM
Unknown error fuzzymallets Fedora 8 05-04-2005 09:38 AM
compile error: #error unknown processor family kmack2001 Linux - Newbie 0 02-14-2004 11:52 AM
Unknown error. Any help? HappyDude Programming 2 10-05-2003 09:27 PM


All times are GMT -5. The time now is 05:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration