LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-25-2001, 01:48 AM   #1
aridhol
LQ Newbie
 
Registered: Nov 2001
Posts: 2

Rep: Reputation: 0
Question 127.0.0.1 used by another host after Mandrake Update-reboot


Today I installed a brand new HD into my lovely Mandrake 8.1 box. I decided to get some experience out of it, and so reinstalled Mandrake too.
After reinstalling, I used Mandrake Update to update the system (Using bugfixes, security-updates, the works) but now at reboot I get some problems...
This is an extract from my last bootlog:

**************************************
...Nov 25 08:11:39 www rc.sysinit: Remounting root filesystem in read-write mode: succeded
Nov 25 08:11:40 www depmod: depmod: Can't open /lib/modules/2.4.8-26mdk/modules.dep for writing
Nov 25 08:11:40 www rc.sysinit: Finding module dependencies: failed...
...Nov 25 08:11:47 www modprobe: modprobe: Can't open dependencies file /lib/modules/2.4.8-26mdk/modules.dep (No such file or directory)
Nov 25 08:11:47 www usb: Loading USB interface (usb-uhci) failed
Nov 25 08:11:48 www network: Setting network parameters: succeded
Nov 25 08:11:48 www ifup: arping: socket: Adress family not supported by protocol
Nov 25 08:11:48 www ifup: Error, some other host already uses address 127.0.0.1.
Nov 25 08:11:48 www network: Binging up interface lo:% failed
**************************************

My questions are these:
1. Why doesn't the update change the path to modules.dep in the relevant files when it updates the path to /lib/modules/2.4.8-34.1mdk/modules.dep?
2. What makes the USB-fail? (No real interest in this as I don't use anything with USB, but it would be nice to know why things doesn't work after updates)
3. How can another host have the adress 127.0.0.1 when this machine isn't connected to the network?

Hope I am right in posting this here... It is now 8:46am (and I have searched the web and found similar problems, but nothing I understand (I'd rather not go through updating the kernel manually if I can help it...)
 
Old 01-06-2002, 04:21 PM   #2
sorendahl
LQ Newbie
 
Registered: Jan 2002
Location: Denmark
Distribution: Mandrake 8.1
Posts: 3

Rep: Reputation: 0
Question I have the same problem ... how did you solve yours ?

Hi Aridhol
I have just run into the same problem as you.

I installed ML8.1, updated the installation and after the first restart of the server ... tahdaaah ... the modules will not load

Have you found a cure for the problem ??
Please inform me if you have

best regards
Soren Dahl (Newbie)
 
Old 01-06-2002, 06:41 PM   #3
aridhol
LQ Newbie
 
Registered: Nov 2001
Posts: 2

Original Poster
Rep: Reputation: 0
I didn't....

I reinstalled everything and just didn't update it...
Thinking about updating anyway, but I'll wait a while untill I have the spare time to do everyting all over again in case it doesn't work...
 
Old 01-07-2002, 01:59 AM   #4
sorendahl
LQ Newbie
 
Registered: Jan 2002
Location: Denmark
Distribution: Mandrake 8.1
Posts: 3

Rep: Reputation: 0
ahaa ... well ... I think I'll do a reinstall then.
Thankz
 
Old 01-07-2002, 04:11 AM   #5
sorendahl
LQ Newbie
 
Registered: Jan 2002
Location: Denmark
Distribution: Mandrake 8.1
Posts: 3

Rep: Reputation: 0
Found the cure !

Hi again.
I have been surfing the www.mandrakeuser.org and found a solution to the problem.

The problem is that you cannot update the kernel via the Mandrake Updater. If you do update the kernel anyway ... the symbolic links in /boot/ are wrong and lilo cant boot correctly !

config, System.map and vmlinuz are linking wrong ... change the links, so that they link to the right files (in the same dir).
I changed these 3 symbolic links and now everything works again

Read more at:
www.mandrakeuser.org

Best regards
Soren Dahl
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOST name in HOSTS file (127.0.0.1) fipeso Linux - Networking 1 05-05-2005 06:22 AM
update - now won't reboot Alfie67 Suse/Novell 6 03-31-2005 12:21 PM
update 9.1 to 9.2: SuseConfig on every Reboot ibert Suse/Novell 1 02-14-2005 07:23 AM
DSN: Data format error & relay=[127.0.0.1] [127.0.0.1] calmbomb Linux - Software 0 11-07-2004 03:24 PM
kernel update under YOU: need reboot? why? bruno buys Linux - Distributions 2 06-20-2004 06:58 PM


All times are GMT -5. The time now is 01:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration