LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-28-2008, 10:47 PM   #1
pgb205
Member
 
Registered: Nov 2007
Posts: 109

Rep: Reputation: 15
'pkg-config --modversion glib-2.0' returned 2.16.3, but GLIB (2.14.6)


Running Centos 5.1 and trying to install latest version of gtk on the machine. When doing the configure get the following message and I'm not
sure how to resolve it. Tried doing rpm -e on the old version of glib but get error messages that alot of stuff depends on it. Tried repointing the LD_LIBRARY_PATH env var to several different folders but that didn't help.
thanks for any ideas.

checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking for GLIB - version >= 2.13.5...
*** 'pkg-config --modversion glib-2.0' returned 2.16.3, but GLIB (2.14.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.13.5 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.
 
Old 04-29-2008, 12:44 AM   #2
nowshining
Member
 
Registered: Dec 2007
Distribution: Ibex
Posts: 93

Rep: Reputation: 15
do a sudo make clean

then

sudo ldconfig

yes it's an lowercase L

then try your request again.
 
Old 04-29-2008, 01:14 AM   #3
pgb205
Member
 
Registered: Nov 2007
Posts: 109

Original Poster
Rep: Reputation: 15
OK now getting this. Even though pango is upgraded to the latest version.

checking pkg-config is at least version 0.9.0... yes
checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.13.5 atk >= 1.9.0 pango >= 1.17.3 cairo >= 1.2.0) were not met:

Requested 'pango >= 1.17.3' but version of Pango is 1.14.9

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
 
Old 04-30-2008, 12:14 AM   #4
nowshining
Member
 
Registered: Dec 2007
Distribution: Ibex
Posts: 93

Rep: Reputation: 15
whenever it says something to this "glib-2.0 >= 2.13.5 atk >= 1.9.0 pango >= 1.17.3 cairo >=
1.2.0) were not met:"

it means your missing the -dev versions of the packages, in ubuntu it's sufficient to ginto the package manager and find the dev-versions

example on mine I would install:

glib - install libglib 2.0-dev
atk - install libatk1.0-dev (sorry I only have 1.0 and in Kubunti/Ubuntu I have 1.20.0)
pango - install libpango1.0-dev (sorry I only have 1.0 and in Kubunti/Ubuntu I have 1.18.3 - not counting the installed one from gtk ie: the updated version)
cairo - install libcairo2-dev (sorry I only have 1.0 and in Kubunti/Ubuntu I have 1.4.10.1)


After installing those and the dependencies, try your request again.
 
Old 05-15-2008, 10:24 AM   #5
tomkralik
LQ Newbie
 
Registered: May 2008
Posts: 2

Rep: Reputation: 0
pkg-configure

Hello,
please help me
I have linux CentOS 4.6
I can compile files into tar file "libmodbus-1.2.4.tar.gz"

I do command "./configure" ended with error
disleyed:
checking for pkg-config... /usr/local/bin/pkg-config
checking pkg-config is at least version 0.7... yes
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.0.0, but GLIB (2.4.7)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: libmodbus needs GLib 2.X

thank you
kr@lik
 
Old 05-16-2008, 05:15 PM   #6
nowshining
Member
 
Registered: Dec 2007
Distribution: Ibex
Posts: 93

Rep: Reputation: 15
have u ran ldconfig? in a root type environement - i don't about CentOS, and I don't know if it uses sudo or not.
 
Old 05-17-2008, 04:07 AM   #7
tomkralik
LQ Newbie
 
Registered: May 2008
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by nowshining View Post
have u ran ldconfig? in a root type environement - i don't about CentOS, and I don't know if it uses sudo or not.
Hello,
yes, I ran ldconfig and I'm user sudo.
I don't know, why have error and problemswith compile
libmodbus-1.2.4.tar.gz -> ./configure

please help me,

appending configuration tag "CXX" to libtool
appending configuration tag "F77" to libtool
checking for pkg-config... /usr/local/bin/pkg-config
checking pkg-config is at least version 0.7... yes
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.0.0, but GLIB (2.4.7)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error: libmodbus needs GLib 2.X


thanks
 
Old 05-17-2008, 04:21 PM   #8
nowshining
Member
 
Registered: Dec 2007
Distribution: Ibex
Posts: 93

Rep: Reputation: 15
hmmm it fails to detect ur Glib ver. 2.0.

sorry but ur problem lies in the detection of glib 2.x, u can try compiling & installing the glib from the main site here http://ftp.acc.umu.se/pub/GNOME/sources/

and see it works.

Don't forget to run ldconfig afterwords.

Last edited by nowshining; 05-17-2008 at 04:23 PM.
 
  


Reply

Tags
glib, ldlibrarypath


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install ethereal, I get the error: 'pkg-config --modversion glib-2.0' retur abefroman Linux - Security 5 07-09-2007 12:09 PM
pkg-config glib gtk gdk Peterius Linux - Software 6 05-11-2007 03:38 AM
pkg-config and glib: Uninstalling Old and Installing New CooManChu Linux - Software 6 09-06-2005 04:35 PM
Installing Glib, ATK, GTK, Pkg Config, and Pango! LinuZ Linux - Newbie 9 10-26-2003 03:58 PM


All times are GMT -5. The time now is 11:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration