LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-12-2003, 02:12 AM   #1
tmadhavan
LQ Newbie
 
Registered: Sep 2002
Location: Wales, bangin'
Distribution: RedHat 9.0, Mandrake 9.1
Posts: 15

Rep: Reputation: 0
'Error trying to open /dev/scd0 exclusively' in RH9 cdrecord - help?


Lo all.

Can''t find any help about this at all, but it seems to have happened to other people.

Just recently installed RH9 and got all the updates I needed. When I try making a cd using cdrecord (i.e., xroast or gnometoaster) I get an error saying:

"Error trying to open /dev/scd0 exclusively... will retry in 1 second"

Eventually it just ends with "...bailing out..."

This happens regardless of whether I'm root or not and I have no clue what the problem is. Don't mind editing anything, I just don't know which things I need to change.

Any required info, I'll put it up ASAP.

Thanks very much.

Thom
 
Old 08-12-2003, 04:18 AM   #2
seidren
Member
 
Registered: May 2003
Distribution: Ubuntu, Windows XP
Posts: 90

Rep: Reputation: 16
Its because you have mounted the drive
try unmounting it

umount /mnt/cdrom

this should work.
otherwise try running as root
also check if you are using the correct device

try cdrecord -scanbus

you should get a list where the name of your cd-writer will be listed followed by 3 numbers
for me its 0,0,0

so then when running cdrecord
use
cdrecord dev=0,0,0
 
1 members found this post helpful.
Old 02-21-2004, 12:01 AM   #3
verstapp
Member
 
Registered: Feb 2004
Location: canberra australia
Distribution: Suse 9.0
Posts: 44

Rep: Reputation: 15
tmadhavan>seems to have happened to other people.
Speaking as one of the 'other people' I have exactly the same problem as you. I find that Gnome's Go/CD Creator works almost as well as 'doze's right-click/send to/CDROM, but only when there's a blank CD in the drive, otherwise I get the old "...bailing out...". Using 650MB of storage to copy 1kB of file is a bit wasteful when I have to use a new disc each time...

Remember siedren, you are speaking to newbies here so if your method, which didn't work for me (it didn't give an error but it also didn't write the files to a non-blank CD), needs me to first click redhat/preferences/cd properties and change things in there, then you had better specify that. Same with changes to /etc/XF86Config .

ps. I am also having problems writing to my floppy. Once again it goes through the motions but if I transfer the floppy to a 'doze box the files aren't there. Also, Nautilus claims to be 'unable to unmount the volume' 15 minutes after it claimed that it had finished copying files there because 'the device is busy'. I know its only an AMD 1800+...
 
Old 02-21-2004, 01:07 AM   #4
hiteshmaisheri
Member
 
Registered: Nov 2003
Location: Kerala, India
Distribution: Red Hat, Knoppix, Mandrake, FreeBSD
Posts: 231

Rep: Reputation: 30
(This is for tmadhavan) I also use the xcdroast and gnome-toaster... in gui... when u use it and insert a blank cd... the guid generally automatically mounts the cd to the system... and when u try to write to a mounted cdrom using xcdroast or gnome-toaster... it requires an unmounted cdrom... to write... this is the reason why u gett retrying in 1 second and bails out after 10 seconds...

(This is for verstapp) regarding writing to floppy the floppy is not automounted in gui... it has to be mounted and then only can u write to it....so mount it first and then try to write a file to it....
 
Old 02-21-2004, 03:26 AM   #5
verstapp
Member
 
Registered: Feb 2004
Location: canberra australia
Distribution: Suse 9.0
Posts: 44

Rep: Reputation: 15
hitesh>and then try to write a file to it...
try to write to it?!
It sounds as if you are having almost as much trouble as I am.
Just tried again -
insert disk
right-click on desktop
hover over Disks menu item, click on Floppy
Floppy icon appears on desktop
right-click on it, click Open
'floppy' window opens
right-click copy file in home window, right-click paste file in 'floppy' window
drive light goes on for a second
right-click on 'floppy' icon, eject, 'device is busy'
right-click on desktop, disks, floppy, 'device is busy'
take floppy out of drive anyway, move to 'doze machine. Needless to say the file hasn't been copied to it.

Please point out to me the thing that I am doing incorrectly.
 
Old 02-21-2004, 03:27 AM   #6
verstapp
Member
 
Registered: Feb 2004
Location: canberra australia
Distribution: Suse 9.0
Posts: 44

Rep: Reputation: 15
hitesh>and then try to write a file to it...
try to write to it?!
It sounds as if you are having almost as much trouble as I am.
Just tried again -
insert disk
right-click on desktop
hover over Disks menu item, click on Floppy
Floppy icon appears on desktop
right-click on it, click Open
'floppy' window opens
right-click copy file in home window, right-click paste file in 'floppy' window
drive light goes on for a second
right-click on 'floppy' icon, eject, 'device is busy'
right-click on desktop, disks, floppy, 'device is busy'
take floppy out of drive anyway, move to 'doze machine. Needless to say the file hasn't been copied to it.

Please point out to me the thing that I am doing incorrectly.
 
Old 02-21-2004, 03:27 AM   #7
verstapp
Member
 
Registered: Feb 2004
Location: canberra australia
Distribution: Suse 9.0
Posts: 44

Rep: Reputation: 15
hitesh>and then try to write a file to it...
try to write to it?!
It sounds as if you are having almost as much trouble as I am.
Just tried again -
insert disk
right-click on desktop
hover over Disks menu item, click on Floppy
Floppy icon appears on desktop
right-click on it, click Open
'floppy' window opens
right-click copy file in home window, right-click paste file in 'floppy' window
drive light goes on for a second
right-click on 'floppy' icon, eject, 'device is busy'
right-click on desktop, disks, floppy, 'device is busy'
take floppy out of drive anyway, move to 'doze machine. Needless to say the file hasn't been copied to it.

Please point out to me the thing that I am doing incorrectly.
 
Old 02-21-2004, 03:27 AM   #8
verstapp
Member
 
Registered: Feb 2004
Location: canberra australia
Distribution: Suse 9.0
Posts: 44

Rep: Reputation: 15
hitesh>and then try to write a file to it...
try to write to it?!
It sounds as if you are having almost as much trouble as I am.
Just tried again -
insert disk
right-click on desktop
hover over Disks menu item, click on Floppy
Floppy icon appears on desktop
right-click on it, click Open
'floppy' window opens
right-click copy file in home window, right-click paste file in 'floppy' window
drive light goes on for a second
right-click on 'floppy' icon, eject, 'device is busy'
right-click on desktop, disks, floppy, 'device is busy'
take floppy out of drive anyway, move to 'doze machine. Needless to say the file hasn't been copied to it.

Please point out to me the thing that I am doing incorrectly.
 
Old 02-21-2004, 03:27 AM   #9
verstapp
Member
 
Registered: Feb 2004
Location: canberra australia
Distribution: Suse 9.0
Posts: 44

Rep: Reputation: 15
Sorry for five posts. The server was having problems keeping up - the administrators have decided that you can only post once every 22 seconds - and I'm afraid I hit the Send button more often than I should have. A Delete button next to the Edit and Quote buttons would have solved my problem.

Last edited by verstapp; 02-21-2004 at 04:46 AM.
 
Old 02-21-2004, 07:02 AM   #10
seidren
Member
 
Registered: May 2003
Distribution: Ubuntu, Windows XP
Posts: 90

Rep: Reputation: 16
If you are having trouble using your cd-writer, I stronly suggest that you give K3B a try !!! K3B is the best.

Anyway.... as you said....

Quote:
I find that Gnome's Go/CD Creator works almost as well as 'doze's right-click/send to/CDROM, but only when there's a blank CD in the drive, otherwise I get the old "...bailing out..."
This is common sense. If you have a cd in which you cannot write to then obviously you wont be able to write to it. You should insert a cd which is either fully blank, or one which can be appended to (multi session cd). Read the cdwriting howto at tldp for more info.

To use cdrecord, your cd should not be mounted. When you insert a cd, a program called autorun which runs in the background checks the drive and mounts it, if it can. Therefore even if a cd is multisession it will be mounted and you will not be able to write to it.

To solve this issue, I usually kill autorun, before I do any cd-writing business OR you can unmount your cd and then start writing.

To Kill Autorun:
The command 'ps ex' should list all the programs that are running. Get the process id and then enter the command 'kill <processid>'

All the cd-writing front-ends in linux use cdrecord or cdrdao as their backend. So this information applies to all of them.


About the floppy problem. I use mtools (mcopy, mdir etc...) I dont use the floppy very much so I am satisfied with the command line tools. Take a look at mtools. Its very easy. Works just like the dos commands but with an 'm' in from of it.


Happy burning !!!
 
Old 02-26-2004, 12:31 AM   #11
hiteshmaisheri
Member
 
Registered: Nov 2003
Location: Kerala, India
Distribution: Red Hat, Knoppix, Mandrake, FreeBSD
Posts: 231

Rep: Reputation: 30
this is for verstapp>
for mounting the flopppy in gui you have to right click on the desktop then clik on the disks there you wil find floppy... then whne u get the icon of floppy you have toi right clik on the icon and clik on mount to mount the floppy... after mounting it you can copy the files quite as normally ... after copying don't eject the floppy (manually)... just close all the window which are using the floppy drive and then right clik on the floppy icon on the desktop and clik on umount.... thereby copying the things on to the floppy.. to checkthat it has been copied... just mount the floppy again...
 
Old 03-14-2004, 07:22 AM   #12
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
hello im allso having a problem with the cdrecord command i have created a directory in which to store my wav files iv became root user and typed cdrecord -v dev=0,0,0 -audio *.wav the feedback i get from typing this is as followsCdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
TOC Type: 0 = CD-DA
scsidev: '0,0,0'
scsibus: 0 target: 0 lun: 0
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.7'
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.75-RH '@(#)scsi-linux-sg.c 1.75 02/10/21 Copyright
1997 J. Schilling').
atapi: 1
Device type : Removable CD-ROM
Version : 0
Response Format: 1
Vendor_info : 'ATAPI '
Identifikation : 'CD-RW 52XMax '
Revision : '150D'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO RAW/R96R
Drive buf size : 1658880 = 1620 KB
FIFO size : 4194304 = 4096 KB
cdrecord: Bad audio track size 35407872 for track 01.
cdrecord: Audio tracks must be at least 705600 bytes and a multiple of 2352.
cdrecord: See -pad option.
i would appreciate any help
 
Old 03-14-2004, 08:58 AM   #13
seidren
Member
 
Registered: May 2003
Distribution: Ubuntu, Windows XP
Posts: 90

Rep: Reputation: 16
The error message explains it all. The audio track should be a multiple of 2352 bytes and one or more of the audio files you want to burn is not. So you have to add the option -pad to the command and cdrecord will add zeros to the end of the audio file so that it becomes a mutliple of 2352 bytes. This will not affect the audio at all, except increase the length by about less than a second.

Just append -pad to the command and everything should work fine
 
Old 03-14-2004, 12:29 PM   #14
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
seidren i can not thank you enough it worked im now in full flow recording cds for every one thanks
 
Old 03-15-2004, 05:31 AM   #15
seidren
Member
 
Registered: May 2003
Distribution: Ubuntu, Windows XP
Posts: 90

Rep: Reputation: 16
Some more tips for your audio cd recording experience.

Try using normalize. It is a program that will change the volume level of the audio files so that they all sound at the same volume. This is very useful when burning cd with music files from different albums and they have totally different volume levels.

Also try using k3b. I think it is the best cd burning front end ever created.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrecord - Error trying to open /dev/scd0 exclusively... jeffreybluml Linux - Newbie 10 03-22-2004 06:43 PM
cdrecord not working - "cannot open /dev/pg1" ghambis Slackware 10 02-12-2004 05:11 PM
/dev/scd0 does not exist mrsolo Linux - Hardware 1 02-09-2004 09:30 PM
cdrecord problem - Cannot open '/dev/pg*' irvken Linux - Hardware 3 12-31-2003 02:59 AM
dev/scd0 error - audio doesnt play adhara Linux - Hardware 1 12-22-2003 05:19 PM


All times are GMT -5. The time now is 03:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration